projects
/
openwrt.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
sync with buildroot2 from uclibc
[openwrt.git]
/
openwrt
/
package
/
busybox
/
busybox.mk
diff --git
a/openwrt/package/busybox/busybox.mk
b/openwrt/package/busybox/busybox.mk
index
ae9abf1
..
e19aa7b
100644
(file)
--- a/
openwrt/package/busybox/busybox.mk
+++ b/
openwrt/package/busybox/busybox.mk
@@
-26,7
+26,7
@@
busybox-source: $(DL_DIR)/$(BUSYBOX_SOURCE) $(BUSYBOX_CONFIG)
$(BUSYBOX_DIR)/.unpacked: $(DL_DIR)/$(BUSYBOX_SOURCE)
$(BUSYBOX_UNZIP) $(DL_DIR)/$(BUSYBOX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
# Allow busybox patches.
$(BUSYBOX_DIR)/.unpacked: $(DL_DIR)/$(BUSYBOX_SOURCE)
$(BUSYBOX_UNZIP) $(DL_DIR)/$(BUSYBOX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
# Allow busybox patches.
- toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox
busybox-\*.patch
+ toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox
/patches
touch $(BUSYBOX_DIR)/.unpacked
$(BUSYBOX_DIR)/.configured: $(BUSYBOX_DIR)/.unpacked $(BUSYBOX_CONFIG)
touch $(BUSYBOX_DIR)/.unpacked
$(BUSYBOX_DIR)/.configured: $(BUSYBOX_DIR)/.unpacked $(BUSYBOX_CONFIG)
@@
-60,3
+60,12
@@
busybox-clean:
busybox-dirclean:
rm -rf $(BUSYBOX_DIR)
busybox-dirclean:
rm -rf $(BUSYBOX_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_BUSYBOX)),y)
+TARGETS+=busybox
+endif
This page took
0.023767 seconds
and
4
git commands to generate.