bugfix
[openwrt.git] / openwrt / package / ebtables / ebtables.mk
index b28e86c..e7982ca 100644 (file)
@@ -3,7 +3,7 @@
 # ebtables
 #
 #############################################################
-#
+
 EBTABLES_SOURCE_URL=http://umn.dl.sourceforge.net/sourceforge/ebtables/
 EBTABLES_SOURCE=ebtables-v2.0.6.tar.gz
 EBTABLES_BUILD_DIR=$(BUILD_DIR)/ebtables-v2.0.6
@@ -25,7 +25,7 @@ $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY): $(EBTABLES_BUILD_DIR)/ebtables
        cp -af $(EBTABLES_BUILD_DIR)/ebtables $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
        $(STRIP) $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
 
-ebtables: linux $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
+ebtables: $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
 
 ebtables-source: $(DL_DIR)/$(EBTABLES_SOURCE)
 
@@ -35,3 +35,7 @@ ebtables-clean:
 
 ebtables-dirclean:
        rm -rf $(EBTABLES_BUILD_DIR)
+
+ifeq ($(strip $(BR2_PACKAGE_EBTABLES)),y)
+TARGETS+=ebtables
+endif
This page took 0.020943 seconds and 4 git commands to generate.