From b75b8c4a3c73ba71a98071cbab333cf5ce1d0e0b Mon Sep 17 00:00:00 2001 From: wbx Date: Fri, 15 Jul 2005 16:44:34 +0000 Subject: [PATCH] updated example Makefile and descriptions git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1443 3c298f89-4303-0410-b956-a3cf2f4a3e73 --- docs/buildroot-documentation.html | 182 +++++++++++++----------------- 1 file changed, 81 insertions(+), 101 deletions(-) diff --git a/docs/buildroot-documentation.html b/docs/buildroot-documentation.html index 36f294e60..85cce4780 100644 --- a/docs/buildroot-documentation.html +++ b/docs/buildroot-documentation.html @@ -452,31 +452,31 @@ foo-compile: bar-compile

Finally, here's the hardest part. Create a file named Makefile. It will contain the Makefile rules that are in charge of downloading, configuring, compiling and installing - the software. Below is an example that we will comment - afterwards.

+ the software. Below is an example that we will comment afterwards.

      1  # $Id$
-     2  include $(TOPDIR)/rules.mk
-     3  PKG_NAME:=foo
-     4  PKG_VERSION:=1.0
-     5  PKG_RELEASE:=1
-     6  PKG_MD5SUM:=4584f226523776a3cdd2fb6f8212ba8d
-     8  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-     9  PKG_SOURCE_URL:=http://www.foosoftware.org/downloads
-    10  PKG_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-    11  PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-    12  PKG_IPK_DIR:=$(PKG_DIR)/ipkg
-    13
-    14  $(DL_DIR)/$(PKG_SOURCE):
-    15          $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+     2	
+     3  include $(TOPDIR)/rules.mk
+     4
+     5  PKG_NAME:=foo
+     6  PKG_VERSION:=1.0
+     7  PKG_RELEASE:=1
+     8  PKG_MD5SUM:=4584f226523776a3cdd2fb6f8212ba8d
+     9 
+    10  PKG_SOURCE_URL:=http://www.foosoftware.org/downloads
+    11  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+    12 	PKG_CAT:=zcat
+    13	
+    14	PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+    15	PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
     16
-    17  $(PKG_DIR)/.source: $(DL_DIR)/$(PKG_SOURCE)
-    18          zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-    19          touch $(PKG_DIR)/.source
+    17	include $(TOPDIR)/package/rules.mk
+    18
+    19	$(eval $(call PKG_template,FOO,foo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
     20
-    21  $(PKG_DIR)/.configured: $(PKG_DIR)/.source
-    22          (cd $(PKG_DIR); \
+    21  $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+    22          (cd $(PKG_BUILD_DIR); \
     23                  $(TARGET_CONFIGURE_OPTS) \
     24                  CFLAGS="$(TARGET_CFLAGS)" \
     25                  ./configure \
@@ -485,36 +485,37 @@ foo-compile: bar-compile
     28                  --build=$(GNU_HOST_NAME) \
     29                  --prefix=/usr \
     30                  --sysconfdir=/etc \
-    31          );
-    32          touch $(PKG_DIR)/.configured;
-    33
-    34  $(PKG_DIR)/$(PKG_NAME): $(PKG_DIR)/.configured
-    35          $(MAKE) CC=$(TARGET_CC) -C $(PKG_DIR)
-    36
-    37  $(PKG_IPK): $(PKG_DIR)/$(PKG_NAME)
-    38		$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-    39          $(MAKE) prefix=$(PKG_IPK_DIR)/usr -C $(PKG_DIR) install
-    40          rm -Rf $(PKG_IPK_DIR)/usr/man
-    41  	$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-    42
-    43  $(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)  
-    44  	$(IPKG) install $(PKG_IPK) 
-    45  
-    46  prepare: $(PKG_DIR)/.source
-    47  compile: $(PKG_IPK)
-    48  install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-    49  clean:
-    50  	rm -rf $(PKG_DIR)
-    51		rm -f $(PKG_IPK)
+    31 			--with-bar="$(STAGING_DIR)/usr" \
+    32          );
+    33          touch $@
+    34
+    35  $(PKG_BUILD_DIR)/.built:
+    36      	rm -rf $(PKG_INSTALL_DIR)
+    37		mkdir -p $(PKG_INSTALL_DIR)
+    38		$(MAKE) -C $(PKG_BUILD_DIR) \
+    39 	          $(TARGET_CONFIGURE_OPTS) \
+    40            install_prefix="$(PKG_INSTALL_DIR)" \
+    41 	          all install
+    42		touch $@
+    43 
+    44  $(IPKG_FOO):
+    46		install -d -m0755 $(IDIR_FOO)/usr/sbin
+    47    	cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/foo $(IDIR_FOO)/usr/sbin
+    49		$(RSTRIP) $(IDIR_FOO)
+    50		$(IPKG_BUILD) $(IDIR_FOO) $(PACKAGE_DIR)
+    51	
+    52	mostlyclean:
+    53  	make -C $(PKG_BUILD_DIR) clean
+    54    	rm $(PKG_BUILD_DIR)/.built
 

First of all, this Makefile example works for a single binary software. For other software such as libraries or more complex stuff with multiple binaries, it should be adapted. Look at - the other Makefile files in the package + the other Makefile files in the package/ directory.

-

At lines 3-12, a couple of useful variables are defined :

+

At lines 5-15, a couple of useful variables are defined:

-

Lines 14-15 defines a target that downloads the tarball from - the remote site to the download directory - (DL_DIR).

- -

Lines 17-19 defines a target and associated rules that - uncompress the downloaded tarball. As you can see, this target - depends on the tarball file, so that the previous target (line - 14-15) is called before executing the rules of the current - target. Uncompressing is followed by touching a hidden file - to mark the software has having been uncompressed. This trick is - used everywhere in Buildroot Makefile to split steps - (download, uncompress, configure, compile, install) while still - having correct dependencies.

- -

Lines 21-32 defines a target and associated rules that +

In Line 3 and 17 we include common variables and routines to simplify + the process of ipkg creation. It includes routines to download, verify + and extract the software package archives.

+ +

Line 19 contains the magic line which automatically creates the + ipkg for us.

+ +

Lines 21-33 defines a target and associated rules that configures the software. It depends on the previous target (the - hidden .source file) so that we are sure the software has + hidden .prepared file) so that we are sure the software has been uncompressed. In order to configure it, it basically runs the well-known ./configurescript. As we may be doing cross-compilation, target, host and @@ -571,41 +569,21 @@ foo-compile: bar-compile filesystem. Finally it creates a .configured file to mark the software as configured.

-

Lines 34-35 defines a target and a rule that compiles the +

Lines 35-42 defines a target and a rule that compiles the software. This target will create the binary file in the compilation directory, and depends on the software being already configured (hence the reference to the .configured - file). It basically runs make inside the source - directory.

- -

Lines 37-41 defines a target and associated rules that create - the ipkg package which can optionally be embedded into - the resulting firmware image. It depends on the binary file in - the source directory, to make sure the software has been compiled. - It uses the make-ipkg-dir.sh script, which will create the ipkg - build directory for your package, copy your control file into - that directory and add version and architecture information. - Then it calls the install target of the - software Makefile by passing a prefix - argument, so that the Makefile doesn't try to install - the software inside host /usr but inside target - /usr. After the installation, the - /usr/man directory inside the target filesystem is - removed to save space. + file). Afterwards it installs the resulting binary into the + PKG_INSTALL_DIR. It basically runs + make install inside the source directory.

+ +

Lines 44-50 defines a target and associated rules that create + the ipkg package, which can optionally be embedded into + the resulting firmware image. It manually installs all files you + want to integrate in your resulting ipkg. RSTRIP will + recursevily strip all binaries and libraries. Finally IPKG_BUILD is called to create the package.

-

Line 43 and 44 define the installation target of your package, - which will embed the software into the target filesystem.

- -

Lines 46-51 define the main targets that the Makefile in the - package dir calls. -

-

Conclusion

As you can see, adding a software to buildroot is simply a @@ -614,12 +592,14 @@ foo-compile: bar-compile the software.

If you package software that might be useful for other persons, - don't forget to send a patch to OpenWrt developers !

+ don't forget to send a patch to OpenWrt developers! + Use the mail address: patches@openwrt.org +

Resources

-

To learn more about OpenWrt Buildroot you can visit this - website: http://openwrt.org/

+

To learn more about OpenWrt you can visit this website: + http://openwrt.org/

-- 2.20.1