moved db_user calls from includes to actual script, buggy when included from navigation
[iserv-mod-room-reservation.git] / debian / rules
1 #!/usr/bin/make -f
2 # rules for debuild
3
4 # needed for lintian
5 build:
6 dh_testdir
7 rm -f dirs files
8
9 binary-indep:
10 [ ! -f Makefile ] || $(MAKE) clean
11 dh_clean
12
13 dh_testdir
14 dh_testroot
15 dh_clean -k
16 dh_installdirs
17 $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-mod-room-reservation install
18
19 # we rather install the documentation via dh_installdocs
20 rm -rf $(CURDIR)/debian/iserv-mod-room-reservation/usr/share/doc/iserv-mod-room-reservation
21 dh_testdir
22 dh_testroot
23 dh_installchangelogs
24 dh_installdocs doc/changelog.old.html doc/TODO doc/source/
25 #dh_installexamples
26 ##dh_install
27 ##dh_installmenu
28 ##dh_installdebconf
29 ##dh_installlogrotate
30 ##dh_installemacsen
31 ##dh_installpam
32 ##dh_installmime
33 ##dh_python
34 #dh_installinit
35 #dh_installcron
36 #dh_installinfo
37 #dh_installman
38 #dh_link
39 #dh_strip
40 dh_compress
41 dh_fixperms
42 ##dh_perl
43 ##dh_makeshlibs
44 dh_installdeb
45 #dh_shlibdeps
46 dh_gencontrol
47 dh_md5sums
48 dh_builddeb
49 rm -rf $(CURDIR)/debian/iserv-mod-room-reservation
50
51 # needed for lintian
52 binary-arch:
53
54 binary: binary-indep
55
56 clean:
57 dh_testdir
58 dh_testroot
59 [ ! -f Makefile ] || $(MAKE) clean
60 dh_clean
61
62 .PHONY: build clean binary-indep binary install
63
This page took 0.049966 seconds and 5 git commands to generate.