Port kmod-gre to the new module layout
[openwrt.git] / package / kernel / modules.mk
index 51b7d8a..c24de60 100644 (file)
@@ -281,6 +281,21 @@ KCONFIG:=$(CONFIG_BRIDGE_NF_EBTABLES)
 endef
 $(eval $(call KernelPackage,ebtables))
 
+define KernelPackage/ipv6
+TITLE:=IPv6 support
+DESCRIPTION:=Kernel modules for IPv6 support
+KCONFIG:=$(CONFIG_IPV6)
+FILES:=$(MODULES_DIR)/kernel/net/ipv6/ipv6.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,ipv6))
+
+define KernelPackage/gre
+TITLE:=GRE support
+DESCRIPTION:=Generic Routing Encapsulation support
+KCONFIG=$(CONFIG_NET_IPGRE)
+FILES=$(MODULES_DIR)/kernel/net/ipv4/ip_gre.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,gre))
 
 define KernelPackage/ppp
 TITLE:=PPP modules
This page took 0.02076 seconds and 4 git commands to generate.