From 01bb8daf87c27cd6c0addc083fcc5de5a55aa18b Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 24 Apr 2009 01:18:49 +0000
Subject: [PATCH] optimize tools/ directory build order to improve parallel
 building performance

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15365 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 tools/Makefile | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/tools/Makefile b/tools/Makefile
index 72a25b5b0..54520bc75 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,11 +9,14 @@
 curdir:=tools
 
 # subdirectories to descend into
-tools-y := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake bison quilt yaffs2
+tools-y :=
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
+tools-y += m4 autoconf automake bison pkg-config sed
+tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2
 
 tools-$(CONFIG_CCACHE) += ccache
 tools-$(CONFIG_powerpc) += dtc
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
-- 
2.20.1