From 0206267d8c6d6a33a8a8a760556dbdccfa720bc8 Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 20 Oct 2005 05:41:23 +0000
Subject: [PATCH] add AX25 support (thanks to Michael Conrad)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2189 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/Config.in                 |  8 ++++++++
 target/linux/control/kmod-ax25.control |  6 ++++++
 target/linux/linux-2.4/Makefile        |  6 +++++-
 target/linux/linux-2.4/config/brcm     | 25 ++++++++++++++++++++++++-
 target/linux/linux-2.4/config/soekris  | 22 +++++++++++++++++++++-
 5 files changed, 64 insertions(+), 3 deletions(-)
 create mode 100644 target/linux/control/kmod-ax25.control

diff --git a/target/linux/Config.in b/target/linux/Config.in
index f59ba787a..69f96c48d 100644
--- a/target/linux/Config.in
+++ b/target/linux/Config.in
@@ -130,6 +130,14 @@ config BR2_PACKAGE_KMOD_IPTABLES_V4
 	help
 	  Kernel modules for IPv4 firewalling
 
+config BR2_PACKAGE_KMOD_AX25
+	tristate "AX25 support"
+	default m
+	help
+	  Kernel modules for AX25 protocol family
+	   - ax25.o: AX25 layer 2 support
+	   - mkiss.o: AX25 KISS driver
+
 config BR2_PACKAGE_KMOD_IPTABLES_V4_EXTRA
 	tristate "Extra modules for iptables"
 	default m
diff --git a/target/linux/control/kmod-ax25.control b/target/linux/control/kmod-ax25.control
new file mode 100644
index 000000000..c080d4585
--- /dev/null
+++ b/target/linux/control/kmod-ax25.control
@@ -0,0 +1,6 @@
+Package: kmod-ax25
+Priority: optional
+Section: net
+Maintainer: Michael Conrad <openwrt@friggleware.net>
+Source: buildroot internal
+Description: Kernel AX25 driver
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index 9c56a0b2b..ede1e7a98 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -193,6 +193,10 @@ $(eval $(call KMOD_template,VIDEODEV,videodev,\
 $(eval $(call KMOD_template,PWC,pwc,\
 	$(MODULES_DIR)/kernel/drivers/usb/pwc.o \
 ,CONFIG_USB_PWC))
+$(eval $(call KMOD_template,AX25,ax25,\
+	$(MODULES_DIR)/kernel/net/ax25/ax25.o \
+	$(MODULES_DIR)/kernel/drivers/net/hamradio/mkiss.o \
+,CONFIG_AX25))
 
 $(TARGETS): $(PACKAGE_DIR)
 
@@ -230,7 +234,7 @@ $(LINUX_DIR)/vmlinux: $(LINUX_DIR)/.depend_done
 $(LINUX_KERNEL): $(LINUX_DIR)/vmlinux
 	$(TARGET_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $< $@ 
 	touch -c $(LINUX_KERNEL)
-	
+
 $(LINUX_DIR)/.modules_done: $(LINUX_KERNEL) $(LINUX_IMAGE)
 	rm -rf $(LINUX_BUILD_DIR)/modules
 	$(MAKE) -C $(LINUX_DIR) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) modules
diff --git a/target/linux/linux-2.4/config/brcm b/target/linux/linux-2.4/config/brcm
index 871cbdc6a..f970cfe82 100644
--- a/target/linux/linux-2.4/config/brcm
+++ b/target/linux/linux-2.4/config/brcm
@@ -849,7 +849,30 @@ CONFIG_SHAPER=m
 #
 # Amateur Radio support
 #
-# CONFIG_HAMRADIO is not set
+#
+# Amateur Radio support
+#
+CONFIG_HAMRADIO=y
+CONFIG_AX25=m
+# CONFIG_AX25_DAMA_SLAVE is not set
+# CONFIG_NETROM is not set
+# CONFIG_ROSE is not set
+
+#
+# AX.25 network device drivers
+#
+CONFIG_MKISS=m
+# CONFIG_6PACK is not set
+# CONFIG_BPQETHER is not set
+# CONFIG_DMASCC is not set
+# CONFIG_SCC is not set
+# CONFIG_BAYCOM_SER_FDX is not set
+# CONFIG_BAYCOM_SER_HDX is not set
+# CONFIG_BAYCOM_PAR is not set
+# CONFIG_BAYCOM_EPP is not set
+# CONFIG_SOUNDMODEM is not set
+# CONFIG_YAM is not set
+
 
 #
 # IrDA (infrared) support
diff --git a/target/linux/linux-2.4/config/soekris b/target/linux/linux-2.4/config/soekris
index a3d9286a7..92892b180 100644
--- a/target/linux/linux-2.4/config/soekris
+++ b/target/linux/linux-2.4/config/soekris
@@ -807,7 +807,27 @@ CONFIG_NET_PCMCIA=y
 #
 # Amateur Radio support
 #
-# CONFIG_HAMRADIO is not set
+CONFIG_HAMRADIO=y
+CONFIG_AX25=m
+# CONFIG_AX25_DAMA_SLAVE is not set
+# CONFIG_NETROM is not set
+# CONFIG_ROSE is not set
+
+#
+# AX.25 network device drivers
+#
+CONFIG_MKISS=m
+# CONFIG_6PACK is not set
+# CONFIG_BPQETHER is not set
+# CONFIG_DMASCC is not set
+# CONFIG_SCC is not set
+# CONFIG_BAYCOM_SER_FDX is not set
+# CONFIG_BAYCOM_SER_HDX is not set
+# CONFIG_BAYCOM_PAR is not set
+# CONFIG_BAYCOM_EPP is not set
+# CONFIG_SOUNDMODEM is not set
+# CONFIG_YAM is not set
+
 
 #
 # IrDA (infrared) support
-- 
2.20.1