From 0b26a8784780991bb3134985491ef638c37e2c3b Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 17 Oct 2005 22:19:21 +0000
Subject: [PATCH] change icecast to use libvorbisidec instead of
 libogg/libvorbis (thanks to David Collet)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2156 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/Config.in                             |   2 +-
 package/Makefile                              |   2 +-
 package/icecast/Config.in                     |   6 +-
 package/icecast/ipkg/icecast.control          |   2 +-
 .../patches/01-icecast-2.3.0-tremor.patch     | 153 ++++++++++++++++++
 package/libogg/Config.in                      |   2 +-
 package/libvorbis/Config.in                   |   2 +-
 7 files changed, 160 insertions(+), 9 deletions(-)
 create mode 100644 package/icecast/patches/01-icecast-2.3.0-tremor.patch

diff --git a/package/Config.in b/package/Config.in
index e466dcd90..c52697a26 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -155,7 +155,6 @@ source "package/gnutls/Config.in" ## libgnutls
 source "package/libgpg-error/Config.in"
 source "package/libid3tag/Config.in"
 source "package/jpeg/Config.in"  # libjpeg
-source "package/libogg/Config.in"
 source "package/libtool/Config.in"  # libltdl
 source "package/lzo/Config.in"  # liblzo
 source "package/libmad/Config.in"
@@ -164,6 +163,7 @@ source "package/mysql/Config.in"  # limysqlclient
 source "package/ncurses/Config.in"  # libncurses
 source "package/libnet/Config.in"
 source "package/libnids/Config.in"
+source "package/libogg/Config.in"
 source "package/opencdk/Config.in"  # libopencdk
 source "package/openldap/Config.in"  # libopenldap
 source "package/openssl/Config.in"  # libopenssl
diff --git a/package/Makefile b/package/Makefile
index 2d02d3d77..62ed32602 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -231,7 +231,7 @@ fprobe-compile: libpcap-compile
 gdbserver-compile: ncurses-compile
 gmediaserver-compile: id3lib-compile libupnp-compile
 gnutls-compile: libgcrypt-compile opencdk-compile libtasn1-compile
-icecast-compile: curl-compile libogg-compile libvorbis-compile libxml2-compile libxslt-compile
+icecast-compile: curl-compile libvorbisidec-compile libxml2-compile libxslt-compile
 id3lib-compile: uclibc++-compile zlib-compile
 irssi-compile: glib-compile ncurses-compile
 iptraf-compile: ncurses-compile
diff --git a/package/icecast/Config.in b/package/icecast/Config.in
index e16b1f0f6..5252c8c8d 100644
--- a/package/icecast/Config.in
+++ b/package/icecast/Config.in
@@ -2,8 +2,7 @@ config BR2_PACKAGE_ICECAST
 	tristate "icecast - A streaming media server for Ogg/Vorbis and MP3 audio streams"
 	default m if CONFIG_DEVEL
 	select BR2_PACKAGE_LIBCURL
-	select BR2_PACKAGE_LIBOGG
-	select BR2_PACKAGE_LIBVORBIS
+	select BR2_PACKAGE_LIBVORBISIDEC
 	select BR2_PACKAGE_LIBXML2
 	select BR2_PACKAGE_LIBXSLT
 	help
@@ -18,8 +17,7 @@ config BR2_PACKAGE_ICECAST
 	  
 	  Depends:
 	   * libcurl
-	   * libogg
-	   * libvorbis
+	   * libvorbisidec
 	   * libxml2
 	   * libxslt
 	  
diff --git a/package/icecast/ipkg/icecast.control b/package/icecast/ipkg/icecast.control
index 803435971..f52dbbd08 100644
--- a/package/icecast/ipkg/icecast.control
+++ b/package/icecast/ipkg/icecast.control
@@ -3,5 +3,5 @@ Priority: optional
 Section: net
 Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/icecast/
-Depends: libcurl, libogg, libvorbis, libpthread, libxml2, libxslt
+Depends: libcurl, libvorbisidec, libpthread, libxml2, libxslt
 Description: A streaming media server
diff --git a/package/icecast/patches/01-icecast-2.3.0-tremor.patch b/package/icecast/patches/01-icecast-2.3.0-tremor.patch
new file mode 100644
index 000000000..ed170846f
--- /dev/null
+++ b/package/icecast/patches/01-icecast-2.3.0-tremor.patch
@@ -0,0 +1,153 @@
+diff -rNu icecast-2.3.0.old/configure icecast-2.3.0.new/configure
+--- icecast-2.3.0.old/configure	2005-09-24 07:18:46.000000000 +1000
++++ icecast-2.3.0.new/configure	2005-10-07 22:08:29.000000000 +1000
+@@ -21967,7 +21967,7 @@
+ if test "${xt_cv_lib_ogg+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  OGG_LIBS="-logg"
++  OGG_LIBS="-lvorbisidec"
+ 
+ #
+ # check if the installed Ogg is sufficiently new.
+@@ -22033,7 +22033,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h.  */
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ int
+ main ()
+ {
+@@ -22188,9 +22188,9 @@
+ 
+ fi
+ 
+-VORBIS_LIBS="-lvorbis"
+-VORBISFILE_LIBS="-lvorbisfile"
+-VORBISENC_LIBS="-lvorbisenc"
++VORBIS_LIBS="-lvorbisidec"
++VORBISFILE_LIBS="-lvorbisidec"
++VORBISENC_LIBS="-lvorbisidec"
+ 
+ xt_save_LIBS="$LIBS"
+ xt_save_LDFLAGS="$LDFLAGS"
+@@ -22327,17 +22327,18 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h.  */
+ 
+-#include <vorbis/codec.h>
+-#include <vorbis/vorbisenc.h>
++#include <tremor/ivorbiscodec.h>
+ 
+ 
+ int
+ main ()
+ {
++/*
+ if ((struct ovectl_ratemanage_arg *) 0)
+   return 0;
+ if (sizeof (struct ovectl_ratemanage_arg))
+   return 0;
++*/
+   ;
+   return 0;
+ }
+diff -rNu icecast-2.3.0.old/src/format_flac.c icecast-2.3.0.new/src/format_flac.c
+--- icecast-2.3.0.old/src/format_flac.c	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_flac.c	2005-10-07 22:10:24.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ 
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <string.h>
+ 
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_midi.c icecast-2.3.0.new/src/format_midi.c
+--- icecast-2.3.0.old/src/format_midi.c	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_midi.c	2005-10-07 22:10:12.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ 
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <string.h>
+ 
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_ogg.c icecast-2.3.0.new/src/format_ogg.c
+--- icecast-2.3.0.old/src/format_ogg.c	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_ogg.c	2005-10-07 22:10:02.000000000 +1000
+@@ -24,7 +24,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ 
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ 
+ #include "refbuf.h"
+ #include "source.h"
+diff -rNu icecast-2.3.0.old/src/format_ogg.h icecast-2.3.0.new/src/format_ogg.h
+--- icecast-2.3.0.old/src/format_ogg.h	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_ogg.h	2005-10-07 22:09:51.000000000 +1000
+@@ -18,7 +18,7 @@
+ #ifndef __FORMAT_OGG_H__
+ #define __FORMAT_OGG_H__
+ 
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include "refbuf.h"
+ #include "format.h"
+ 
+diff -rNu icecast-2.3.0.old/src/format_speex.c icecast-2.3.0.new/src/format_speex.c
+--- icecast-2.3.0.old/src/format_speex.c	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_speex.c	2005-10-07 22:09:44.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ 
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <speex/speex_header.h>
+ 
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_theora.c icecast-2.3.0.new/src/format_theora.c
+--- icecast-2.3.0.old/src/format_theora.c	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_theora.c	2005-10-07 22:09:38.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ 
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <theora/theora.h>
+ 
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_vorbis.c icecast-2.3.0.new/src/format_vorbis.c
+--- icecast-2.3.0.old/src/format_vorbis.c	2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_vorbis.c	2005-10-07 22:09:29.000000000 +1000
+@@ -18,8 +18,8 @@
+ #endif
+ 
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
+-#include <vorbis/codec.h>
++#include <tremor/ogg.h>
++#include <tremor/ivorbiscodec.h>
+ #include <memory.h>
+ #include <string.h>
+ 
+diff -rNu icecast-2.3.0.old/src/source.c icecast-2.3.0.new/src/source.c
+--- icecast-2.3.0.old/src/source.c	2005-09-23 06:19:28.000000000 +1000
++++ icecast-2.3.0.new/src/source.c	2005-10-07 22:09:17.000000000 +1000
+@@ -19,7 +19,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <errno.h>
+ 
+ #ifndef _WIN32
diff --git a/package/libogg/Config.in b/package/libogg/Config.in
index 38213a5cc..98632ddb5 100644
--- a/package/libogg/Config.in
+++ b/package/libogg/Config.in
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBOGG
 	tristate "libogg - The Ogg bitstream handling library"
-	default m if CONFIG_DEVEL
+	default n
 	help
 	  The Ogg bitstream handling library.
 	  
diff --git a/package/libvorbis/Config.in b/package/libvorbis/Config.in
index ab93bd392..67c5cabd1 100644
--- a/package/libvorbis/Config.in
+++ b/package/libvorbis/Config.in
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBVORBIS
 	tristate "libvorbis - The Vorbis General Audio Compression Codec library"
-	default m if CONFIG_DEVEL
+	default n
 	select BR2_PACKAGE_LIBOGG
 	help
 	  The Vorbis General Audio Compression Codec library.
-- 
2.20.1