From 0ee891fb2b29965a4735eb25cd4f2689c988702d Mon Sep 17 00:00:00 2001
From: juhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 8 Sep 2009 07:25:20 +0000
Subject: [PATCH] add menuconfig option for enabling debugfs support in the
 kernel

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17540 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 Config.in                  | 10 ++++++++++
 include/kernel-defaults.mk |  1 +
 2 files changed, 11 insertions(+)

diff --git a/Config.in b/Config.in
index 699c68940..e03cf03af 100644
--- a/Config.in
+++ b/Config.in
@@ -195,6 +195,7 @@ config KERNEL_KALLSYMS
 	default n
 	help
 		This will give you more information in stack traces from kernel oopses
+
 config KERNEL_PROFILING
 	bool "Compile the kernel with profiling enabled"
 	default n
@@ -202,6 +203,15 @@ config KERNEL_PROFILING
 		Enable the extended profiling support mechanisms used by profilers such
 		as OProfile.
 
+config KERNEL_DEBUG_FS
+	bool "Compile the kernel with Debug Filesystem enabled"
+	depends LINUX_2_6
+	default y
+	help
+		debugfs is a virtual file system that kernel developers use to put
+		debugging files into. Enable this option to be able to read and
+		write to these files.
+
 endmenu
 
 menuconfig DEVEL
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 4266157d2..cf3eb3105 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -97,6 +97,7 @@ define Kernel/Configure/Default
 	$(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
 	echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
 	echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target
+	echo "$(if $(CONFIG_KERNEL_DEBUG_FS),CONFIG_DEBUG_FS=y,# CONFIG_DEBUG_FS is not set)" >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
 	echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
-- 
2.20.1