From 12142a2b5d946082d69c44067b12d0e4dc2c5878 Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 14 Aug 2005 16:15:37 +0000
Subject: [PATCH] add changes from whiterussian

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1665 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/base-files/Makefile                  |  8 ++++----
 openwrt/package/base-files/ipkg/base-files.conffiles | 10 ++++++++++
 2 files changed, 14 insertions(+), 4 deletions(-)
 create mode 100644 openwrt/package/base-files/ipkg/base-files.conffiles

diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index e2c47b51c..f0394f84b 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
 
 include $(TOPDIR)/package/rules.mk
@@ -50,9 +50,9 @@ $(IPKG_BASE):
 $(IPKG_LIBC):
 	$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBC) ipkg/uclibc.control $(LIBC_VERSION)-$(PKG_RELEASE) $(ARCH)
 	mkdir -p $(IDIR_LIBC)/lib
-	cp -a $(STAGING_DIR)/lib/ld-uClibc*.so* $(IDIR_LIBC)/lib/
+	cp -fpR $(STAGING_DIR)/lib/ld-uClibc*.so.* $(IDIR_LIBC)/lib/
 	for file in c crypt dl m nsl resolv rt uClibc util; do \
-		cp -a $(STAGING_DIR)/lib/lib$$file*.so* $(IDIR_LIBC)/lib/; \
+		cp -fpR $(STAGING_DIR)/lib/lib$$file*.so.* $(IDIR_LIBC)/lib/; \
 	done
 	-$(STRIP) $(IDIR_LIBC)/lib/*
 	$(IPKG_BUILD) $(IDIR_LIBC) $(PACKAGE_DIR)
@@ -60,7 +60,7 @@ $(IPKG_LIBC):
 $(IPKG_GCC):
 	$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_GCC) ipkg/libgcc.control $(GCC_VERSION)-$(PKG_RELEASE) $(ARCH)
 	mkdir -p $(IDIR_GCC)/lib
-	cp -a $(STAGING_DIR)/lib/libgcc*.so* $(IDIR_GCC)/lib/
+	cp -fpR $(STAGING_DIR)/lib/libgcc*.so.* $(IDIR_GCC)/lib/
 	-$(STRIP) $(IDIR_GCC)/lib/*
 	$(IPKG_BUILD) $(IDIR_GCC) $(PACKAGE_DIR)
 
diff --git a/openwrt/package/base-files/ipkg/base-files.conffiles b/openwrt/package/base-files/ipkg/base-files.conffiles
new file mode 100644
index 000000000..ec83db41b
--- /dev/null
+++ b/openwrt/package/base-files/ipkg/base-files.conffiles
@@ -0,0 +1,10 @@
+/etc/config/network
+/etc/firewall.user
+/etc/group
+/etc/hosts
+/etc/ipkg.conf
+/etc/modules
+/etc/passwd
+/etc/profile
+/etc/protocols
+/etc/sysctl.conf
-- 
2.20.1