From 13a779d3f3a91f0f029990ac96a7607aa24f6fe6 Mon Sep 17 00:00:00 2001
From: hauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 22 Jul 2011 16:04:25 +0000
Subject: [PATCH] kernel: update to linux-3.0 and refresh patches.

Thank you Peter Wagner for the patch


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27722 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/kernel-version.mk                     |  3 ++
 .../022-USB-Add-ehci-ssb-driver.patch         |  6 ++--
 .../patches-3.0/023-usb_ehci_ohci.patch       |  4 +--
 .../patches-3.0/240-ssb_no_sprom_on_pci.patch | 28 -------------------
 .../generic/patches-3.0/020-ssb_update.patch  |  8 ++++--
 .../patches-3.0/650-pppoe_header_pad.patch    |  4 +--
 .../generic/patches-3.0/721-phy_packets.patch |  2 +-
 .../generic/patches-3.0/950-vm_exports.patch  |  2 +-
 .../patches-3.0/999-drop_sublevel.patch       |  2 +-
 9 files changed, 18 insertions(+), 41 deletions(-)
 delete mode 100644 target/linux/brcm47xx/patches-3.0/240-ssb_no_sprom_on_pci.patch

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 66fb021ed..4fd3207a7 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -29,6 +29,9 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.2)
   LINUX_KERNEL_MD5SUM:=51be93d92028658ec93f68b79a378b17
 endif
+ifeq ($(LINUX_VERSION),3.0)
+  LINUX_KERNEL_MD5SUM:=398e95866794def22b12dfbc15ce89c0
+endif
 
 # disable the md5sum check for unknown kernel versions
 LINUX_KERNEL_MD5SUM?=x
diff --git a/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch b/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
index 4ae8ca4a8..d236fcbbb 100644
--- a/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
+++ b/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
@@ -22,7 +22,7 @@
  	depends on USB
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1282,9 +1282,14 @@ MODULE_LICENSE ("GPL");
+@@ -1286,9 +1286,14 @@ MODULE_LICENSE ("GPL");
  #define PLATFORM_DRIVER		ehci_grlib_driver
  #endif
  
@@ -38,7 +38,7 @@
  #error "missing bus glue for ehci-hcd"
  #endif
  
-@@ -1344,10 +1349,20 @@ static int __init ehci_hcd_init(void)
+@@ -1348,10 +1353,20 @@ static int __init ehci_hcd_init(void)
  	if (retval < 0)
  		goto clean4;
  #endif
@@ -60,7 +60,7 @@
  clean4:
  #endif
  #ifdef OF_PLATFORM_DRIVER
-@@ -1378,6 +1393,9 @@ module_init(ehci_hcd_init);
+@@ -1382,6 +1397,9 @@ module_init(ehci_hcd_init);
  
  static void __exit ehci_hcd_cleanup(void)
  {
diff --git a/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch b/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
index d975302e6..a3ec2b70d 100644
--- a/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
+++ b/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
@@ -152,7 +152,7 @@
 +#endif
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1350,17 +1350,21 @@ static int __init ehci_hcd_init(void)
+@@ -1354,17 +1354,21 @@ static int __init ehci_hcd_init(void)
  		goto clean4;
  #endif
  
@@ -174,7 +174,7 @@
  #ifdef XILINX_OF_PLATFORM_DRIVER
  	platform_driver_unregister(&XILINX_OF_PLATFORM_DRIVER);
  clean4:
-@@ -1393,9 +1397,11 @@ module_init(ehci_hcd_init);
+@@ -1397,9 +1401,11 @@ module_init(ehci_hcd_init);
  
  static void __exit ehci_hcd_cleanup(void)
  {
diff --git a/target/linux/brcm47xx/patches-3.0/240-ssb_no_sprom_on_pci.patch b/target/linux/brcm47xx/patches-3.0/240-ssb_no_sprom_on_pci.patch
deleted file mode 100644
index 52c8fe95f..000000000
--- a/target/linux/brcm47xx/patches-3.0/240-ssb_no_sprom_on_pci.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/drivers/ssb/driver_pcicore.c
-+++ b/drivers/ssb/driver_pcicore.c
-@@ -412,16 +412,6 @@ static int __devinit pcicore_is_in_hostm
-  * Workarounds.
-  **************************************************/
- 
--static void __devinit ssb_pcicore_fix_sprom_core_index(struct ssb_pcicore *pc)
--{
--	u16 tmp = pcicore_read16(pc, SSB_PCICORE_SPROM(0));
--	if (((tmp & 0xF000) >> 12) != pc->dev->core_index) {
--		tmp &= ~0xF000;
--		tmp |= (pc->dev->core_index << 12);
--		pcicore_write16(pc, SSB_PCICORE_SPROM(0), tmp);
--	}
--}
--
- static u8 ssb_pcicore_polarity_workaround(struct ssb_pcicore *pc)
- {
- 	return (ssb_pcie_read(pc, 0x204) & 0x10) ? 0xC0 : 0x80;
-@@ -529,8 +519,6 @@ void __devinit ssb_pcicore_init(struct s
- 	if (!ssb_device_is_enabled(dev))
- 		ssb_device_enable(dev, 0);
- 
--	ssb_pcicore_fix_sprom_core_index(pc);
--
- #ifdef CONFIG_SSB_PCICORE_HOSTMODE
- 	pc->hostmode = pcicore_is_in_hostmode(pc);
- 	if (pc->hostmode)
diff --git a/target/linux/generic/patches-3.0/020-ssb_update.patch b/target/linux/generic/patches-3.0/020-ssb_update.patch
index a310d90f9..817c4f4dd 100644
--- a/target/linux/generic/patches-3.0/020-ssb_update.patch
+++ b/target/linux/generic/patches-3.0/020-ssb_update.patch
@@ -77,15 +77,17 @@
  {
  	u16 tmp = pcicore_read16(pc, SSB_PCICORE_SPROM(0));
  	if (((tmp & 0xF000) >> 12) != pc->dev->core_index) {
-@@ -514,13 +514,13 @@ static void ssb_pcicore_pcie_setup_worka
+@@ -514,7 +514,7 @@ static void ssb_pcicore_pcie_setup_worka
   * Generic and Clientmode operation code.
   **************************************************/
  
 -static void ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
 +static void __devinit ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
  {
- 	/* Disable PCI interrupts. */
- 	ssb_write32(pc->dev, SSB_INTVEC, 0);
+ 	ssb_pcicore_fix_sprom_core_index(pc);
+ 
+@@ -529,7 +529,7 @@ static void ssb_pcicore_init_clientmode(
+ 	}
  }
  
 -void ssb_pcicore_init(struct ssb_pcicore *pc)
diff --git a/target/linux/generic/patches-3.0/650-pppoe_header_pad.patch b/target/linux/generic/patches-3.0/650-pppoe_header_pad.patch
index 4875d5f23..147b28366 100644
--- a/target/linux/generic/patches-3.0/650-pppoe_header_pad.patch
+++ b/target/linux/generic/patches-3.0/650-pppoe_header_pad.patch
@@ -1,6 +1,6 @@
 --- a/drivers/net/pppoe.c
 +++ b/drivers/net/pppoe.c
-@@ -855,7 +855,7 @@ static int pppoe_sendmsg(struct kiocb *i
+@@ -856,7 +856,7 @@ static int pppoe_sendmsg(struct kiocb *i
  		goto end;
  
  
@@ -9,7 +9,7 @@
  			   0, GFP_KERNEL);
  	if (!skb) {
  		error = -ENOMEM;
-@@ -863,7 +863,7 @@ static int pppoe_sendmsg(struct kiocb *i
+@@ -864,7 +864,7 @@ static int pppoe_sendmsg(struct kiocb *i
  	}
  
  	/* Reserve space for headers. */
diff --git a/target/linux/generic/patches-3.0/721-phy_packets.patch b/target/linux/generic/patches-3.0/721-phy_packets.patch
index ab86bbea3..988212edb 100644
--- a/target/linux/generic/patches-3.0/721-phy_packets.patch
+++ b/target/linux/generic/patches-3.0/721-phy_packets.patch
@@ -53,7 +53,7 @@
  
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1194,6 +1194,7 @@ struct net_device {
+@@ -1188,6 +1188,7 @@ struct net_device {
  	void			*ax25_ptr;	/* AX.25 specific data */
  	struct wireless_dev	*ieee80211_ptr;	/* IEEE 802.11 specific data,
  						   assign before registering */
diff --git a/target/linux/generic/patches-3.0/950-vm_exports.patch b/target/linux/generic/patches-3.0/950-vm_exports.patch
index b9e6f4088..a37be04e1 100644
--- a/target/linux/generic/patches-3.0/950-vm_exports.patch
+++ b/target/linux/generic/patches-3.0/950-vm_exports.patch
@@ -61,7 +61,7 @@
  {
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4905,6 +4905,7 @@ int can_nice(const struct task_struct *p
+@@ -4937,6 +4937,7 @@ int can_nice(const struct task_struct *p
  	return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
  		capable(CAP_SYS_NICE));
  }
diff --git a/target/linux/generic/patches-3.0/999-drop_sublevel.patch b/target/linux/generic/patches-3.0/999-drop_sublevel.patch
index f85fc861f..ed938e0d9 100644
--- a/target/linux/generic/patches-3.0/999-drop_sublevel.patch
+++ b/target/linux/generic/patches-3.0/999-drop_sublevel.patch
@@ -4,6 +4,6 @@
  VERSION = 3
  PATCHLEVEL = 0
 -SUBLEVEL = 0
- EXTRAVERSION = -rc7
+ EXTRAVERSION =
  NAME = Sneaky Weasel
  
-- 
2.20.1