From 160fb73c17c31c29ab040d3e30f9c6f6f2198d93 Mon Sep 17 00:00:00 2001
From: wbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 1 Apr 2005 15:59:13 +0000
Subject: [PATCH] small compile fix for gcc 3.4.3

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@503 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/ebtables/Makefile                      |  1 +
 .../package/ebtables/patches/gcc3.4-ebtables_c.patch   | 10 ++++++++++
 2 files changed, 11 insertions(+)
 create mode 100644 openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch

diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 3f0b467ba..809caf3c0 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -19,6 +19,7 @@ $(DL_DIR)/$(PKG_SOURCE):
 
 $(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
 	$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+	$(PATCH) $(PKG_BUILD_DIR) ./patches
 	touch $(PKG_BUILD_DIR)/.unpacked
 
 $(PKG_BUILD_DIR)/ebtables: $(PKG_BUILD_DIR)/.unpacked
diff --git a/openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch b/openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch
new file mode 100644
index 000000000..1973ea57f
--- /dev/null
+++ b/openwrt/package/ebtables/patches/gcc3.4-ebtables_c.patch
@@ -0,0 +1,10 @@
+--- ebtables-v2.0.6/ebtables.c	2003-11-02 19:22:56.000000000 +0100
++++ ebtables-patch/ebtables.c	2005-03-29 08:03:09.734707134 +0200
+@@ -1171,6 +1171,7 @@
+ 			continue;
+ 		return i;
+ letscontinue:
++	{};
+ 	}
+ 	return -1;
+ }
-- 
2.20.1