From 17143fc18ab20b81d0a2e16ef7b2e81b0ccdda1d Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 12 May 2005 18:26:43 +0000
Subject: [PATCH] convert aiccu to new packaging style

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@838 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/aiccu/Makefile                | 38 +++++--------------
 .../package/aiccu/{ => ipkg}/aiccu.control    |  0
 2 files changed, 10 insertions(+), 28 deletions(-)
 rename openwrt/package/aiccu/{ => ipkg}/aiccu.control (100%)

diff --git a/openwrt/package/aiccu/Makefile b/openwrt/package/aiccu/Makefile
index 0b662d198..f680f33cc 100644
--- a/openwrt/package/aiccu/Makefile
+++ b/openwrt/package/aiccu/Makefile
@@ -9,38 +9,20 @@ PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-	$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-	$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-	touch $(PKG_BUILD_DIR)/.unpacked
+$(eval $(call PKG_template,AICCU,aiccu,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/unix-console/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
+$(PKG_BUILD_DIR)/.built:
 	$(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
 	$(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" DEBUG=0 -C $(PKG_BUILD_DIR)
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME)
-	$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-	mkdir -p $(PKG_IPK_DIR)/usr/sbin $(PKG_IPK_DIR)/etc/init.d
-	install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(PKG_IPK_DIR)/usr/sbin/
-	install -m 755 ./files/S51aiccu $(PKG_IPK_DIR)/etc/init.d/
-	install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(PKG_IPK_DIR)/etc/aiccu.conf
-	$(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-	mkdir -p $(PACKAGE_DIR)
-	$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+$(IPKG_AICCU):
+	mkdir -p $(IDIR_AICCU)/usr/sbin $(IDIR_AICCU)/etc/init.d
+	install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(IDIR_AICCU)/usr/sbin/
+	install -m 755 ./files/S51aiccu $(IDIR_AICCU)/etc/init.d/
+	install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(IDIR_AICCU)/etc/aiccu.conf
+	$(STRIP) $(IDIR_AICCU)/usr/sbin/*
+	$(IPKG_BUILD) $(IDIR_AICCU) $(PACKAGE_DIR)
 
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-	$(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-clean:
-	rm -rf $(PKG_BUILD_DIR)
-	rm -f $(PKG_IPK)
diff --git a/openwrt/package/aiccu/aiccu.control b/openwrt/package/aiccu/ipkg/aiccu.control
similarity index 100%
rename from openwrt/package/aiccu/aiccu.control
rename to openwrt/package/aiccu/ipkg/aiccu.control
-- 
2.20.1