From 191849c5b3d816b4048eacba53076d67d23776d4 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 8 Aug 2008 21:33:53 +0000
Subject: [PATCH] ipkg-build calls 'find' directly irrespective of the
 platform, this causes failure in case gnu-find specific options are used
 (such as "-uid +99").

The attached diff, which creates tools/ipkg-utils/patches/160-find.patch,
fixes the problem by using gfind is available. Again, this is similar
to what is done in include/host.mk. (#3868)

Signed-off-by: Luigi Rizzo <rizzo@iet.unipi.it>


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12247 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 tools/ipkg-utils/patches/160-find.patch | 39 +++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
 create mode 100644 tools/ipkg-utils/patches/160-find.patch

diff --git a/tools/ipkg-utils/patches/160-find.patch b/tools/ipkg-utils/patches/160-find.patch
new file mode 100644
index 000000000..51b101afd
--- /dev/null
+++ b/tools/ipkg-utils/patches/160-find.patch
@@ -0,0 +1,39 @@
+--- /tmp/ipkg-build	2008-08-01 09:36:41.000000000 +0200
++++ ipkg-utils-1.7/ipkg-build	2008-08-06 15:04:52.000000000 +0200
+@@ -10,7 +10,8 @@
+ set -e
+ 
+ version=1.0
+-
++FIND="$(which gfind)"
++FIND="${FIND:-$(which find)}"
+ TAR="${TAR:-$(which tar)}"
+ 
+ ipkg_extract_value() {
+@@ -49,7 +50,7 @@
+ 
+ 	PKG_ERROR=0
+ 
+-	cvs_dirs=`find . -name 'CVS'`
++	cvs_dirs=`$FIND . -name 'CVS'`
+ 	if [ -n "$cvs_dirs" ]; then
+ 	    if [ "$noclean" = "1" ]; then
+ 		echo "*** Warning: The following CVS directories where found.
+@@ -62,7 +63,7 @@
+ 	    fi
+ 	fi
+ 
+-	tilde_files=`find . -name '*~'`
++	tilde_files=`$FIND . -name '*~'`
+ 	if [ -n "$tilde_files" ]; then
+ 	    if [ "$noclean" = "1" ]; then
+ 		echo "*** Warning: The following files have names ending in '~'.
+@@ -75,7 +76,7 @@
+ 	    fi
+ 	fi
+ 
+-	large_uid_files=`find . -uid +99 || true`
++	large_uid_files=`$FIND . -uid +99 || true`
+ 
+ 	if [ "$ogargs" = "" ]  && [ -n "$large_uid_files" ]; then
+ 		echo "*** Warning: The following files have a UID greater than 99.
-- 
2.20.1