From 1c29e8c8f28972e619884972498b87302ee049a5 Mon Sep 17 00:00:00 2001
From: juhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 18 Apr 2010 08:32:35 +0000
Subject: [PATCH] ppc40x: build initramfs images for the OpenRB/Magicbox boards

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20980 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/ppc40x/image/Makefile | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index 3e355a98e..415539e9c 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -16,6 +16,7 @@ endef
 
 define Image/BuildKernel
 	cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+	$(call Image/Build/Initramfs)
 endef
 
 define Image/Build
@@ -62,4 +63,11 @@ define Image/Build/squashfs
 	) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
 endef
 
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+define Image/Build/Initramfs
+	cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox $(BIN_DIR)/openwrt-$(BOARD)-magicbox-initramfs.bin
+	cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb $(BIN_DIR)/openwrt-$(BOARD)-openrb-initramfs.bin
+endef
+endif
+
 $(eval $(call BuildImage))
-- 
2.20.1