From 1c583f3a1fc86853cccc15713907696a430004f3 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 23 Oct 2009 12:13:00 +0000
Subject: [PATCH] [kernel] update to 2.6.31.5

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18127 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/kernel-version.mk                     |  4 +-
 .../patches-2.6.31/028-module_exports.patch   | 45 +++++++++----------
 target/linux/x86/Makefile                     |  2 +-
 .../patches-2.6.31/100-pata_sc1200-wrap.patch |  6 ++-
 4 files changed, 28 insertions(+), 29 deletions(-)

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index d5df7a36f..ad94c8e00 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -25,8 +25,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.30.9)
   LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
 endif
-ifeq ($(LINUX_VERSION),2.6.31.1)
-  LINUX_KERNEL_MD5SUM:=8077cd7f7c1cdeb6aef3872441ae5294
+ifeq ($(LINUX_VERSION),2.6.31.5)
+  LINUX_KERNEL_MD5SUM:=926bff46d24e2f303e4ee92234e394d8
 endif
 
 # disable the md5sum check for unknown kernel versions
diff --git a/target/linux/generic-2.6/patches-2.6.31/028-module_exports.patch b/target/linux/generic-2.6/patches-2.6.31/028-module_exports.patch
index 1af1a5036..355139e8f 100644
--- a/target/linux/generic-2.6/patches-2.6.31/028-module_exports.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/028-module_exports.patch
@@ -1,5 +1,7 @@
---- a/include/asm-generic/vmlinux.lds.h
-+++ b/include/asm-generic/vmlinux.lds.h
+Index: linux-2.6.31.5/include/asm-generic/vmlinux.lds.h
+===================================================================
+--- linux-2.6.31.5.orig/include/asm-generic/vmlinux.lds.h	2009-10-23 00:57:56.000000000 +0200
++++ linux-2.6.31.5/include/asm-generic/vmlinux.lds.h	2009-10-23 12:43:50.000000000 +0200
 @@ -55,6 +55,27 @@
  #define LOAD_OFFSET 0
  #endif
@@ -84,9 +86,11 @@
  	}								\
  									\
  	/* __*init sections */						\
---- a/include/linux/module.h
-+++ b/include/linux/module.h
-@@ -188,16 +188,24 @@ void *__symbol_get_gpl(const char *symbo
+Index: linux-2.6.31.5/include/linux/module.h
+===================================================================
+--- linux-2.6.31.5.orig/include/linux/module.h	2009-10-23 00:57:56.000000000 +0200
++++ linux-2.6.31.5/include/linux/module.h	2009-10-23 12:43:50.000000000 +0200
+@@ -188,16 +188,24 @@
  #define __CRC_SYMBOL(sym, sec)
  #endif
  
@@ -113,20 +117,11 @@
  	= { (unsigned long)&sym, __kstrtab_##sym }
  
  #define EXPORT_SYMBOL(sym)					\
---- a/Makefile
-+++ b/Makefile
-@@ -986,7 +986,7 @@ prepare: prepare0
- # Leave this as default for preprocessing vmlinux.lds.S, which is now
- # done in arch/$(ARCH)/kernel/Makefile
- 
--export CPPFLAGS_vmlinux.lds += -P -C -U$(ARCH)
-+export CPPFLAGS_vmlinux.lds += -P -C -U$(ARCH) $(EXTRA_LDSFLAGS)
- 
- # The asm symlink changes when $(ARCH) changes.
- # Detect this and ask user to run make mrproper
---- a/arch/arm/kernel/vmlinux.lds.S
-+++ b/arch/arm/kernel/vmlinux.lds.S
-@@ -79,26 +79,6 @@ SECTIONS
+Index: linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S
+===================================================================
+--- linux-2.6.31.5.orig/arch/arm/kernel/vmlinux.lds.S	2009-10-23 00:57:56.000000000 +0200
++++ linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S	2009-10-23 12:43:50.000000000 +0200
+@@ -79,26 +79,6 @@
  #endif
  	}
  
@@ -153,7 +148,7 @@
  	.text : {			/* Real text segment		*/
  		_text = .;		/* Text and read-only data	*/
  			__exception_text_start = .;
-@@ -205,6 +185,28 @@ SECTIONS
+@@ -205,6 +185,28 @@
  		__bss_stop = .;
  		_end = .;
  	}
@@ -182,9 +177,11 @@
  					/* Stabs debugging sections.	*/
  	.stab 0 : { *(.stab) }
  	.stabstr 0 : { *(.stabstr) }
---- a/arch/powerpc/kernel/vmlinux.lds.S
-+++ b/arch/powerpc/kernel/vmlinux.lds.S
-@@ -37,12 +37,6 @@ jiffies = jiffies_64 + 4;
+Index: linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S
+===================================================================
+--- linux-2.6.31.5.orig/arch/powerpc/kernel/vmlinux.lds.S	2009-10-23 00:57:56.000000000 +0200
++++ linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S	2009-10-23 12:43:50.000000000 +0200
+@@ -37,12 +37,6 @@
  #endif
  SECTIONS
  {
@@ -197,7 +194,7 @@
  	. = KERNELBASE;
  
  /*
-@@ -295,6 +289,12 @@ SECTIONS
+@@ -295,6 +289,12 @@
  		__bss_stop = .;
  	}
  
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 59247a4c4..899939581 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.31.1
+LINUX_VERSION:=2.6.31.5
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/x86/patches-2.6.31/100-pata_sc1200-wrap.patch b/target/linux/x86/patches-2.6.31/100-pata_sc1200-wrap.patch
index 691d1ca85..edd925fbe 100644
--- a/target/linux/x86/patches-2.6.31/100-pata_sc1200-wrap.patch
+++ b/target/linux/x86/patches-2.6.31/100-pata_sc1200-wrap.patch
@@ -1,5 +1,7 @@
---- a/drivers/ata/pata_sc1200.c
-+++ b/drivers/ata/pata_sc1200.c
+Index: linux-2.6.31.5/drivers/ata/pata_sc1200.c
+===================================================================
+--- linux-2.6.31.5.orig/drivers/ata/pata_sc1200.c	2009-10-23 00:57:56.000000000 +0200
++++ linux-2.6.31.5/drivers/ata/pata_sc1200.c	2009-10-23 12:45:54.000000000 +0200
 @@ -236,7 +236,7 @@
  		.port_ops = &sc1200_port_ops
  	};
-- 
2.20.1