From 1c6727552a93c3f045e07dcd6de9e61d8a32280e Mon Sep 17 00:00:00 2001
From: lars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 25 Mar 2010 15:04:44 +0000
Subject: [PATCH] include/target.mk: Only set usb feature flag for a target if
 there is a HCD

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20425 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/target.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/include/target.mk b/include/target.mk
index 61ff2d21a..5eb8547cc 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -148,7 +148,9 @@ ifeq ($(DUMP),1)
       FEATURES += pcie
     endif
     ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
-      FEATURES += usb
+      ifneq ($(CONFIG_USB_ARCH_HAS_HCD)$(CONFIG_USB_EHCI_HCD),)
+        FEATURES += usb
+      endif
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
       FEATURES += pcmcia
-- 
2.20.1