From 1d37d32fc59dc7f2f76e49fdd11bde5bed3ec96c Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 8 May 2009 23:27:49 +0000
Subject: [PATCH] rb532: add missing drivers and adjust the kernel command line
 for the right device name

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15725 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/rb532/config-2.6.28  | 5 ++++-
 target/linux/rb532/image/Makefile | 8 ++++----
 2 files changed, 8 insertions(+), 5 deletions(-)

diff --git a/target/linux/rb532/config-2.6.28 b/target/linux/rb532/config-2.6.28
index a02f46a0d..038b09214 100644
--- a/target/linux/rb532/config-2.6.28
+++ b/target/linux/rb532/config-2.6.28
@@ -15,6 +15,7 @@ CONFIG_ATA_SFF=y
 CONFIG_BASE_SMALL=0
 # CONFIG_BCM47XX is not set
 CONFIG_BITREVERSE=y
+CONFIG_BLK_DEV_SD=y
 CONFIG_BOOT_RAW=y
 CONFIG_CEVT_R4K=y
 CONFIG_CLASSIC_RCU=y
@@ -136,7 +137,6 @@ CONFIG_PAGEFLAGS_EXTENDED=y
 CONFIG_PAGE_SIZE_4KB=y
 # CONFIG_PAGE_SIZE_64KB is not set
 # CONFIG_PAGE_SIZE_8KB is not set
-CONFIG_PATA_PLATFORM=y
 CONFIG_PATA_RB532=y
 # CONFIG_PATA_SCH is not set
 CONFIG_PCI=y
@@ -153,6 +153,9 @@ CONFIG_PCSPKR_PLATFORM=y
 CONFIG_RC32434_WDT=y
 CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
 CONFIG_SCSI=y
+# CONFIG_SCSI_LOWLEVEL is not set
+# CONFIG_SCSI_MULTI_LUN is not set
+# CONFIG_SCSI_PROC_FS is not set
 # CONFIG_SERIAL_8250_EXTENDED is not set
 # CONFIG_SGI_IP22 is not set
 # CONFIG_SGI_IP27 is not set
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index ab11706c4..a29ddf828 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -34,19 +34,19 @@ define Image/BuildKernel
 endef
 
 define Image/cmdline/jffs2-64k
-block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
+block2mtd.block2mtd=/dev/sda2,65536 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
 endef
 
 define Image/cmdline/jffs2-128k
-block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
+block2mtd.block2mtd=/dev/sda2,131072 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
 endef
 
 define Image/cmdline/ext2
-root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
+root=/dev/sda2 rootfstype=ext2 init=/etc/preinit
 endef
 
 define Image/cmdline/squashfs
-block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
+block2mtd.block2mtd=/dev/sda2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
 endef
 
 define Image/cmdline/yaffs2
-- 
2.20.1