From 263a705cc66a4899562a43ab51c42939d963f8e9 Mon Sep 17 00:00:00 2001
From: juhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 15 Mar 2012 09:25:53 +0000
Subject: [PATCH] ar71xx: move micrel PHY driver to the generic linux target

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30946 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 .../linux/{ar71xx => generic}/files/drivers/net/phy/micrel.c  | 0
 .../patches-3.2/728-phy-micrel.patch}                         | 4 ++--
 .../patches-3.3/728-phy-micrel.patch}                         | 4 ++--
 3 files changed, 4 insertions(+), 4 deletions(-)
 rename target/linux/{ar71xx => generic}/files/drivers/net/phy/micrel.c (100%)
 rename target/linux/{ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch => generic/patches-3.2/728-phy-micrel.patch} (87%)
 rename target/linux/{ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch => generic/patches-3.3/728-phy-micrel.patch} (87%)

diff --git a/target/linux/ar71xx/files/drivers/net/phy/micrel.c b/target/linux/generic/files/drivers/net/phy/micrel.c
similarity index 100%
rename from target/linux/ar71xx/files/drivers/net/phy/micrel.c
rename to target/linux/generic/files/drivers/net/phy/micrel.c
diff --git a/target/linux/ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch b/target/linux/generic/patches-3.2/728-phy-micrel.patch
similarity index 87%
rename from target/linux/ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch
rename to target/linux/generic/patches-3.2/728-phy-micrel.patch
index 78d7e0e3e..8272ba7ca 100644
--- a/target/linux/ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch
+++ b/target/linux/generic/patches-3.2/728-phy-micrel.patch
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -124,6 +124,11 @@ config RTL8306_PHY
+@@ -128,6 +128,11 @@ config RTL8306_PHY
  	tristate "Driver for Realtek RTL8306S switches"
  	select SWCONFIG
  
@@ -14,7 +14,7 @@
  	depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8366S_PHY)	+= rtl8366s.o
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366S_PHY)	+= rtl8366s.o
  obj-$(CONFIG_RTL8366RB_PHY)	+= rtl8366rb.o
  obj-$(CONFIG_RTL8367_PHY)	+= rtl8367.o
  obj-$(CONFIG_LSI_ET1011C_PHY)	+= et1011c.o
diff --git a/target/linux/ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch b/target/linux/generic/patches-3.3/728-phy-micrel.patch
similarity index 87%
rename from target/linux/ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch
rename to target/linux/generic/patches-3.3/728-phy-micrel.patch
index 78d7e0e3e..8272ba7ca 100644
--- a/target/linux/ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch
+++ b/target/linux/generic/patches-3.3/728-phy-micrel.patch
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -124,6 +124,11 @@ config RTL8306_PHY
+@@ -128,6 +128,11 @@ config RTL8306_PHY
  	tristate "Driver for Realtek RTL8306S switches"
  	select SWCONFIG
  
@@ -14,7 +14,7 @@
  	depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8366S_PHY)	+= rtl8366s.o
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366S_PHY)	+= rtl8366s.o
  obj-$(CONFIG_RTL8366RB_PHY)	+= rtl8366rb.o
  obj-$(CONFIG_RTL8367_PHY)	+= rtl8367.o
  obj-$(CONFIG_LSI_ET1011C_PHY)	+= et1011c.o
-- 
2.20.1