From 33d39081fb309d6ffcbadaca8b694cf695038900 Mon Sep 17 00:00:00 2001
From: kaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 31 Jan 2006 11:07:21 +0000
Subject: [PATCH] add pciutils v2.2.1

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3077 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/Config.in                     |  1 +
 openwrt/package/pciutils/Config.in            |  7 ++++
 openwrt/package/pciutils/Makefile             | 35 +++++++++++++++++++
 .../package/pciutils/ipkg/pciutils.control    |  4 +++
 4 files changed, 47 insertions(+)
 create mode 100644 openwrt/package/pciutils/Config.in
 create mode 100644 openwrt/package/pciutils/Makefile
 create mode 100644 openwrt/package/pciutils/ipkg/pciutils.control

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 54fc4b794..f10bca13b 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -256,6 +256,7 @@ source "package/bc/Config.in"
 source "package/gdbserver/Config.in"
 source "package/pcmcia-cs/Config.in"  # pcmcia-utils
 source "package/usbutils/Config.in"  # lsusb
+source "package/pciutils/Config.in"
 source "package/strace/Config.in"
 source "package/udev/Config.in"
 source "package/watchdog/Config.in"
diff --git a/openwrt/package/pciutils/Config.in b/openwrt/package/pciutils/Config.in
new file mode 100644
index 000000000..e76962f82
--- /dev/null
+++ b/openwrt/package/pciutils/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PCIUTILS
+	prompt "pciutils.......................... Linux PCI Utilities"
+	tristate
+	default m if CONFIG_DEVEL
+	help
+	  This package contains various utilities for inspecting and setting of
+	  devices connected to the PCI bus.
diff --git a/openwrt/package/pciutils/Makefile b/openwrt/package/pciutils/Makefile
new file mode 100644
index 000000000..631834456
--- /dev/null
+++ b/openwrt/package/pciutils/Makefile
@@ -0,0 +1,35 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pciutils
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
+
+PKG_SOURCE_URL:=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PCIUTILS,pciutils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+	touch $@
+
+$(IPKG_PCIUTILS):
+	install -d -m0755 $(IDIR_PCIUTILS)/usr/sbin
+	install -d -m0755 $(IDIR_PCIUTILS)/usr/share
+	cp -fpR $(PKG_BUILD_DIR)/{lspci,setpci} $(IDIR_PCIUTILS)/usr/sbin/
+	cp -fpR $(PKG_BUILD_DIR)/pci.ids $(IDIR_PCIUTILS)/usr/share/
+	$(RSTRIP) $(IDIR_PCIUTILS)/
+	$(IPKG_BUILD) $(IDIR_PCIUTILS) $(PACKAGE_DIR)
diff --git a/openwrt/package/pciutils/ipkg/pciutils.control b/openwrt/package/pciutils/ipkg/pciutils.control
new file mode 100644
index 000000000..b3f0c4eea
--- /dev/null
+++ b/openwrt/package/pciutils/ipkg/pciutils.control
@@ -0,0 +1,4 @@
+Package: pciutils
+Priority: optional
+Section: sys
+Description: Linux PCI Utilities
-- 
2.20.1