From 37420c3666dc32a266f3bda0e31952b0eb3be6e4 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 19 Apr 2007 13:19:37 +0000
Subject: [PATCH] Add admswconfig until we add support for adm5120 switch in
 kmod-switch, thanks Thomas Langer for the makefile.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7007 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/admswconfig/Makefile | 48 ++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
 create mode 100644 package/admswconfig/Makefile

diff --git a/package/admswconfig/Makefile b/package/admswconfig/Makefile
new file mode 100644
index 000000000..ab4077052
--- /dev/null
+++ b/package/admswconfig/Makefile
@@ -0,0 +1,48 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=admswconfig
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
+PKG_MD5SUM:=3d00efbff699af8a4d3179becd881b1e
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/admswconfig
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=ADM5120 Switch configuration tool
+  DEPENDS:=@LINUX_2_6_ADM5120 || @LINUX_2_6_ADM5120EB
+  DESCRIPTION:=\
+	A program to configure the internal ethernet switch of an ADM5120 processor. \\\
+	You need the corresponding driver for the switch in the kernel. \\\
+	with this program you can configure which ports of the switch belong \\\
+	to the different ethernet devices.
+  URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+	$(TARGET_CC) $(TARGET_CFLAGS) -Os $(PKG_BUILD_DIR)/admswconfig.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+endef
+
+define Package/admswconfig/install
+	$(INSTALL_DIR) $(1)/sbin
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,admswconfig))
-- 
2.20.1