From 3b44beac3c33cd614cd3b2ec71650cb5a334867c Mon Sep 17 00:00:00 2001
From: wbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 25 Dec 2005 00:56:25 +0000
Subject: [PATCH] change ipkg.conf to use snapshots

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2765 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/base-files/Makefile              | 6 ++++++
 openwrt/package/base-files/default/etc/ipkg.conf | 2 +-
 2 files changed, 7 insertions(+), 1 deletion(-)

diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 16169fa28..8b74ee0d9 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -6,6 +6,11 @@ PKG_NAME:=base-files
 PKG_RELEASE:=6
 PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
 
+BOARD:=$(shell LANG=C grep ^BR2_LINUX_2 $(TOPDIR)/.config|sed -e "s/=y//" \
+	-e "s/.*_//"| tr "[:upper:]" "[:lower:]")
+KERNEL:=$(shell LANG=C grep ^BR2_LINUX_2 $(TOPDIR)/.config|sed -e "s/=y//" \
+	-e "s/BR2_LINUX_//" -e "s/_BRCM//" -e "s/_/./"| tr "[:upper:]" "[:lower:]")
+
 REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
 ifeq ($(REV),)
 REV:=0
@@ -40,6 +45,7 @@ $(IPKG_BASE):
 	$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_BASE) ipkg/$(PKG_NAME).control $(PKG_RELEASE) $(ARCH)
 	cp -a ./default/* $(IDIR_BASE)
 	$(SED) 's,$$R,r$(REV),g' $(IDIR_BASE)/etc/banner
+	$(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(IDIR_BASE)/etc/ipkg.conf
 	mkdir -p $(IDIR_BASE)/jffs
 	mkdir -p $(IDIR_BASE)/dev
 	mkdir -p $(IDIR_BASE)/proc
diff --git a/openwrt/package/base-files/default/etc/ipkg.conf b/openwrt/package/base-files/default/etc/ipkg.conf
index 386721331..2931d2cf8 100644
--- a/openwrt/package/base-files/default/etc/ipkg.conf
+++ b/openwrt/package/base-files/default/etc/ipkg.conf
@@ -1,3 +1,3 @@
-src experimental http://openwrt.org/downloads/experimental/bin/packages
+src snapshots http://openwrt.org/downloads/snapshots/$S/packages
 dest root /
 dest ram /tmp
-- 
2.20.1