From 41696be697ac407621000be86fb56046c58ece0d Mon Sep 17 00:00:00 2001
From: kaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 14 Apr 2008 13:24:30 +0000
Subject: [PATCH] do target dependent optimizations

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10834 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/madwifi/Makefile | 4 ++--
 toolchain/Config.in      | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 918424db2..f2fdac7b9 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -39,10 +39,10 @@ endif
 ifeq ($(ARCH),i686)
   HAL_TARGET:=i386-elf
 endif
-ifeq ($(ARCH),armeb)
+ifeq ($(BOARD),ixp4xx)
   HAL_TARGET:=xscale-be-elf
 endif
-ifeq ($(ARCH),arm)
+ifeq ($(BOARD),iop32x)
   HAL_TARGET:=xscale-le-elf
 endif
 ifeq ($(ARCH),powerpc)
diff --git a/toolchain/Config.in b/toolchain/Config.in
index c4f6e14f5..1d7f1ab07 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -84,7 +84,7 @@ config TARGET_OPTIMIZATION
 	default "-O2 -pipe -march=i486 -funit-at-a-time" if TARGET_x86
 	default "-Os -pipe -march=i486 -funit-at-a-time" if TARGET_rdc
 	default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if mipsel || mips
-	default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if armeb || arm
+	default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if TARGET_ixp4xx || TARGET_iop32x
 	default "-Os -pipe -funit-at-a-time"
 	help
 	  Optimizations to use when building for the target host.
-- 
2.20.1