From 46862b86f0d1dc726d627ac79aa3f98d3d7c1b17 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 5 Jun 2005 14:05:22 +0000
Subject: [PATCH] add target package/target_name to the master makefile, which
 will run $(MAKE) -C package target_name. same for target/ and toolchain/

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1147 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/Makefile | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

diff --git a/openwrt/Makefile b/openwrt/Makefile
index e935295e6..1b8d968a0 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -74,7 +74,6 @@ package_install: package_compile toolchain
 #
 #############################################################
 
-
 # In this section, we need .config
 include .config.cmd
 
@@ -108,6 +107,16 @@ $(BUILD_DIR):
 
 source: $(TARGETS_SOURCE)
 
+
+package/%:
+	$(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+	$(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+	$(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
 #############################################################
 #
 # Cleanup and misc junk
-- 
2.20.1