From 4ab123b1f5c04bf284a7ed95ce413738679ad656 Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 16 Dec 2005 19:37:38 +0000
Subject: [PATCH] fix package version and ack source name change, use target
 optimization cflags, remove conflicting patch.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2709 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/madwifi-tools/Makefile        | 12 +--
 .../patches/001-no_kerneldir.patch            | 75 -------------------
 2 files changed, 7 insertions(+), 80 deletions(-)
 delete mode 100644 openwrt/package/madwifi-tools/patches/001-no_kerneldir.patch

diff --git a/openwrt/package/madwifi-tools/Makefile b/openwrt/package/madwifi-tools/Makefile
index 76a2cc0ae..af2e82286 100644
--- a/openwrt/package/madwifi-tools/Makefile
+++ b/openwrt/package/madwifi-tools/Makefile
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=madwifi
-PKG_VERSION:=r1158-20051215
+PKG_VERSION:=r1358-20051215
 PKG_RELEASE:=1
 PKG_MD5SUM:=0ef00a095359e5af313f52446ebfbbf1
 
 PKG_SOURCE_URL:=http://snapshots.madwifi.org/madwifi-ng
-PKG_SOURCE:=$(PKG_NAME)-trunk-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-ng-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-ng-$(PKG_VERSION)
@@ -22,12 +22,14 @@ $(PKG_BUILD_DIR)/.configured:
 
 $(PKG_BUILD_DIR)/.built:
 	$(MAKE) -C $(PKG_BUILD_DIR)/tools \
-		$(TARGET_CONFIGURE_OPTS)
+		$(TARGET_CONFIGURE_OPTS) \
+		CFLAGS="$(TARGET_CFLAGS)" \
+		all
 	touch $@
 
 $(IPKG_MADWIFI_TOOLS):
-	mkdir -p $(IDIR_MADWIFI_TOOLS)/usr/sbin
-	cp -fpR $(PKG_BUILD_DIR)/tools/athstats \
+	install -d -m0755 $(IDIR_MADWIFI_TOOLS)/usr/sbin
+	install -m0755 $(PKG_BUILD_DIR)/tools/athstats \
 		$(PKG_BUILD_DIR)/tools/athdebug \
 		$(PKG_BUILD_DIR)/tools/80211stats \
 		$(PKG_BUILD_DIR)/tools/80211debug \
diff --git a/openwrt/package/madwifi-tools/patches/001-no_kerneldir.patch b/openwrt/package/madwifi-tools/patches/001-no_kerneldir.patch
deleted file mode 100644
index d8603e5b1..000000000
--- a/openwrt/package/madwifi-tools/patches/001-no_kerneldir.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -urN madwifi.old/Makefile.inc madwifi.dev/Makefile.inc
---- madwifi.old/Makefile.inc	2005-07-14 02:35:49.000000000 +0200
-+++ madwifi.dev/Makefile.inc	2005-09-06 20:10:18.801794992 +0200
-@@ -74,71 +74,6 @@
- 
- # TOOLPATH is the path which contains the crosscompile toolchain (?)
- 
--ifeq ($(strip ${BUS}),AHB)
--# Bus type AHB forces the target platform to be mipsisa32.
--TARGET :=	mipsisa32-be-elf
--
--# Bus type AHB requires KERNELPATH and TOOLPATH to be set manually.
--ifndef KERNELPATH
--$(error KERNELPATH must be defined for bus type AHB.)
--endif
--ifndef TOOLPATH
--$(error TOOLPATH must be defined for bus type AHB.)
--endif
--
--else
--
--KERNELPATH ?= $(firstword $(wildcard $(DESTDIR)/lib/modules/$(shell uname -r)/build /usr/src/linux))
--
--ifeq ($(KERNELPATH),)
--$(error KERNELPATH must be defined)
--endif
--
--endif
--
--# sanity check: does KERNELPATH exist?
--ifeq ($(wildcard $(KERNELPATH)),)
--$(error KERNELPATH: $(KERNELPATH) does not exist)
--endif
--
--# KERNELRELEASE is the target kernel's version.  If KERNELRELEASE
--# is not set in the environment then it is taken from the running
--# system.
--# To determine the correct version a mini-Makefile is piped to make
--# which includes the Makefile in KERNELPATH and prints out the version.
--# This is done to come by problems recently introduced with some distros
--# and newer kernel releases.
--#
--# Note: '\044' used instead of '$' in order to avoid make complaining like
--# "Recursive variable `KERNELRELEASE' references itself (eventually)."
--KERNELRELEASE ?= $(shell echo -e 'madwifi_$$_`date +%s`:\n\t@echo \044(KERNELRELEASE)\ninclude Makefile' | make -C $(KERNELPATH) -s -f-)
--
--# KERNELCONF is the name of the file that holds the configuration
--# of the target kernel.
--KERNELCONF ?=	${KERNELPATH}/.config
--
--# sanity check: does KERNELCONF exist?
--ifeq ($(wildcard $(KERNELCONF)),)
--$(error KERNELCONF: $(KERNELCONF) does not exist.)
--endif
--
--# SYSTEMMAP is the name of the System.map file for the target
--# kernel. This will be needed when DESTDIR is defined in order
--# to run depmod properly.
--SYSTEMMAP ?= 	${KERNELPATH}/System.map
--
--# MODULEPATH nominates the directory where the modules will be
--# installed to
--ifeq ($(strip ${BUS}),AHB)
--MODULEPATH := 	${KERNELPATH}/arch/mips/ar531x/RAMDISK/rootdir/lib/modules/${KERNELRELEASE}/net
--else
--MODULEPATH ?=	/lib/modules/${KERNELRELEASE}/net
--endif
--
--# WIRELESSEXT contains information about the version of the wireless
--# extensions that are available in the target kernel
--WIRELESSEXT ?=	$(shell cat $(KERNELPATH)/include/linux/wireless.h | grep "\#define WIRELESS_EXT" | cut -f2)
--
- # Some settings that depend on actual kernel release
- ifneq ($(findstring 2.6,$(KERNELRELEASE)),)
- export-objs	:=
-- 
2.20.1