From 4d1dc2d13a24c1a8fab6d25e6cf7acf161a154c1 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 12 Jul 2008 22:23:21 +0000
Subject: [PATCH] refresh some madwifi patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11791 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/madwifi/patches/200-no_debug.patch    | 96 +++++++------------
 package/madwifi/patches/352-ani_fix.patch     | 18 ++--
 package/madwifi/patches/353-devid.patch       |  6 +-
 .../madwifi/patches/354-ifxmips_eeprom.patch  |  6 +-
 package/madwifi/patches/404-linux24_fix.patch |  6 +-
 .../patches/405-retransmit_check.patch        | 12 +--
 6 files changed, 48 insertions(+), 96 deletions(-)

diff --git a/package/madwifi/patches/200-no_debug.patch b/package/madwifi/patches/200-no_debug.patch
index 3f040820f..ce059e05c 100644
--- a/package/madwifi/patches/200-no_debug.patch
+++ b/package/madwifi/patches/200-no_debug.patch
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/ath/if_ath.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath.c	2008-07-06 02:38:05.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath/if_ath.c
++++ b/ath/if_ath.c
 @@ -42,7 +42,6 @@
   * This software is derived from work of Atsushi Onoe; his contribution
   * is greatly appreciated.
@@ -101,10 +99,8 @@ Index: madwifi-trunk-r3314/ath/if_ath.c
  /* If we are shutting down or blowing off the DFS channel availability check
   * then we call this to stop the behavior before we take the rest of the
   * necessary actions (such as a DFS reaction to radar). */
-Index: madwifi-trunk-r3314/ath_rate/amrr/amrr.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/amrr/amrr.c	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/ath_rate/amrr/amrr.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath_rate/amrr/amrr.c
++++ b/ath_rate/amrr/amrr.c
 @@ -70,7 +70,9 @@
  
  #include "amrr.h"
@@ -115,10 +111,8 @@ Index: madwifi-trunk-r3314/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define	DPRINTF(sc, _fmt, ...) do {					\
  	if (sc->sc_debug & 0x10)					\
-Index: madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/minstrel/minstrel.c	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath_rate/minstrel/minstrel.c
++++ b/ath_rate/minstrel/minstrel.c
 @@ -117,7 +117,9 @@
  
  #include "minstrel.h"
@@ -129,10 +123,8 @@ Index: madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c
  #ifdef MINSTREL_DEBUG
  enum {
  		ATH_DEBUG_RATE		= 0x00000010	/* rate control */
-Index: madwifi-trunk-r3314/ath_rate/onoe/onoe.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/onoe/onoe.c	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/ath_rate/onoe/onoe.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath_rate/onoe/onoe.c
++++ b/ath_rate/onoe/onoe.c
 @@ -66,7 +66,9 @@
  
  #include "onoe.h"
@@ -143,10 +135,8 @@ Index: madwifi-trunk-r3314/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
  	ATH_DEBUG_RATE	= 0x00000010,	/* rate control */
-Index: madwifi-trunk-r3314/ath_rate/sample/sample.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/sample/sample.c	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/ath_rate/sample/sample.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath_rate/sample/sample.c
++++ b/ath_rate/sample/sample.c
 @@ -68,7 +68,9 @@
  
  #include "sample.h"
@@ -158,10 +148,8 @@ Index: madwifi-trunk-r3314/ath_rate/sample/sample.c
  #ifdef SAMPLE_DEBUG
  enum {
  	ATH_DEBUG_RATE		= 0x00000010,	/* rate control */
-Index: madwifi-trunk-r3314/tools/do_multi.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/do_multi.c	2008-07-06 02:38:05.000000000 +0200
-+++ madwifi-trunk-r3314/tools/do_multi.c	2008-07-06 02:38:18.000000000 +0200
+--- a/tools/do_multi.c
++++ b/tools/do_multi.c
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -183,10 +171,8 @@ Index: madwifi-trunk-r3314/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
  	ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-trunk-r3314/tools/Makefile
-===================================================================
---- madwifi-trunk-r3314.orig/tools/Makefile	2008-07-06 02:38:05.000000000 +0200
-+++ madwifi-trunk-r3314/tools/Makefile	2008-07-06 02:38:18.000000000 +0200
+--- a/tools/Makefile
++++ b/tools/Makefile
 @@ -48,6 +48,8 @@
  
  all: compile
@@ -205,10 +191,8 @@ Index: madwifi-trunk-r3314/tools/Makefile
  LDFLAGS=
  
  
-Index: madwifi-trunk-r3314/net80211/ieee80211_linux.h
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_linux.h	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/net80211/ieee80211_linux.h	2008-07-06 02:38:18.000000000 +0200
+--- a/net80211/ieee80211_linux.h
++++ b/net80211/ieee80211_linux.h
 @@ -29,8 +29,6 @@
  #ifndef _NET80211_IEEE80211_LINUX_H_
  #define _NET80211_IEEE80211_LINUX_H_
@@ -218,10 +202,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_linux.h
  /* #define ATH_DEBUG_SPINLOCKS */		/* announce before spinlocking */
  
  #include <linux/wireless.h>
-Index: madwifi-trunk-r3314/Makefile.inc
-===================================================================
---- madwifi-trunk-r3314.orig/Makefile.inc	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/Makefile.inc	2008-07-06 02:38:18.000000000 +0200
+--- a/Makefile.inc
++++ b/Makefile.inc
 @@ -148,7 +148,8 @@
  TOOLS=  $(TOP)/tools 
  
@@ -232,10 +214,8 @@ Index: madwifi-trunk-r3314/Makefile.inc
  INCS=	-include $(TOP)/include/compat.h -I$(TOP)/include
  
  # TARGET defines the target platform architecture. It must match one of
-Index: madwifi-trunk-r3314/ath/if_ath_radar.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_radar.c	2008-07-06 02:38:05.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath_radar.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath/if_ath_radar.c
++++ b/ath/if_ath_radar.c
 @@ -19,8 +19,6 @@
   * $Id: if_ath_radar.c 2464 2007-06-15 22:51:56Z mtaylor $
   */
@@ -254,10 +234,8 @@ Index: madwifi-trunk-r3314/ath/if_ath_radar.c
  #include "net80211/if_athproto.h"
  #include "if_athvar.h"
  
-Index: madwifi-trunk-r3314/ath/if_ath_hal.h
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_hal.h	2008-07-06 02:38:05.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath_hal.h	2008-07-06 02:38:18.000000000 +0200
+--- a/ath/if_ath_hal.h
++++ b/ath/if_ath_hal.h
 @@ -1081,6 +1081,7 @@
  
             tail -f /var/log/messages | sed -f hal_unmangle.sed 
@@ -275,10 +253,8 @@ Index: madwifi-trunk-r3314/ath/if_ath_hal.h
  #include "if_ath_hal_wrappers.h"
  
  #endif				/* #ifndef _IF_ATH_HAL_H_ */
-Index: madwifi-trunk-r3314/net80211/ieee80211_var.h
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_var.h	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/net80211/ieee80211_var.h	2008-07-06 02:38:18.000000000 +0200
+--- a/net80211/ieee80211_var.h
++++ b/net80211/ieee80211_var.h
 @@ -492,9 +492,10 @@
  	/* inject a fake radar signal -- used while on a 802.11h DFS channels */
  	unsigned int (*ic_test_radar)(struct ieee80211com *);
@@ -291,10 +267,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_var.h
  	/* DFS channel availability check time (in seconds) */
  	void (*ic_set_dfs_cac_time)(struct ieee80211com *, unsigned int);
  	unsigned int (*ic_get_dfs_cac_time)(struct ieee80211com *);
-Index: madwifi-trunk-r3314/net80211/ieee80211_wireless.c
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_wireless.c	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/net80211/ieee80211_wireless.c	2008-07-06 02:38:18.000000000 +0200
+--- a/net80211/ieee80211_wireless.c
++++ b/net80211/ieee80211_wireless.c
 @@ -1548,6 +1548,7 @@
  	return 0;
  }
@@ -333,10 +307,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_wireless.c
  	set_priv(IEEE80211_IOCTL_ADDMAC, ieee80211_ioctl_addmac),
  	set_priv(IEEE80211_IOCTL_DELMAC, ieee80211_ioctl_delmac),
  	set_priv(IEEE80211_IOCTL_WDSADDMAC, ieee80211_ioctl_wdsmac),
-Index: madwifi-trunk-r3314/ath/if_ath_debug.h
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_debug.h	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath_debug.h	2008-07-06 02:38:18.000000000 +0200
+--- a/ath/if_ath_debug.h
++++ b/ath/if_ath_debug.h
 @@ -54,6 +54,10 @@
  	ATH_DEBUG_GLOBAL	= (ATH_DEBUG_SKB|ATH_DEBUG_SKB_REF)
  };
@@ -384,10 +356,8 @@ Index: madwifi-trunk-r3314/ath/if_ath_debug.h
 +#endif
  
  #endif /* #ifndef _IF_ATH_DEBUG_H_ */
-Index: madwifi-trunk-r3314/net80211/ieee80211_node.c
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_node.c	2008-07-06 02:38:04.000000000 +0200
-+++ madwifi-trunk-r3314/net80211/ieee80211_node.c	2008-07-06 02:38:18.000000000 +0200
+--- a/net80211/ieee80211_node.c
++++ b/net80211/ieee80211_node.c
 @@ -920,6 +920,9 @@
  	ni->ni_rxkeyoff = 0;
  }
@@ -407,10 +377,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_node.c
  
  static void
  #ifdef IEEE80211_DEBUG_REFCNT
-Index: madwifi-trunk-r3314/ath/if_ath_pci.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_pci.c	2008-07-06 02:37:58.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath_pci.c	2008-07-06 02:38:18.000000000 +0200
+--- a/ath/if_ath_pci.c
++++ b/ath/if_ath_pci.c
 @@ -134,8 +134,10 @@
  	u16 vdevice;
  	int i;
diff --git a/package/madwifi/patches/352-ani_fix.patch b/package/madwifi/patches/352-ani_fix.patch
index e3c37c00c..012966523 100644
--- a/package/madwifi/patches/352-ani_fix.patch
+++ b/package/madwifi/patches/352-ani_fix.patch
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/ath/if_ath.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath.c	2008-06-13 10:39:28.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath.c	2008-06-13 10:39:54.000000000 +0200
+--- a/ath/if_ath.c
++++ b/ath/if_ath.c
 @@ -1014,9 +1014,7 @@
  	 */
  	sc->sc_hasveol = ath_hal_hasveol(ah);
@@ -250,10 +248,8 @@ Index: madwifi-trunk-r3314/ath/if_ath.c
  	{ 0 }
  };
  
-Index: madwifi-trunk-r3314/ath/if_athvar.h
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_athvar.h	2008-06-13 10:39:28.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_athvar.h	2008-06-13 10:39:32.000000000 +0200
+--- a/ath/if_athvar.h
++++ b/ath/if_athvar.h
 @@ -693,6 +693,10 @@
  	unsigned int sc_txcont_power; /* Continuous transmit power in 0.5dBm units */
  	unsigned int sc_txcont_rate;  /* Continuous transmit rate in Mbps */
@@ -265,10 +261,8 @@ Index: madwifi-trunk-r3314/ath/if_athvar.h
  	/* rate tables */
  	const HAL_RATE_TABLE *sc_rates[IEEE80211_MODE_MAX];
  	const HAL_RATE_TABLE *sc_currates;	/* current rate table */
-Index: madwifi-trunk-r3314/ath/if_ath_hal.h
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_hal.h	2008-06-13 10:39:26.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath_hal.h	2008-06-13 10:39:32.000000000 +0200
+--- a/ath/if_ath_hal.h
++++ b/ath/if_ath_hal.h
 @@ -67,14 +67,14 @@
  
  static inline HAL_BOOL ath_hal_getdiagstate(struct ath_hal *ah, int request,
diff --git a/package/madwifi/patches/353-devid.patch b/package/madwifi/patches/353-devid.patch
index b79caca84..281e348f8 100644
--- a/package/madwifi/patches/353-devid.patch
+++ b/package/madwifi/patches/353-devid.patch
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/ath/if_ath_pci.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_pci.c	2008-07-06 01:38:57.000000000 +0200
-+++ madwifi-trunk-r3314/ath/if_ath_pci.c	2008-07-06 01:52:09.000000000 +0200
+--- a/ath/if_ath_pci.c
++++ b/ath/if_ath_pci.c
 @@ -114,11 +114,13 @@
  	{ 0x168c, 0x0023, PCI_ANY_ID, PCI_ANY_ID },
  	{ 0x168c, 0x0024, PCI_ANY_ID, PCI_ANY_ID },
diff --git a/package/madwifi/patches/354-ifxmips_eeprom.patch b/package/madwifi/patches/354-ifxmips_eeprom.patch
index f4c8f7310..e96bf8654 100644
--- a/package/madwifi/patches/354-ifxmips_eeprom.patch
+++ b/package/madwifi/patches/354-ifxmips_eeprom.patch
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/ath_hal/ah_os.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_hal/ah_os.c	2008-07-06 02:42:52.000000000 +0200
-+++ madwifi-trunk-r3314/ath_hal/ah_os.c	2008-07-06 02:51:53.000000000 +0200
+--- a/ath_hal/ah_os.c
++++ b/ath_hal/ah_os.c
 @@ -343,6 +343,46 @@
   * NB: see the comments in ah_osdep.h about byte-swapping register
   *     reads and writes to understand what's going on below.
diff --git a/package/madwifi/patches/404-linux24_fix.patch b/package/madwifi/patches/404-linux24_fix.patch
index feda6d4e2..ecc80f1b9 100644
--- a/package/madwifi/patches/404-linux24_fix.patch
+++ b/package/madwifi/patches/404-linux24_fix.patch
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/ath_hal/Makefile
-===================================================================
---- madwifi-trunk-r3314.orig/ath_hal/Makefile	2008-06-07 17:08:42.354855646 +0200
-+++ madwifi-trunk-r3314/ath_hal/Makefile	2008-06-07 17:09:03.260046968 +0200
+--- a/ath_hal/Makefile
++++ b/ath_hal/Makefile
 @@ -78,10 +78,11 @@
  quiet_cmd_uudecode = UUDECODE $@
        cmd_uudecode = $(obj)/uudecode -o $@ $<
diff --git a/package/madwifi/patches/405-retransmit_check.patch b/package/madwifi/patches/405-retransmit_check.patch
index c20a02293..cb9de7f11 100644
--- a/package/madwifi/patches/405-retransmit_check.patch
+++ b/package/madwifi/patches/405-retransmit_check.patch
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/net80211/ieee80211.h
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211.h	2008-07-01 22:16:19.000000000 +0200
-+++ madwifi-trunk-r3314/net80211/ieee80211.h	2008-07-01 22:17:12.000000000 +0200
+--- a/net80211/ieee80211.h
++++ b/net80211/ieee80211.h
 @@ -174,8 +174,6 @@
  #define	IEEE80211_SEQ_SEQ_MASK			0xfff0
  #define	IEEE80211_SEQ_SEQ_SHIFT			4
@@ -11,10 +9,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211.h
  #define	IEEE80211_NWID_LEN			32
  
  #define	IEEE80211_QOS_TXOP			0x00ff
-Index: madwifi-trunk-r3314/net80211/ieee80211_input.c
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_input.c	2008-07-01 22:17:11.000000000 +0200
-+++ madwifi-trunk-r3314/net80211/ieee80211_input.c	2008-07-01 22:17:49.000000000 +0200
+--- a/net80211/ieee80211_input.c
++++ b/net80211/ieee80211_input.c
 @@ -412,7 +412,7 @@
  				tid = 0;
  			rxseq = le16toh(*(__le16 *)wh->i_seq);
-- 
2.20.1