From 526a41b8bda39df0d058032f341fbe01bb3f73f8 Mon Sep 17 00:00:00 2001
From: juhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 15 Jul 2007 15:33:15 +0000
Subject: [PATCH] [adm5120] refresh patches for 2.6.22.1 using quilt

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7976 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 .../patches-2.6.22/001-adm5120.patch          | 18 +++++------
 .../patches-2.6.22/002-adm5120_flash.patch    | 12 ++++----
 .../patches-2.6.22/003-adm5120_switch.patch   | 12 ++++----
 .../patches-2.6.22/004-adm5120_uart.patch     | 18 +++++------
 .../patches-2.6.22/005-adm5120_usb.patch      | 30 +++++++++----------
 .../patches-2.6.22/006-adm5120_leds.patch     | 12 ++++----
 .../patches-2.6.22/007-adm5120_pci.patch      | 12 ++++----
 .../100-mtd-myloder-partition-parser.patch    | 12 ++++----
 .../101-cfi-fixup-macronix-bootloc.patch      | 12 ++++----
 .../102-jedec-pmc-39lvxxx-chips.patch         |  6 ++--
 .../patches-2.6.22/140-cmdline_hack.patch     |  6 ++--
 .../adm5120-2.6/patches-2.6.22/500-Nand.patch | 12 ++++----
 12 files changed, 81 insertions(+), 81 deletions(-)

diff --git a/target/linux/adm5120-2.6/patches-2.6.22/001-adm5120.patch b/target/linux/adm5120-2.6/patches-2.6.22/001-adm5120.patch
index 71db5fd86..cc2a88ed5 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/001-adm5120.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/001-adm5120.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/arch/mips/Kconfig
+Index: linux-2.6.22.1/arch/mips/Kconfig
 ===================================================================
---- linux-2.6.22.orig/arch/mips/Kconfig
-+++ linux-2.6.22/arch/mips/Kconfig
+--- linux-2.6.22.1.orig/arch/mips/Kconfig
++++ linux-2.6.22.1/arch/mips/Kconfig
 @@ -15,6 +15,18 @@ choice
  	prompt "System type"
  	default SGI_IP22
@@ -29,10 +29,10 @@ Index: linux-2.6.22/arch/mips/Kconfig
  source "arch/mips/au1000/Kconfig"
  source "arch/mips/ddb5xxx/Kconfig"
  source "arch/mips/gt64120/ev64120/Kconfig"
-Index: linux-2.6.22/arch/mips/Makefile
+Index: linux-2.6.22.1/arch/mips/Makefile
 ===================================================================
---- linux-2.6.22.orig/arch/mips/Makefile
-+++ linux-2.6.22/arch/mips/Makefile
+--- linux-2.6.22.1.orig/arch/mips/Makefile
++++ linux-2.6.22.1/arch/mips/Makefile
 @@ -165,6 +165,16 @@ cflags-$(CONFIG_MACH_JAZZ)	+= -Iinclude/
  load-$(CONFIG_MACH_JAZZ)	+= 0xffffffff80080000
  
@@ -50,10 +50,10 @@ Index: linux-2.6.22/arch/mips/Makefile
  # Common Alchemy Au1x00 stuff
  #
  core-$(CONFIG_SOC_AU1X00)	+= arch/mips/au1000/common/
-Index: linux-2.6.22/include/asm-mips/bootinfo.h
+Index: linux-2.6.22.1/include/asm-mips/bootinfo.h
 ===================================================================
---- linux-2.6.22.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.22/include/asm-mips/bootinfo.h
+--- linux-2.6.22.1.orig/include/asm-mips/bootinfo.h
++++ linux-2.6.22.1/include/asm-mips/bootinfo.h
 @@ -213,6 +213,57 @@
  #define MACH_GROUP_NEC_EMMA2RH 25	/* NEC EMMA2RH (was 23)		*/
  #define  MACH_NEC_MARKEINS	0	/* NEC EMMA2RH Mark-eins	*/
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/002-adm5120_flash.patch b/target/linux/adm5120-2.6/patches-2.6.22/002-adm5120_flash.patch
index b84a62c49..e2f21bfc4 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/002-adm5120_flash.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/002-adm5120_flash.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/mtd/maps/Kconfig
+Index: linux-2.6.22.1/drivers/mtd/maps/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/maps/Kconfig
-+++ linux-2.6.22/drivers/mtd/maps/Kconfig
+--- linux-2.6.22.1.orig/drivers/mtd/maps/Kconfig
++++ linux-2.6.22.1/drivers/mtd/maps/Kconfig
 @@ -620,5 +620,9 @@ config MTD_PLATRAM
  
  	  This selection automatically selects the map_ram driver.
@@ -12,10 +12,10 @@ Index: linux-2.6.22/drivers/mtd/maps/Kconfig
 +
  endmenu
  
-Index: linux-2.6.22/drivers/mtd/maps/Makefile
+Index: linux-2.6.22.1/drivers/mtd/maps/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/maps/Makefile
-+++ linux-2.6.22/drivers/mtd/maps/Makefile
+--- linux-2.6.22.1.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.22.1/drivers/mtd/maps/Makefile
 @@ -47,6 +47,7 @@ obj-$(CONFIG_MTD_OCELOT)	+= ocelot.o
  obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
  obj-$(CONFIG_MTD_PCI)		+= pci.o
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/003-adm5120_switch.patch b/target/linux/adm5120-2.6/patches-2.6.22/003-adm5120_switch.patch
index 83c1ff942..ff8a9bbc2 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/003-adm5120_switch.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/003-adm5120_switch.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/net/Kconfig
+Index: linux-2.6.22.1/drivers/net/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/net/Kconfig
-+++ linux-2.6.22/drivers/net/Kconfig
+--- linux-2.6.22.1.orig/drivers/net/Kconfig
++++ linux-2.6.22.1/drivers/net/Kconfig
 @@ -574,6 +574,10 @@ config MIPS_AU1X00_ENET
  	  If you have an Alchemy Semi AU1X00 based system
  	  say Y.  Otherwise, say N.
@@ -13,10 +13,10 @@ Index: linux-2.6.22/drivers/net/Kconfig
  config NET_SB1250_MAC
  	tristate "SB1250 Ethernet support"
  	depends on NET_ETHERNET && SIBYTE_SB1xxx_SOC
-Index: linux-2.6.22/drivers/net/Makefile
+Index: linux-2.6.22.1/drivers/net/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/net/Makefile
-+++ linux-2.6.22/drivers/net/Makefile
+--- linux-2.6.22.1.orig/drivers/net/Makefile
++++ linux-2.6.22.1/drivers/net/Makefile
 @@ -165,6 +165,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
  # This is also a 82596 and should probably be merged
  obj-$(CONFIG_LP486E) += lp486e.o
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/004-adm5120_uart.patch b/target/linux/adm5120-2.6/patches-2.6.22/004-adm5120_uart.patch
index 089221eb4..7f8451324 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/004-adm5120_uart.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/004-adm5120_uart.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/serial/Makefile
+Index: linux-2.6.22.1/drivers/serial/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/serial/Makefile
-+++ linux-2.6.22/drivers/serial/Makefile
+--- linux-2.6.22.1.orig/drivers/serial/Makefile
++++ linux-2.6.22.1/drivers/serial/Makefile
 @@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554) 
  obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
  obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
@@ -10,10 +10,10 @@ Index: linux-2.6.22/drivers/serial/Makefile
  obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
  obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
  obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
-Index: linux-2.6.22/include/linux/serial_core.h
+Index: linux-2.6.22.1/include/linux/serial_core.h
 ===================================================================
---- linux-2.6.22.orig/include/linux/serial_core.h
-+++ linux-2.6.22/include/linux/serial_core.h
+--- linux-2.6.22.1.orig/include/linux/serial_core.h
++++ linux-2.6.22.1/include/linux/serial_core.h
 @@ -143,6 +143,9 @@
  #define PORT_KS8695	76
  
@@ -24,10 +24,10 @@ Index: linux-2.6.22/include/linux/serial_core.h
  #ifdef __KERNEL__
  
  #include <linux/compiler.h>
-Index: linux-2.6.22/drivers/serial/Kconfig
+Index: linux-2.6.22.1/drivers/serial/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/serial/Kconfig
-+++ linux-2.6.22/drivers/serial/Kconfig
+--- linux-2.6.22.1.orig/drivers/serial/Kconfig
++++ linux-2.6.22.1/drivers/serial/Kconfig
 @@ -270,6 +270,22 @@ config SERIAL_8250_RM9K
  
  comment "Non-8250 serial port support"
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/005-adm5120_usb.patch b/target/linux/adm5120-2.6/patches-2.6.22/005-adm5120_usb.patch
index 06734a172..73f326eb7 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/005-adm5120_usb.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/005-adm5120_usb.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/usb/core/hub.c
+Index: linux-2.6.22.1/drivers/usb/core/hub.c
 ===================================================================
---- linux-2.6.22.orig/drivers/usb/core/hub.c
-+++ linux-2.6.22/drivers/usb/core/hub.c
+--- linux-2.6.22.1.orig/drivers/usb/core/hub.c
++++ linux-2.6.22.1/drivers/usb/core/hub.c
 @@ -464,7 +464,7 @@ void usb_hub_tt_clear_buffer (struct usb
  			: (USB_ENDPOINT_XFER_BULK << 11);
  	if (usb_pipein (pipe))
@@ -182,10 +182,10 @@ Index: linux-2.6.22/drivers/usb/core/hub.c
  re_enumerate:
  	hub_port_logical_disconnect(parent_hub, port1);
  	return -ENODEV;
-Index: linux-2.6.22/drivers/usb/host/Kconfig
+Index: linux-2.6.22.1/drivers/usb/host/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/usb/host/Kconfig
-+++ linux-2.6.22/drivers/usb/host/Kconfig
+--- linux-2.6.22.1.orig/drivers/usb/host/Kconfig
++++ linux-2.6.22.1/drivers/usb/host/Kconfig
 @@ -237,3 +237,6 @@ config USB_SL811_CS
  	  To compile this driver as a module, choose M here: the
  	  module will be called "sl811_cs".
@@ -193,10 +193,10 @@ Index: linux-2.6.22/drivers/usb/host/Kconfig
 +config USB_ADM5120_HCD
 +	tristate "ADM5120 HCD support"
 +	depends on USB && MIPS_ADM5120
-Index: linux-2.6.22/drivers/usb/host/Makefile
+Index: linux-2.6.22.1/drivers/usb/host/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/usb/host/Makefile
-+++ linux-2.6.22/drivers/usb/host/Makefile
+--- linux-2.6.22.1.orig/drivers/usb/host/Makefile
++++ linux-2.6.22.1/drivers/usb/host/Makefile
 @@ -8,6 +8,7 @@ endif
  
  obj-$(CONFIG_PCI)		+= pci-quirks.o
@@ -205,10 +205,10 @@ Index: linux-2.6.22/drivers/usb/host/Makefile
  obj-$(CONFIG_USB_EHCI_HCD)	+= ehci-hcd.o
  obj-$(CONFIG_USB_ISP116X_HCD)	+= isp116x-hcd.o
  obj-$(CONFIG_USB_OHCI_HCD)	+= ohci-hcd.o
-Index: linux-2.6.22/drivers/usb/Kconfig
+Index: linux-2.6.22.1/drivers/usb/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/usb/Kconfig
-+++ linux-2.6.22/drivers/usb/Kconfig
+--- linux-2.6.22.1.orig/drivers/usb/Kconfig
++++ linux-2.6.22.1/drivers/usb/Kconfig
 @@ -88,8 +88,6 @@ source "drivers/usb/storage/Kconfig"
  
  source "drivers/usb/image/Kconfig"
@@ -218,10 +218,10 @@ Index: linux-2.6.22/drivers/usb/Kconfig
  comment "USB port drivers"
  	depends on USB
  
-Index: linux-2.6.22/drivers/usb/Makefile
+Index: linux-2.6.22.1/drivers/usb/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/usb/Makefile
-+++ linux-2.6.22/drivers/usb/Makefile
+--- linux-2.6.22.1.orig/drivers/usb/Makefile
++++ linux-2.6.22.1/drivers/usb/Makefile
 @@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD)	+= host/
  obj-$(CONFIG_USB_SL811_HCD)	+= host/
  obj-$(CONFIG_USB_U132_HCD)	+= host/
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/006-adm5120_leds.patch b/target/linux/adm5120-2.6/patches-2.6.22/006-adm5120_leds.patch
index c7c65613d..bf173bd92 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/006-adm5120_leds.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/006-adm5120_leds.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/leds/Kconfig
+Index: linux-2.6.22.1/drivers/leds/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/leds/Kconfig
-+++ linux-2.6.22/drivers/leds/Kconfig
+--- linux-2.6.22.1.orig/drivers/leds/Kconfig
++++ linux-2.6.22.1/drivers/leds/Kconfig
 @@ -20,6 +20,27 @@ config LEDS_CLASS
  
  comment "LED drivers"
@@ -30,10 +30,10 @@ Index: linux-2.6.22/drivers/leds/Kconfig
  config LEDS_CORGI
  	tristate "LED Support for the Sharp SL-C7x0 series"
  	depends on LEDS_CLASS && PXA_SHARP_C7xx
-Index: linux-2.6.22/drivers/leds/Makefile
+Index: linux-2.6.22.1/drivers/leds/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/leds/Makefile
-+++ linux-2.6.22/drivers/leds/Makefile
+--- linux-2.6.22.1.orig/drivers/leds/Makefile
++++ linux-2.6.22.1/drivers/leds/Makefile
 @@ -5,6 +5,8 @@ obj-$(CONFIG_LEDS_CLASS)		+= led-class.o
  obj-$(CONFIG_LEDS_TRIGGERS)		+= led-triggers.o
  
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/007-adm5120_pci.patch b/target/linux/adm5120-2.6/patches-2.6.22/007-adm5120_pci.patch
index 3fe345e53..71b97ed12 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/007-adm5120_pci.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/007-adm5120_pci.patch
@@ -1,16 +1,16 @@
-Index: linux-2.6.22/arch/mips/pci/Makefile
+Index: linux-2.6.22.1/arch/mips/pci/Makefile
 ===================================================================
---- linux-2.6.22.orig/arch/mips/pci/Makefile
-+++ linux-2.6.22/arch/mips/pci/Makefile
+--- linux-2.6.22.1.orig/arch/mips/pci/Makefile
++++ linux-2.6.22.1/arch/mips/pci/Makefile
 @@ -50,3 +50,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938)	+= fixup-
  obj-$(CONFIG_VICTOR_MPC30X)	+= fixup-mpc30x.o
  obj-$(CONFIG_ZAO_CAPCELLA)	+= fixup-capcella.o
  obj-$(CONFIG_WR_PPMC)		+= fixup-wrppmc.o
 +obj-$(CONFIG_PCI_ADM5120)	+= fixup-adm5120.o ops-adm5120.o pci-adm5120.o
-Index: linux-2.6.22/include/linux/pci_ids.h
+Index: linux-2.6.22.1/include/linux/pci_ids.h
 ===================================================================
---- linux-2.6.22.orig/include/linux/pci_ids.h
-+++ linux-2.6.22/include/linux/pci_ids.h
+--- linux-2.6.22.1.orig/include/linux/pci_ids.h
++++ linux-2.6.22.1/include/linux/pci_ids.h
 @@ -1713,6 +1713,9 @@
  #define PCI_VENDOR_ID_ESDGMBH		0x12fe
  #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch b/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
index 6e6d748a8..184d9fbad 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/100-mtd-myloder-partition-parser.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/mtd/Kconfig
+Index: linux-2.6.22.1/drivers/mtd/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/Kconfig
-+++ linux-2.6.22/drivers/mtd/Kconfig
+--- linux-2.6.22.1.orig/drivers/mtd/Kconfig
++++ linux-2.6.22.1/drivers/mtd/Kconfig
 @@ -155,6 +155,22 @@ config MTD_AFS_PARTS
  	  for your particular device. It won't happen automatically. The
  	  'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
@@ -25,10 +25,10 @@ Index: linux-2.6.22/drivers/mtd/Kconfig
  comment "User Modules And Translation Layers"
  
  config MTD_CHAR
-Index: linux-2.6.22/drivers/mtd/Makefile
+Index: linux-2.6.22.1/drivers/mtd/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/Makefile
-+++ linux-2.6.22/drivers/mtd/Makefile
+--- linux-2.6.22.1.orig/drivers/mtd/Makefile
++++ linux-2.6.22.1/drivers/mtd/Makefile
 @@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT)	+= mtdconcat.o
  obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
  obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/101-cfi-fixup-macronix-bootloc.patch b/target/linux/adm5120-2.6/patches-2.6.22/101-cfi-fixup-macronix-bootloc.patch
index b68eade91..84c45d201 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/101-cfi-fixup-macronix-bootloc.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/101-cfi-fixup-macronix-bootloc.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/mtd/chips/cfi_cmdset_0002.c
+Index: linux-2.6.22.1/drivers/mtd/chips/cfi_cmdset_0002.c
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/chips/cfi_cmdset_0002.c
-+++ linux-2.6.22/drivers/mtd/chips/cfi_cmdset_0002.c
+--- linux-2.6.22.1.orig/drivers/mtd/chips/cfi_cmdset_0002.c
++++ linux-2.6.22.1/drivers/mtd/chips/cfi_cmdset_0002.c
 @@ -47,12 +47,19 @@
  #define MANUFACTURER_AMD	0x0001
  #define MANUFACTURER_ATMEL	0x001F
@@ -74,10 +74,10 @@ Index: linux-2.6.22/drivers/mtd/chips/cfi_cmdset_0002.c
  	{ 0, 0, NULL, NULL }
  };
  static struct cfi_fixup jedec_fixup_table[] = {
-Index: linux-2.6.22/drivers/mtd/chips/Kconfig
+Index: linux-2.6.22.1/drivers/mtd/chips/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/chips/Kconfig
-+++ linux-2.6.22/drivers/mtd/chips/Kconfig
+--- linux-2.6.22.1.orig/drivers/mtd/chips/Kconfig
++++ linux-2.6.22.1/drivers/mtd/chips/Kconfig
 @@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
  	  provides support for one of those command sets, used on chips
  	  including the AMD Am29LV320.
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/102-jedec-pmc-39lvxxx-chips.patch b/target/linux/adm5120-2.6/patches-2.6.22/102-jedec-pmc-39lvxxx-chips.patch
index fa9d35dd1..abed363ed 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/102-jedec-pmc-39lvxxx-chips.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/102-jedec-pmc-39lvxxx-chips.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/mtd/chips/jedec_probe.c
+Index: linux-2.6.22.1/drivers/mtd/chips/jedec_probe.c
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/chips/jedec_probe.c
-+++ linux-2.6.22/drivers/mtd/chips/jedec_probe.c
+--- linux-2.6.22.1.orig/drivers/mtd/chips/jedec_probe.c
++++ linux-2.6.22.1/drivers/mtd/chips/jedec_probe.c
 @@ -121,6 +121,10 @@
  #define UPD29F064115	0x221C
  
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/140-cmdline_hack.patch b/target/linux/adm5120-2.6/patches-2.6.22/140-cmdline_hack.patch
index de3ffa078..093dfc6b4 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/140-cmdline_hack.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/140-cmdline_hack.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/arch/mips/kernel/head.S
+Index: linux-2.6.22.1/arch/mips/kernel/head.S
 ===================================================================
---- linux-2.6.22.orig/arch/mips/kernel/head.S
-+++ linux-2.6.22/arch/mips/kernel/head.S
+--- linux-2.6.22.1.orig/arch/mips/kernel/head.S
++++ linux-2.6.22.1/arch/mips/kernel/head.S
 @@ -129,14 +129,19 @@
  #endif
  	.endm
diff --git a/target/linux/adm5120-2.6/patches-2.6.22/500-Nand.patch b/target/linux/adm5120-2.6/patches-2.6.22/500-Nand.patch
index de96babbe..79915e028 100644
--- a/target/linux/adm5120-2.6/patches-2.6.22/500-Nand.patch
+++ b/target/linux/adm5120-2.6/patches-2.6.22/500-Nand.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22/drivers/mtd/nand/Kconfig
+Index: linux-2.6.22.1/drivers/mtd/nand/Kconfig
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/nand/Kconfig
-+++ linux-2.6.22/drivers/mtd/nand/Kconfig
+--- linux-2.6.22.1.orig/drivers/mtd/nand/Kconfig
++++ linux-2.6.22.1/drivers/mtd/nand/Kconfig
 @@ -81,6 +81,12 @@ config MTD_NAND_TS7250
  	help
  	  Support for NAND flash on Technologic Systems TS-7250 platform.
@@ -15,10 +15,10 @@ Index: linux-2.6.22/drivers/mtd/nand/Kconfig
  config MTD_NAND_IDS
  	tristate
  
-Index: linux-2.6.22/drivers/mtd/nand/Makefile
+Index: linux-2.6.22.1/drivers/mtd/nand/Makefile
 ===================================================================
---- linux-2.6.22.orig/drivers/mtd/nand/Makefile
-+++ linux-2.6.22/drivers/mtd/nand/Makefile
+--- linux-2.6.22.1.orig/drivers/mtd/nand/Makefile
++++ linux-2.6.22.1/drivers/mtd/nand/Makefile
 @@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE)		+= cafe_nan
  obj-$(CONFIG_MTD_NAND_SPIA)		+= spia.o
  obj-$(CONFIG_MTD_NAND_AMS_DELTA)	+= ams-delta.o
-- 
2.20.1