From 5b23b36b7c0d9beb9335c7351e656426b6e85610 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 25 Jul 2005 10:16:56 +0000
Subject: [PATCH] fix base-files-arch package

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1558 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/target/linux/package/openwrt/Makefile | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/openwrt/target/linux/package/openwrt/Makefile b/openwrt/target/linux/package/openwrt/Makefile
index 75053b148..2f90631a0 100644
--- a/openwrt/target/linux/package/openwrt/Makefile
+++ b/openwrt/target/linux/package/openwrt/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME := base-files-arch
 PKG_RELEASE := 1
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(BOARD)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(TOPDIR)/package/rules.mk
 
@@ -35,13 +35,15 @@ $(IDIR_OPENWRT):
 	$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_OPENWRT) ipkg/base-files-arch.control $(PKG_RELEASE) $(ARCH)
 	$(SED) s,base-files-arch,base-files-$(BOARD),g $(IDIR_OPENWRT)/CONTROL/control
 
-$(IPKG_OPENWRT):
+$(IPKG_OPENWRT): $(IDIR_OPENWRT)
 	mkdir -p $(IDIR_OPENWRT)/etc
 	cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
 	$(RSTRIP) $(IDIR_OPENWRT)
 	$(IPKG_BUILD) $(IDIR_OPENWRT) $(PACKAGE_DIR)
 
-compile: install-dev
+install: $(IPKG_OPENWRT)
+	$(IPKG) install $(IPKG_OPENWRT)
+compile: install-dev $(IPKG_OPENWRT)
 install-dev:
 	mkdir -p $(STAGING_DIR)/usr/include
 	cp -a ./include/* $(STAGING_DIR)/usr/include/
-- 
2.20.1