From 6364d7fe22964d0c113264560e6aa625fe8d0d5d Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Wed, 4 May 2005 14:34:22 +0000
Subject: [PATCH] fix openvpn dependencies when removing lzo support

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@798 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/openvpn/Makefile        | 4 ++++
 openwrt/package/openvpn/openvpn.control | 1 -
 2 files changed, 4 insertions(+), 1 deletion(-)

diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index 19a1c5e15..ad2210fe5 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -14,8 +14,11 @@ PKG_CAT:=zcat
 PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
 PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
+PKG_DEPEND:="openssl, kmod-tun"
 ifneq ($(BR2_PACKAGE_OPENVPN_LZO),y)
 DISABLE_LZO:=--disable-lzo
+else
+PKG_DEPEND+=", lzo"
 endif
 
 ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
@@ -64,6 +67,7 @@ $(PKG_BUILD_DIR)/openvpn: $(PKG_BUILD_DIR)/.configured
 
 $(PKG_IPK): $(PKG_BUILD_DIR)/openvpn
 	$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+	echo "Depends: $(PKG_DEPEND)" >> $(PKG_IPK_DIR)/CONTROL/control
 	mkdir -p $(PKG_IPK_DIR)/usr/sbin
 	cp $(PKG_BUILD_DIR)/openvpn $(PKG_IPK_DIR)/usr/sbin/
 	$(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
diff --git a/openwrt/package/openvpn/openvpn.control b/openwrt/package/openvpn/openvpn.control
index b2739f494..6332d34d2 100644
--- a/openwrt/package/openvpn/openvpn.control
+++ b/openwrt/package/openvpn/openvpn.control
@@ -2,6 +2,5 @@ Package: openvpn
 Priority: optional
 Section: net
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Depends: lzo, openssl, kmod-tun
 Source: buildroot internal
 Description: Open Source VPN solution using SSL
-- 
2.20.1