From 64544ce5225d04bcb62b6a10fe465ce560cb74a5 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 11 Feb 2006 17:46:17 +0000
Subject: [PATCH] Restored mrd6 compilation as "ceilf" dependency is now
 solved, updated to latest upstream version

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3219 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/mrd6/Config.in                |  2 +-
 openwrt/package/mrd6/Makefile                 |  7 ++++---
 openwrt/package/mrd6/ipkg/mrd6.control        |  2 +-
 .../mrd6/patches/01-ceilf_replacement.patch   | 21 +++++++++++++++++++
 4 files changed, 27 insertions(+), 5 deletions(-)
 create mode 100644 openwrt/package/mrd6/patches/01-ceilf_replacement.patch

diff --git a/openwrt/package/mrd6/Config.in b/openwrt/package/mrd6/Config.in
index 3ae0c871c..cacebe2ac 100644
--- a/openwrt/package/mrd6/Config.in
+++ b/openwrt/package/mrd6/Config.in
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_MRD6
 	prompt "mrd6.............................. IPv6 multicast routing daemon"
 	tristate
-	default n
+	default m if CONFIG_DEVEL
 	help
 		Multicast is becoming a major component in next generation 
 		networks, used in several scenarios, from video broadcasting 
diff --git a/openwrt/package/mrd6/Makefile b/openwrt/package/mrd6/Makefile
index 8b6ab7039..ea92943b3 100644
--- a/openwrt/package/mrd6/Makefile
+++ b/openwrt/package/mrd6/Makefile
@@ -3,15 +3,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mrd6
-PKG_VERSION:=0.9.4-beta2
+PKG_VERSION:=0.9.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=fe2e617954eccacd9b5c3d6e85f41c89
+PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
 
 PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
 
@@ -29,8 +30,8 @@ $(PKG_BUILD_DIR)/.built:
 		CXX=$(TARGET_CROSS)g++ \
 		CC=$(TARGET_CC) \
 		STAGING_DIR=$(STAGING_DIR) \
-		PREFIX=/usr \
 		DESTDIR=$(PKG_INSTALL_DIR) \
+		PREFIX=/usr/ \
 		install
 	install -d -m0755 $(PKG_INSTALL_DIR)/etc/init.d
 	install -m0644 files/$(PKG_NAME).conf $(PKG_INSTALL_DIR)/etc
diff --git a/openwrt/package/mrd6/ipkg/mrd6.control b/openwrt/package/mrd6/ipkg/mrd6.control
index 89082b9f4..3a50f1713 100644
--- a/openwrt/package/mrd6/ipkg/mrd6.control
+++ b/openwrt/package/mrd6/ipkg/mrd6.control
@@ -2,5 +2,5 @@ Package: mrd6
 Architecture: mipsel
 Section: net
 Priority: optional
-Depends: kmod-ipv6
+Depends: kmod-ipv6, libnotimpl
 Description: IPv6 multicast routing daemon
diff --git a/openwrt/package/mrd6/patches/01-ceilf_replacement.patch b/openwrt/package/mrd6/patches/01-ceilf_replacement.patch
new file mode 100644
index 000000000..1b4ac6213
--- /dev/null
+++ b/openwrt/package/mrd6/patches/01-ceilf_replacement.patch
@@ -0,0 +1,21 @@
+diff -urN mrd6-0.9.5/src/Makefile mrd6-0.9.5.new/src/Makefile
+--- mrd6-0.9.5/src/Makefile	2005-12-18 19:15:04.000000000 +0100
++++ mrd6-0.9.5.new/src/Makefile	2006-02-11 18:30:44.000000000 +0100
+@@ -43,7 +43,7 @@
+ 	CFLAGS += -DNO_INET6_OPTION
+ endif
+ 
+-DEST_PREFIX = $(DESTDIR)$(PREFIX)
++DEST_PREFIX = $(DESTDIR)/$(PREFIX)
+ 
+ ifeq ($(OPTIMIZE),yes)
+ 	ifeq ($(SPACE_OPTIMIZE),yes)
+@@ -97,7 +97,7 @@
+ 	endif
+ endif
+ 
+-LDFLAGS += -lm
++LDFLAGS += -lm -lnotimpl -L$(STAGING_DIR)/usr/lib
+ ifeq ($(PLATFORM),OS_LINUX)
+ 	LDFLAGS += -ldl
+ endif
-- 
2.20.1