From 655d6b3b1b0831c0dd7b60e447a1ac5526e811f1 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 23 Dec 2005 12:23:15 +0000
Subject: [PATCH] Added cutter

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2750 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/Config.in                  |  1 +
 openwrt/package/Makefile                   |  3 ++
 openwrt/package/cutter/Config.in           |  9 ++++++
 openwrt/package/cutter/Makefile            | 32 ++++++++++++++++++++++
 openwrt/package/cutter/ipkg/cutter.control |  5 ++++
 5 files changed, 50 insertions(+)
 create mode 100644 openwrt/package/cutter/Config.in
 create mode 100755 openwrt/package/cutter/Makefile
 create mode 100644 openwrt/package/cutter/ipkg/cutter.control

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 7fe864652..775653b71 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -53,6 +53,7 @@ source "package/bwm/Config.in"
 source "package/chillispot/Config.in"
 source "package/cifsmount/Config.in"
 source "package/cups/Config.in"
+source "package/cutter/Config.in"
 source "package/dhcp/Config.in"
 source "package/dhcp-forwarder/Config.in"
 source "package/dropbear/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 34dafe886..0e53eec2c 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -23,6 +23,7 @@ package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
 package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
 package-$(BR2_PACKAGE_CUPS) += cups
 package-$(BR2_COMPILE_CURL) += curl
+package-$(BR2_PACKAGE_CUTTER) += cutter
 package-$(BR2_COMPILE_CYRUS_SASL) += cyrus-sasl
 package-$(BR2_COMPILE_DB) += libdb
 package-$(BR2_PACKAGE_DECO) += deco
@@ -153,6 +154,7 @@ package-$(BR2_PACKAGE_PARPROUTED) += parprouted
 package-$(BR2_COMPILE_PCMCIA_CS) += pcmcia-cs
 package-$(BR2_COMPILE_PCRE) += pcre
 package-$(BR2_PACKAGE_PEERCAST) += peercast
+package-$(BR2_PACKAGE_PEERGUARDIAN) += peerguardian
 package-$(BR2_COMPILE_PHP4) += php4
 package-$(BR2_COMPILE_PHP5) += php5
 package-$(BR2_PACKAGE_PICOCOM) += picocom
@@ -307,6 +309,7 @@ openswan-compile: gmp-compile
 osiris-compile: openssl-compile
 palantir-compile: jpeg-compile
 peercast-compile: uclibc++-compile
+peerguardian-compile: libpthread-compile
 portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile
diff --git a/openwrt/package/cutter/Config.in b/openwrt/package/cutter/Config.in
new file mode 100644
index 000000000..4c231fddc
--- /dev/null
+++ b/openwrt/package/cutter/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_CUTTER
+	prompt "cutter............................ allows an user to abort TCP/IP connections"
+	tristate
+	default m if CONFIG_DEVEL
+	help
+		"Cutter" is an open source program that allows Linux firewall 
+		administrators to abort TCP/IP connections routed over the 
+		firewall or router on which it is run.
+
diff --git a/openwrt/package/cutter/Makefile b/openwrt/package/cutter/Makefile
new file mode 100755
index 000000000..c9cf5d77f
--- /dev/null
+++ b/openwrt/package/cutter/Makefile
@@ -0,0 +1,32 @@
+# $Id: Makefile 2745 2005-12-21 09:50:28Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cutter
+PKG_VERSION:=1.03
+PKG_RELEASE:=1
+PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
+
+PKG_SOURCE_URL:=http://www.lowth.com/cutter/software/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=gzcat
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,CUTTER,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+	
+$(PKG_BUILD_DIR)/.built:
+	$(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
+	install -d -m0755 $(PKG_INSTALL_DIR)/usr/sbin
+	install -m0755 $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
+	
+$(IPKG_CUTTER):
+	mkdir -p $(IDIR_CUTTER)
+	cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_CUTTER)/
+	$(RSTRIP) $(IDIR_CUTTER)/
+	$(IPKG_BUILD) $(IDIR_CUTTER) $(PACKAGE_DIR)
diff --git a/openwrt/package/cutter/ipkg/cutter.control b/openwrt/package/cutter/ipkg/cutter.control
new file mode 100644
index 000000000..6c9169222
--- /dev/null
+++ b/openwrt/package/cutter/ipkg/cutter.control
@@ -0,0 +1,5 @@
+Package: cutter
+Architecture: mipsel
+Section: net
+Description: "Cutter" is an open source program that allows Linux firewall administrators to abort TCP/IP connections routed over the firewall or router on which it is run.
+Priority: optional
-- 
2.20.1