From 677487a09fa372dc1576745234afdb754a5e82d1 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 12 Dec 2005 22:44:19 +0000
Subject: [PATCH] Added vrrpd package, fixed typo in vgp Config.in and added
 them to the package list in menuconfig

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2644 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/Config.in                             |  2 ++
 package/Makefile                              |  2 ++
 package/vgp/Config.in                         | 10 ++----
 package/vrrpd/Config.in                       |  8 +++++
 package/vrrpd/Makefile                        | 33 +++++++++++++++++++
 package/vrrpd/ipkg/vrrpd.control              |  5 +++
 .../vrrpd/patches/01-honor-target_cc.patch    | 11 +++++++
 7 files changed, 64 insertions(+), 7 deletions(-)
 create mode 100755 package/vrrpd/Config.in
 create mode 100755 package/vrrpd/Makefile
 create mode 100755 package/vrrpd/ipkg/vrrpd.control
 create mode 100644 package/vrrpd/patches/01-honor-target_cc.patch

diff --git a/package/Config.in b/package/Config.in
index c60605556..bd5bb67f8 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -129,6 +129,8 @@ source "package/tor/Config.in"
 source "package/ttcp/Config.in"
 source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
+source "package/vgp/Config.in"
+source "package/vrrpd/Config.in"
 source "package/vsftpd/Config.in"
 source "package/vtun/Config.in"
 source "package/wificonf/Config.in"
diff --git a/package/Makefile b/package/Makefile
index 7168c3f55..ea902e4aa 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -205,6 +205,8 @@ package-$(BR2_COMPILE_USBUTILS) += usbutils
 package-$(BR2_PACKAGE_USTL) += ustl
 package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
 package-$(BR2_PACKAGE_UDEV) += udev
+package-$(BR2_PACKAGE_VGP) += vgp
+package-$(BR2_PACKGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
 package-$(BR2_PACKAGE_WIFICONF) += wificonf
diff --git a/package/vgp/Config.in b/package/vgp/Config.in
index ace8446a4..b3426846c 100755
--- a/package/vgp/Config.in
+++ b/package/vgp/Config.in
@@ -1,11 +1,7 @@
 config BR2_PACKAGE_VGP
-	tristate "vgp - a daemon working like Cisco(c) HSRP"
+	tristate "vgp............................... a daemon working like Cisco(c) HSRP"
 	default m if CONFIG_DEVEL
 	help
 		VGP (Virtual Gateway Protocol)is a very simple protocol able to work in 
-  a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway
-  to provide fault tollerance (and load balancing) on your net. 
-  Each client on your net has as its default gateway the virtual gateway 
-  and not the real router. 
-  		
-		http://vgpd.freaknet.org/
\ No newline at end of file
+		a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway to provide fault tollerance (and load balancing) on your net. Each client on your net has as its default gateway the virtual gateway and not the real router.
+		http://vgpd.freaknet.org/
diff --git a/package/vrrpd/Config.in b/package/vrrpd/Config.in
new file mode 100755
index 000000000..84e7dbc18
--- /dev/null
+++ b/package/vrrpd/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_VRRPD
+        tristate "vrrpd............................. Virtual Router Redundancy Protocol daemon"
+	default m if CONFIG_DEVEL
+	help
+		VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338. 
+		VRRPd is interoperable with other RFC-based VRRP implementations, including Cisco and Juniper, and is included as a standard feature on ImageStream routers.
+		
+		http://www.sourceforge.net/projects/vrrpd
diff --git a/package/vrrpd/Makefile b/package/vrrpd/Makefile
new file mode 100755
index 000000000..82ee36b7b
--- /dev/null
+++ b/package/vrrpd/Makefile
@@ -0,0 +1,33 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vrrpd
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+
+PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
+PKG_SOURCE_URL:=@SF/vrrpd
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VRRPD,VRRPD,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
+	$(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
+	install -m0755 $(PKG_BUILD_DIR)/vrrpd $(PKG_INSTALL_DIR)/usr/sbin/
+	touch $@
+
+$(IPKG_VRRPD):
+	mkdir -p $(IDIR_VRRPD)
+	cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VRRPD)/
+	$(RSTRIP) $(IDIR_VRRPD)
+	$(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)
diff --git a/package/vrrpd/ipkg/vrrpd.control b/package/vrrpd/ipkg/vrrpd.control
new file mode 100755
index 000000000..92cce305b
--- /dev/null
+++ b/package/vrrpd/ipkg/vrrpd.control
@@ -0,0 +1,5 @@
+Package: vrrpd
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338.
diff --git a/package/vrrpd/patches/01-honor-target_cc.patch b/package/vrrpd/patches/01-honor-target_cc.patch
new file mode 100644
index 000000000..c7506070a
--- /dev/null
+++ b/package/vrrpd/patches/01-honor-target_cc.patch
@@ -0,0 +1,11 @@
+diff -urN orig/vrrpd-1.0/Makefile vrrpd-1.0/Makefile
+--- orig/vrrpd-1.0/Makefile	2002-09-09 16:51:13.000000000 +0200
++++ vrrpd-1.0/Makefile	2005-12-12 23:31:30.000000000 +0100
+@@ -15,7 +15,6 @@
+ COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
+ 
+ # set to compile with GCC
+-CC=gcc
+ CFLAGS= $(COMMON_CFLAGS) -Wall
+ 
+ vrrpd : $(VRRPD_OBJS)
-- 
2.20.1