From 6b08782f4c7ffa224646b5e5fb5c4afa4d513ebb Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 12 May 2005 18:29:12 +0000
Subject: [PATCH] convert arptables to new packaging style

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@839 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/arptables/Makefile            | 33 ++++---------------
 .../arptables/{ => ipkg}/arptables.control    |  0
 2 files changed, 7 insertions(+), 26 deletions(-)
 rename openwrt/package/arptables/{ => ipkg}/arptables.control (100%)

diff --git a/openwrt/package/arptables/Makefile b/openwrt/package/arptables/Makefile
index baa2dc300..e770fef59 100644
--- a/openwrt/package/arptables/Makefile
+++ b/openwrt/package/arptables/Makefile
@@ -13,36 +13,17 @@ PKG_SOURCE_URL:=@SF/ebtables
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-	 $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-	$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-	touch $(PKG_BUILD_DIR)/.unpacked
+$(eval $(call PKG_template,ARPTABLES,arptables,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/arptables: $(PKG_BUILD_DIR)/.unpacked
+$(PKG_BUILD_DIR)/.built: 
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
 		CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DARPTABLES_VERSION=\\\"$(PKG_VERSION)\\\" "
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/arptables
-	$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-	mkdir -p $(PKG_IPK_DIR)/usr/sbin
-	cp $(PKG_BUILD_DIR)/arptables $(PKG_IPK_DIR)/usr/sbin/
-	mkdir -p $(PACKAGE_DIR)
-	$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/arptables.list: $(PKG_IPK)
-	$(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/arptables.list
-
-clean:
-	rm -rf $(PKG_BUILD_DIR)
-	rm -f $(PKG_IPK)
+$(IPKG_ARPTABLES):
+	mkdir -p $(IDIR_ARPTABLES)/usr/sbin
+	cp $(PKG_BUILD_DIR)/arptables $(IDIR_ARPTABLES)/usr/sbin/
+	$(IPKG_BUILD) $(IDIR_ARPTABLES) $(PACKAGE_DIR)
diff --git a/openwrt/package/arptables/arptables.control b/openwrt/package/arptables/ipkg/arptables.control
similarity index 100%
rename from openwrt/package/arptables/arptables.control
rename to openwrt/package/arptables/ipkg/arptables.control
-- 
2.20.1