From 6e336367e4a1db5404202ccf58910e945db0af4f Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 11 Dec 2006 17:56:15 +0000
Subject: [PATCH] Add Wi-Fi profiles (for what it matters with this arch)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5763 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/brcm63xx-2.6/Makefile | 13 +++++++++++++
 1 file changed, 13 insertions(+)

diff --git a/target/linux/brcm63xx-2.6/Makefile b/target/linux/brcm63xx-2.6/Makefile
index b8da70e13..d7b71c803 100644
--- a/target/linux/brcm63xx-2.6/Makefile
+++ b/target/linux/brcm63xx-2.6/Makefile
@@ -21,4 +21,17 @@ LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Broadcom
+  NAME:=Broadcom WiFi (default)
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
+define Profile/Atheros
+  NAME:=Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
 $(eval $(call BuildKernel))
-- 
2.20.1