From 7bc978b32b012346bad19ee8f1481a1e63a33d37 Mon Sep 17 00:00:00 2001
From: cshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Wed, 30 Jun 2010 23:09:13 +0000
Subject: [PATCH] block-extroot, block-mount: Fixed multiple bugs which
 prevented e2fsck from being executed on the external root filesystem before
 mounting it as root.  Added /etc/e2fsck.conf which indicates that the clock
 is broken (since most OpenWRT devices don't have a battery backed RTC) so
 that e2fsck will not exit with fatal error when the rdat has not yet been run
 (i.e. before network).

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22002 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 .../block-extroot/files/50_determine_usb_root |  8 +++----
 package/block-mount/files/fsck.sh             | 24 +++++++++----------
 package/block-mount/files/mount.sh            |  4 +---
 package/e2fsprogs/Makefile                    |  1 +
 package/e2fsprogs/files/e2fsck.conf           |  3 +++
 5 files changed, 20 insertions(+), 20 deletions(-)
 create mode 100644 package/e2fsprogs/files/e2fsck.conf

diff --git a/package/block-extroot/files/50_determine_usb_root b/package/block-extroot/files/50_determine_usb_root
index 0de9be384..98ec0016e 100644
--- a/package/block-extroot/files/50_determine_usb_root
+++ b/package/block-extroot/files/50_determine_usb_root
@@ -4,11 +4,11 @@
 # See /LICENSE for more information.
 
 
-. /etc/functions.sh
-. /lib/functions/extmount.sh
-. /lib/functions/mount.sh
-
 determine_external_root() {
+	. /etc/functions.sh
+	. /lib/functions/extmount.sh
+	. /lib/functions/mount.sh
+
 	local OLD_UCI_CONFIG_DIR="$UCI_CONFIG_DIR"
 	set_jffs_mp
 	determine_root_device
diff --git a/package/block-mount/files/fsck.sh b/package/block-mount/files/fsck.sh
index d80e71693..2b6402563 100644
--- a/package/block-mount/files/fsck.sh
+++ b/package/block-mount/files/fsck.sh
@@ -12,20 +12,18 @@ libmount_fsck() {
 	local found_fsck=0
 	
 
-	[ -n "$fsck_type" ] && [ "$fsck_type" != "swap" ] && {
-		grep -q "$device" /proc/swaps || grep -q "$device" /proc/mounts || {
-			[ -e "$device" ] && [ "$fsck_enabled" -eq 1 ] && {
-				for known_type in $libmount_known_fsck; do
-					if [ "$known_type" = "$fsck_fstype" ]; then
-						fsck_${known_type} "$device"
-						found_fsck=1
-						break
-					fi
-				done
-				if [ "$found_fsck" -ne 1 ]; then
-					logger -t 'fstab' "Unable to check/repair $device; no known fsck for filesystem type $fstype"
+	grep -q "$device" /proc/swaps || grep -q "$device" /proc/mounts || {
+		[ -e "$device" ] && [ "$fsck_enabled" -eq 1 ] && {
+			for known_type in $libmount_known_fsck; do
+				if [ "$known_type" = "$fsck_fstype" ]; then
+					fsck_${known_type} "$device"
+					found_fsck=1
+					break
 				fi
-			}
+			done
+			if [ "$found_fsck" -ne 1 ]; then
+				logger -t 'fstab' "Unable to check/repair $device; no known fsck for filesystem type $fstype"
+			fi
 		}
 	}
 }
diff --git a/package/block-mount/files/mount.sh b/package/block-mount/files/mount.sh
index 1616ca7a1..db0fbad1a 100644
--- a/package/block-mount/files/mount.sh
+++ b/package/block-mount/files/mount.sh
@@ -28,14 +28,13 @@ config_mount_by_section() {
 		local is_rootfs="$9"
 		shift
 		local found_device=""
-		local fsck_type=""
 		
 		found_device="$(libmount_find_device_by_id "$uuid" "$label" "$device" "$cfgdevice")"
 		if [ -n "$found_device" ]; then
 			if [ -z "$find_rootfs" ] || [ "$find_rootfs" -eq 0 ] || [ "$is_rootfs" -eq 1 ]; then
 				[ "$enabled_fsck" -eq 1 ] && {
 					grep -q "$found_device" /proc/swaps || grep -q "$found_device" /proc/mounts || {
-						libmount_fsck "$found_device" "$fsck_type" "$enabled_fsck"
+						libmount_fsck "$found_device" "$fstype" "$enabled_fsck"
 					}
 				}								
 	
@@ -72,7 +71,6 @@ config_swapon_by_section() {
 		local label
 		
 		local found_device=""
-		local fsck_type=""
 		
 		found_device="$(libmount_find_device_by_id "$uuid" "$label" "$device" "$cfgdevice")"
 
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index 21942ef0d..d05e9d8b1 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -158,6 +158,7 @@ define Package/e2fsprogs/install
 	$(INSTALL_DIR) $(1)/etc/init.d
 	$(INSTALL_DIR) $(1)/lib/functions/fsck
 	$(INSTALL_DATA) ./files/e2fsck.sh $(1)/lib/functions/fsck/
+	$(INSTALL_DATA) ./files/e2fsck.conf $(1)/etc/e2fsck.conf
 endef
 
 define Package/libuuid/install
diff --git a/package/e2fsprogs/files/e2fsck.conf b/package/e2fsprogs/files/e2fsck.conf
new file mode 100644
index 000000000..9c96b4958
--- /dev/null
+++ b/package/e2fsprogs/files/e2fsck.conf
@@ -0,0 +1,3 @@
+[options]
+broken_system_clock = true
+
-- 
2.20.1