From 7f8cad5eeb1916f10c61634df15999c0ba8b6776 Mon Sep 17 00:00:00 2001
From: noz <noz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 26 Oct 2008 10:34:40 +0000
Subject: [PATCH] [ixp4xx] Add preliminary support for USR8200 board

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13049 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 .../patches-2.6.26/500-usr8200_support.patch  | 327 ++++++++++++++++++
 1 file changed, 327 insertions(+)
 create mode 100644 target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch

diff --git a/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch b/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch
new file mode 100644
index 000000000..7af073225
--- /dev/null
+++ b/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch
@@ -0,0 +1,327 @@
+Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/Kconfig
+===================================================================
+--- linux-2.6.26.5.orig/arch/arm/mach-ixp4xx/Kconfig	2008-10-22 22:31:30.000000000 +0100
++++ linux-2.6.26.5/arch/arm/mach-ixp4xx/Kconfig	2008-10-22 22:40:55.000000000 +0100
+@@ -97,6 +97,14 @@ config MACH_SIDEWINDER
+ 	  Engineering Sidewinder board. For more information on this
+ 	  platform, see http://www.adiengineering.com
+ 
++config MACH_USR8200
++	bool "USRobotics USR8200"
++	select PCI
++	help
++	  Say 'Y' here if you want your kernel to support the USRobotics
++	  USR8200 router board. For more information on this platform, see
++	  http://openwrt.org
++
+ config MACH_COMPEX
+ 	bool "Compex WP18 / NP18A"
+ 	select PCI
+Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/Makefile
+===================================================================
+--- linux-2.6.26.5.orig/arch/arm/mach-ixp4xx/Makefile	2008-10-22 22:31:37.000000000 +0100
++++ linux-2.6.26.5/arch/arm/mach-ixp4xx/Makefile	2008-10-22 22:49:38.000000000 +0100
+@@ -24,6 +24,7 @@ obj-pci-$(CONFIG_MACH_COMPEX)		+= ixdp42
+ obj-pci-$(CONFIG_MACH_WRT300NV2)		+= wrt300nv2-pci.o
+ obj-pci-$(CONFIG_MACH_AP1000)		+= ixdp425-pci.o
+ obj-pci-$(CONFIG_MACH_TW5334)		+= tw5334-pci.o
++obj-pci-$(CONFIG_MACH_USR8200)		+= usr8200-pci.o
+ 
+ obj-y	+= common.o
+ 
+@@ -46,6 +47,7 @@ obj-$(CONFIG_MACH_COMPEX)	+= compex-setu
+ obj-$(CONFIG_MACH_WRT300NV2)	+= wrt300nv2-setup.o
+ obj-$(CONFIG_MACH_AP1000)	+= ap1000-setup.o
+ obj-$(CONFIG_MACH_TW5334)	+= tw5334-setup.o
++obj-$(CONFIG_MACH_USR8200)	+= usr8200-setup.o
+ 
+ obj-$(CONFIG_PCI)		+= $(obj-pci-$(CONFIG_PCI)) common-pci.o
+ obj-$(CONFIG_IXP4XX_QMGR)	+= ixp4xx_qmgr.o
+Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c
+===================================================================
+--- /dev/null	1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c	2008-10-22 23:37:56.000000000 +0100
+@@ -0,0 +1,78 @@
++/*
++ * arch/arch/mach-ixp4xx/usr8200-pci.c
++ *
++ * PCI setup routines for USRobotics USR8200
++ *
++ * Copyright (C) 2008 Peter Denison <openwrt@marshadder.org>
++ *
++ * based on pronghorn-pci.c
++ * 	Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
++ * based on coyote-pci.c:
++ *	Copyright (C) 2002 Jungo Software Technologies.
++ *	Copyright (C) 2003 MontaVista Softwrae, Inc.
++ *
++ * Maintainer: Peter Denison <openwrt@marshadder.org>
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License version 2 as
++ * published by the Free Software Foundation.
++ *
++ */
++
++#include <linux/kernel.h>
++#include <linux/pci.h>
++#include <linux/init.h>
++#include <linux/irq.h>
++
++#include <asm/mach-types.h>
++#include <asm/hardware.h>
++
++#include <asm/mach/pci.h>
++
++void __init usr8200_pci_preinit(void)
++{
++	set_irq_type(IRQ_IXP4XX_GPIO7, IRQT_LOW);
++	set_irq_type(IRQ_IXP4XX_GPIO8, IRQT_LOW);
++	set_irq_type(IRQ_IXP4XX_GPIO9, IRQT_LOW);
++	set_irq_type(IRQ_IXP4XX_GPIO10, IRQT_LOW);
++	set_irq_type(IRQ_IXP4XX_GPIO11, IRQT_LOW);
++
++	ixp4xx_pci_preinit();
++}
++
++static int __init usr8200_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
++{
++	if (slot == 14)
++		return IRQ_IXP4XX_GPIO7;
++	else if (slot == 15)
++		return IRQ_IXP4XX_GPIO8;
++	else if (slot == 16) {
++		if (pin == 1)
++			return IRQ_IXP4XX_GPIO11;
++		else if (pin == 2)
++			return IRQ_IXP4XX_GPIO10;
++		else if (pin == 3)
++			return IRQ_IXP4XX_GPIO9;
++		else
++			return -1;
++	} else
++		return -1;
++}
++
++struct hw_pci usr8200_pci __initdata = {
++	.nr_controllers	= 1,
++	.preinit	= usr8200_pci_preinit,
++	.swizzle	= pci_std_swizzle,
++	.setup		= ixp4xx_setup,
++	.scan		= ixp4xx_scan_bus,
++	.map_irq	= usr8200_map_irq,
++};
++
++int __init usr8200_pci_init(void)
++{
++	if (machine_is_usr8200())
++		pci_common_init(&usr8200_pci);
++	return 0;
++}
++
++subsys_initcall(usr8200_pci_init);
+Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c
+===================================================================
+--- /dev/null	1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c	2008-10-22 23:41:48.000000000 +0100
+@@ -0,0 +1,187 @@
++/*
++ * arch/arm/mach-ixp4xx/usr8200-setup.c
++ *
++ * Board setup for the USRobotics USR8200
++ *
++ * Copyright (C) 2008 Peter Denison <openwrt@marshadder.org>
++ *
++ * based on pronghorn-setup.c:
++ * 	Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
++ * based on coyote-setup.c:
++ *      Copyright (C) 2003-2005 MontaVista Software, Inc.
++ *
++ * Author: Peter Denison <openwrt@marshadder.org>
++ */
++
++#include <linux/kernel.h>
++#include <linux/init.h>
++#include <linux/device.h>
++#include <linux/serial.h>
++#include <linux/tty.h>
++#include <linux/serial_8250.h>
++#include <linux/slab.h>
++#include <linux/types.h>
++#include <linux/memory.h>
++#include <linux/i2c-gpio.h>
++#include <linux/leds.h>
++
++#include <asm/setup.h>
++#include <asm/hardware.h>
++#include <asm/irq.h>
++#include <asm/mach-types.h>
++#include <asm/mach/arch.h>
++#include <asm/mach/flash.h>
++
++static struct flash_platform_data usr8200_flash_data = {
++	.map_name	= "cfi_probe",
++	.width		= 2,
++};
++
++static struct resource usr8200_flash_resource = {
++	.flags		= IORESOURCE_MEM,
++};
++
++static struct platform_device usr8200_flash = {
++	.name		= "IXP4XX-Flash",
++	.id		= 0,
++	.dev		= {
++		.platform_data	= &usr8200_flash_data,
++	},
++	.num_resources	= 1,
++	.resource	= &usr8200_flash_resource,
++};
++
++static struct resource usr8200_uart_resources [] = {
++	{
++		.start		= IXP4XX_UART2_BASE_PHYS,
++		.end		= IXP4XX_UART2_BASE_PHYS + 0x0fff,
++		.flags		= IORESOURCE_MEM
++	},
++	{
++		.start		= IXP4XX_UART1_BASE_PHYS,
++		.end		= IXP4XX_UART1_BASE_PHYS + 0x0fff,
++		.flags		= IORESOURCE_MEM
++	}
++};
++
++static struct plat_serial8250_port usr8200_uart_data[] = {
++	{
++		.mapbase	= IXP4XX_UART2_BASE_PHYS,
++		.membase	= (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
++		.irq		= IRQ_IXP4XX_UART2,
++		.flags		= UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
++		.iotype		= UPIO_MEM,
++		.regshift	= 2,
++		.uartclk	= IXP4XX_UART_XTAL,
++	},
++	{
++		.mapbase	= IXP4XX_UART1_BASE_PHYS,
++		.membase	= (char *)IXP4XX_UART1_BASE_VIRT + REG_OFFSET,
++		.irq		= IRQ_IXP4XX_UART1,
++		.flags		= UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
++		.iotype		= UPIO_MEM,
++		.regshift	= 2,
++		.uartclk	= IXP4XX_UART_XTAL,
++	},
++	{ },
++};
++
++static struct platform_device usr8200_uart = {
++	.name		= "serial8250",
++	.id		= PLAT8250_DEV_PLATFORM,
++	.dev		= {
++		.platform_data	= usr8200_uart_data,
++	},
++	.num_resources	= 2,
++	.resource	= usr8200_uart_resources,
++};
++
++/*
++static struct i2c_gpio_platform_data usr8200_i2c_gpio_data = {
++	.sda_pin	= 9,
++	.scl_pin	= 10,
++};
++
++static struct platform_device usr8200_i2c_gpio = {
++	.name		= "i2c-gpio",
++	.id		= 0,
++	.dev		= {
++		.platform_data	= &usr8200_i2c_gpio_data,
++	},
++};
++
++static struct gpio_led usr8200_led_pin[] = {
++	{
++		.name		= "usr8200:green:status",
++		.gpio		= 7,
++	}
++};
++
++static struct gpio_led_platform_data usr8200_led_data = {
++	.num_leds		= 1,
++	.leds			= usr8200_led_pin,
++};
++
++static struct platform_device usr8200_led = {
++	.name			= "leds-gpio",
++	.id			= -1,
++	.dev.platform_data	= &usr8200_led_data,
++};
++*/
++
++static struct eth_plat_info usr8200_plat_eth[] = {
++	{
++		.phy		= 9,
++		.rxq		= 3,
++		.txreadyq	= 20,
++	}, {
++		.phy		= 16,
++		.rxq		= 4,
++		.txreadyq	= 21,
++	}
++};
++
++static struct platform_device usr8200_eth[] = {
++	{
++		.name			= "ixp4xx_eth",
++		.id			= IXP4XX_ETH_NPEB,
++		.dev.platform_data	= usr8200_plat_eth,
++	}, {
++		.name			= "ixp4xx_eth",
++		.id			= IXP4XX_ETH_NPEC,
++		.dev.platform_data	= usr8200_plat_eth + 1,
++	}
++};
++
++static struct platform_device *usr8200_devices[] __initdata = {
++	&usr8200_flash,
++	&usr8200_uart,
++/*	&usr8200_led,
++	&usr8200_i2c_gpio, */
++	&usr8200_eth[0],
++	&usr8200_eth[1],
++};
++
++static void __init usr8200_init(void)
++{
++	ixp4xx_sys_init();
++
++	usr8200_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
++	usr8200_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_64M - 1;
++
++	*IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
++	*IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
++
++	platform_add_devices(usr8200_devices, ARRAY_SIZE(usr8200_devices));
++}
++
++MACHINE_START(USR8200, "USRobotics USR8200")
++	/* Maintainer: Peter Denison <openwrt@marshadder.org> */
++	.phys_io	= IXP4XX_PERIPHERAL_BASE_PHYS,
++	.io_pg_offst	= ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
++	.map_io		= ixp4xx_map_io,
++	.init_irq	= ixp4xx_init_irq,
++	.timer		= &ixp4xx_timer,
++	.boot_params	= 0x0100,
++	.init_machine	= usr8200_init,
++MACHINE_END
+Index: linux-2.6.26.5/include/asm-arm/arch-ixp4xx/uncompress.h
+===================================================================
+--- linux-2.6.26.5.orig/include/asm-arm/arch-ixp4xx/uncompress.h	2008-10-22 23:27:33.000000000 +0100
++++ linux-2.6.26.5/include/asm-arm/arch-ixp4xx/uncompress.h	2008-10-22 23:28:09.000000000 +0100
+@@ -43,7 +43,7 @@ static __inline__ void __arch_decomp_set
+ 	if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
+ 			 machine_is_gateway7001() || machine_is_wg302v2() ||
+ 			 machine_is_pronghorn() || machine_is_pronghorn_metro() || machine_is_wrt300nv2() ||
+-			 machine_is_tw5334())
++			 machine_is_tw5334() || machine_is_usr8200())
+ 		uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
+ 	else
+ 		uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;
-- 
2.20.1