From 81671750134cc98c33ac4441d7a6eacf59448641 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 3 Nov 2006 22:03:50 +0000
Subject: [PATCH] rename the <boardname>-<kernelversion> directories of
 base-files to just <boardname>, so that the broadcom stuff can share files
 across kernel versions. adding back <boardname>-<kernelversion> for version
 specific overrides is still possible

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5427 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/base-files/Makefile                   |  3 +
 .../base-files/{ar7-2.4 => ar7}/bin/firstboot |  0
 .../{ar7-2.4 => ar7}/etc/config/network       |  0
 .../{ar7-2.4 => ar7}/etc/init.d/adam2         |  0
 .../base-files/{ar7-2.4 => ar7}/etc/preinit   |  0
 .../{ar7-2.4 => ar7}/sbin/mount_root          |  0
 .../{aruba-2.6 => aruba}/etc/config/network   |  0
 .../{au1000-2.6 => au1000}/etc/config/network |  0
 .../{au1000-2.6 => au1000}/sbin/mount_root    |  0
 package/base-files/brcm-2.6/bin/firstboot     | 90 -----------------
 .../base-files/brcm-2.6/etc/init.d/netconfig  | 98 -------------------
 package/base-files/brcm-2.6/etc/preinit       | 13 ---
 package/base-files/brcm-2.6/sbin/mount_root   | 35 -------
 .../{brcm-2.4 => brcm}/bin/firstboot          |  0
 .../{brcm-2.4 => brcm}/etc/init.d/netconfig   |  0
 .../base-files/{brcm-2.4 => brcm}/etc/preinit |  0
 .../{brcm-2.4 => brcm}/sbin/mount_root        |  1 +
 .../{rb532-2.6 => rb532}/etc/config/network   |  0
 .../{rb532-2.6 => rb532}/sbin/cf2nand         |  0
 package/base-files/x86-2.6/etc/config/network | 19 ----
 .../{x86-2.4 => x86}/etc/config/network       |  0
 .../{xscale-2.6 => xscale}/etc/config/network |  0
 22 files changed, 4 insertions(+), 255 deletions(-)
 rename package/base-files/{ar7-2.4 => ar7}/bin/firstboot (100%)
 rename package/base-files/{ar7-2.4 => ar7}/etc/config/network (100%)
 rename package/base-files/{ar7-2.4 => ar7}/etc/init.d/adam2 (100%)
 rename package/base-files/{ar7-2.4 => ar7}/etc/preinit (100%)
 rename package/base-files/{ar7-2.4 => ar7}/sbin/mount_root (100%)
 rename package/base-files/{aruba-2.6 => aruba}/etc/config/network (100%)
 rename package/base-files/{au1000-2.6 => au1000}/etc/config/network (100%)
 rename package/base-files/{au1000-2.6 => au1000}/sbin/mount_root (100%)
 delete mode 100755 package/base-files/brcm-2.6/bin/firstboot
 delete mode 100755 package/base-files/brcm-2.6/etc/init.d/netconfig
 delete mode 100755 package/base-files/brcm-2.6/etc/preinit
 delete mode 100755 package/base-files/brcm-2.6/sbin/mount_root
 rename package/base-files/{brcm-2.4 => brcm}/bin/firstboot (100%)
 rename package/base-files/{brcm-2.4 => brcm}/etc/init.d/netconfig (100%)
 rename package/base-files/{brcm-2.4 => brcm}/etc/preinit (100%)
 rename package/base-files/{brcm-2.4 => brcm}/sbin/mount_root (91%)
 rename package/base-files/{rb532-2.6 => rb532}/etc/config/network (100%)
 rename package/base-files/{rb532-2.6 => rb532}/sbin/cf2nand (100%)
 delete mode 100644 package/base-files/x86-2.6/etc/config/network
 rename package/base-files/{x86-2.4 => x86}/etc/config/network (100%)
 rename package/base-files/{xscale-2.6 => xscale}/etc/config/network (100%)

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 9f6da3bc7..f77821966 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -143,6 +143,9 @@ endef
 
 define Package/base-files$(TARGET)/install
 	$(CP) ./default/* $(1)/
+	if [ -d $(BOARD) ]; then \
+		$(CP) $(BOARD)/* $(1)/; \
+	fi
 	if [ -d $(BOARD)-$(KERNEL) ]; then \
 		$(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
 	fi
diff --git a/package/base-files/ar7-2.4/bin/firstboot b/package/base-files/ar7/bin/firstboot
similarity index 100%
rename from package/base-files/ar7-2.4/bin/firstboot
rename to package/base-files/ar7/bin/firstboot
diff --git a/package/base-files/ar7-2.4/etc/config/network b/package/base-files/ar7/etc/config/network
similarity index 100%
rename from package/base-files/ar7-2.4/etc/config/network
rename to package/base-files/ar7/etc/config/network
diff --git a/package/base-files/ar7-2.4/etc/init.d/adam2 b/package/base-files/ar7/etc/init.d/adam2
similarity index 100%
rename from package/base-files/ar7-2.4/etc/init.d/adam2
rename to package/base-files/ar7/etc/init.d/adam2
diff --git a/package/base-files/ar7-2.4/etc/preinit b/package/base-files/ar7/etc/preinit
similarity index 100%
rename from package/base-files/ar7-2.4/etc/preinit
rename to package/base-files/ar7/etc/preinit
diff --git a/package/base-files/ar7-2.4/sbin/mount_root b/package/base-files/ar7/sbin/mount_root
similarity index 100%
rename from package/base-files/ar7-2.4/sbin/mount_root
rename to package/base-files/ar7/sbin/mount_root
diff --git a/package/base-files/aruba-2.6/etc/config/network b/package/base-files/aruba/etc/config/network
similarity index 100%
rename from package/base-files/aruba-2.6/etc/config/network
rename to package/base-files/aruba/etc/config/network
diff --git a/package/base-files/au1000-2.6/etc/config/network b/package/base-files/au1000/etc/config/network
similarity index 100%
rename from package/base-files/au1000-2.6/etc/config/network
rename to package/base-files/au1000/etc/config/network
diff --git a/package/base-files/au1000-2.6/sbin/mount_root b/package/base-files/au1000/sbin/mount_root
similarity index 100%
rename from package/base-files/au1000-2.6/sbin/mount_root
rename to package/base-files/au1000/sbin/mount_root
diff --git a/package/base-files/brcm-2.6/bin/firstboot b/package/base-files/brcm-2.6/bin/firstboot
deleted file mode 100755
index d37ce4f90..000000000
--- a/package/base-files/brcm-2.6/bin/firstboot
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
-
-rom=$(awk '/squashfs/ {print $2}' /proc/mounts)
-jffs=$(awk '/jffs2/ {print $2}' /proc/mounts)
-
-dupe() { # <new_root> <old_root>
-	cd $1
-	echo -n "creating directories... "
-	{
-		cd $2 
-		find . -xdev -type d
-		echo "./dev ./jffs ./mnt ./proc ./tmp ./sys"
-		# xdev skips mounted directories
-		cd $1 
-	} | xargs mkdir -p
-	echo "done"
-
-	echo -n "setting up symlinks... "
-	for file in $(cd $2; find . -xdev -type f;); do
-		case "$file" in
-		./rom/note) ;; #nothing
-		./etc/config*|\
-		./etc/resolv.conf|\
-		./usr/lib/ipkg/info) cp -af $2/$file $file;;
-		*) ln -sf /rom/${file#./*} $file;;
-		esac
-	done
-	for file in $(cd $2; find . -xdev -type l;); do
-		cp -af $2/${file#./*} $file
-	done
-	echo "done"
-}
-
-pivot() { # <new_root> <old_root>
-	mount -o move /proc $1/proc && \
-	pivot_root $1 $1$2 && {
-		mount -o move $2/dev /dev
-		mount -o move $2/tmp /tmp
-		mount -o move $2/sys /sys
-		return 0
-	}
-}
-
-mountdp() { # <device> <mount_point> <ignored> <fs>
-        dev=$1; mnt=$2; shift 2; opt=$*
-	mount $dev $mnt $opt
-	dupe $mnt $rom
-	pivot $mnt /rom
-}
-
-ramoverlay() {
-	mkdir -p /tmp/root
-	mountdp /tmp/root /mnt -o bind
-}
-
-[ "${0##*/}" = "firstboot" ] && {
-	[ -z "$rom" ] && {
-		echo "You do not have a squashfs partition; aborting"
-		echo "(firstboot cannot be run on jffs2 based firmwares)"
-		exit 1
-	}
-
-	[ "$1" = "switch2jffs" ] && {
-		mtd erase OpenWrt
-		mount -o remount,ro none / # try to avoid fs changing while copying
-		mount -o bind / /mnt
-		mount /dev/mtdblock/4 /rom/jffs -t jffs2
-		echo -n "copying files ... "
-		cp -a /mnt/* /rom/jffs
-		umount /mnt
-		echo "done"
-		pivot /rom /mnt
-		mount -o move /mnt /tmp/root
-		pivot /jffs /rom
-		jffs2root --clean
-		exit 0
-	}
-
-	# script run manually
-	[ \! -z "$jffs" ] && {
-		echo "firstboot has already been run"
-		echo "jffs2 partition is mounted, only resetting files"
-		dupe $jffs $rom
-		exit 0
-	}
-
-	mtd erase OpenWrt
-	mountdp /dev/mtdblock/4 /jffs -t jffs2
-}
diff --git a/package/base-files/brcm-2.6/etc/init.d/netconfig b/package/base-files/brcm-2.6/etc/init.d/netconfig
deleted file mode 100755
index fe39f5051..000000000
--- a/package/base-files/brcm-2.6/etc/init.d/netconfig
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-START=05
-
-start() {
-	[ -e /etc/config/network ] && exit 0
-
-	mkdir -p /etc/config
-
-	(
-		if grep -E 'mtd0: 000(6|a)0000' /proc/mtd 2>&- >&-; then
-			# WGT634u
-			echo boardtype=wgt634u
-		else
-			strings /dev/mtdblock/3
-		fi
-	) | awk '
-	function p(cfgname, name) {
-		if (c[name] != "") print "	option " cfgname "	\"" c[name] "\""
-	}
-	
-	BEGIN {
-		FS="="
-		c["lan_ifname"]="eth0.0"
-		c["wan_ifname"]="eth0.1"
-		c["vlan0ports"]="1 2 3 4 5*"
-		c["vlan1ports"]="0 5"
-	}
-	
-	($1 == "boardnum") || ($1 == "boardtype") || ($1 == "boardflags") {
-		nvram[$1] = $2
-	}
-	
-	END {
-		# v1 hardware
-		if (nvram["boardtype"] == "bcm94710dev") {
-			# Asus WL-500g
-			if (nvram["boardnum"] == "asusX") {
-				c["lan_ifname"]="eth0 eth1" # FIXME
-				c["wan_ifname"]=""
-			}
-		}
-		if (nvram["boardtype"] == "bcm94710r4") {
-			# Toshiba WRC-1000
-			c["lan_ifname"] = "eth0"
-			c["wan_ifname"] = "eth1"
-		}
-		if (nvram["boardtype"] == "wgt634u") {
-			c["vlan0ports"] = "0 1 2 3 5*"
-			c["vlan1ports"] = "4 5"
-		}
-		if ((nvram["boardtype"] == "0x0467") || (nvram["boardtype"] == "0x042f")) {
-			if (nvram["boardnum"] == "45") {
-				c["vlan0ports"] = "1 2 3 4 5*"
-				c["vlan1ports"] = "0 5"
-			} else {
-				c["vlan0ports"] = "0 1 2 3 5*"
-				c["vlan1ports"] = "4 5"
-			}
-		}
-	
-		# WAP54G
-		if ((nvram["boardnum"] == "2") || \
-			(nvram["boardnum"] == "1024")) {
-			c["lan_ifname"]="eth0"
-			c["wan_ifname"]=""
-		}
-	
-		print "#### VLAN configuration "
-		print "config switch eth0"
-		p("vlan0", "vlan0ports")
-		p("vlan1", "vlan1ports")
-		print ""
-		print ""
-		print "#### Loopback configuration"
-		print "config interface loopback"
-		print "	option ifname	\"lo\""
-		print "	option proto	static"
-		print "	option ipaddr	127.0.0.1"
-		print "	option netmask	255.0.0.0"
-		print ""
-		print ""
-		print "#### LAN configuration"
-		print "config interface lan"
-		print "	option type 	bridge"
-		p("ifname", "lan_ifname")
-		print "	option proto	static"
-		print "	option ipaddr	192.168.1.1"
-		print "	option netmask	255.255.255.0"
-		print ""
-		print ""
-		print "#### WAN configuration"
-		print "config interface	wan"
-		p("ifname", "wan_ifname")
-		print "	option proto	dhcp"
-	}' > /etc/config/network
-}
diff --git a/package/base-files/brcm-2.6/etc/preinit b/package/base-files/brcm-2.6/etc/preinit
deleted file mode 100755
index fb13e107e..000000000
--- a/package/base-files/brcm-2.6/etc/preinit
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
-
-export PATH=/bin:/sbin:/usr/bin:/usr/sbin
-mount none /proc -t proc
-
-[ -f /etc/preinit.arch ] && . /etc/preinit.arch
-[ -z "$FAILSAFE" ] || {
-	echo /bin/true > /proc/sys/kernel/hotplug
-	telnetd -l /bin/login <> /dev/null 2>&1
-}
-mount_root ${FAILSAFE:+failsafe}
-exec /sbin/init
diff --git a/package/base-files/brcm-2.6/sbin/mount_root b/package/base-files/brcm-2.6/sbin/mount_root
deleted file mode 100755
index e3bdd3655..000000000
--- a/package/base-files/brcm-2.6/sbin/mount_root
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
-
-is_dirty() {
-	grep Broadcom /proc/cpuinfo >&- || return 1
-	OFFSET="$(($(hexdump -v /dev/mtdblock/1 -s 20 -n 2 -e '"%d"')-1))"
-	return $(hexdump -v /dev/mtdblock/1 -s $OFFSET -n 1 -e '"%d"')
-}
-
-size=$(awk '/Mem:/ {l=5242880;print((s=$2/2)<l)?$2-l:s}' /proc/meminfo)
-mount none /tmp -t tmpfs -o size=$size
-
-if [ "$1" != "failsafe" ]; then 
-	mtd unlock linux
-	mount | grep jffs2 >&-
-	if [ $? = 0 ] ; then
-		mount -o remount,rw /dev/root /
-	else
-		. /bin/firstboot
-		is_dirty 
-		[ $? != 0 ] && {
-			echo "switching to jffs2"
-			mount /dev/mtdblock/4 /jffs -t jffs2
-			pivot /jffs /rom
-		} || {
-			echo "jffs2 unusable; using ramdisk"
-			ramoverlay
-		}
-	fi
-fi
-
-mount none /tmp -t tmpfs -o remount,nosuid,nodev,mode=1777
-mkdir -p /dev/pts
-mount none /dev/pts -t devpts
-mount -t sysfs none /sys 2>&-
diff --git a/package/base-files/brcm-2.4/bin/firstboot b/package/base-files/brcm/bin/firstboot
similarity index 100%
rename from package/base-files/brcm-2.4/bin/firstboot
rename to package/base-files/brcm/bin/firstboot
diff --git a/package/base-files/brcm-2.4/etc/init.d/netconfig b/package/base-files/brcm/etc/init.d/netconfig
similarity index 100%
rename from package/base-files/brcm-2.4/etc/init.d/netconfig
rename to package/base-files/brcm/etc/init.d/netconfig
diff --git a/package/base-files/brcm-2.4/etc/preinit b/package/base-files/brcm/etc/preinit
similarity index 100%
rename from package/base-files/brcm-2.4/etc/preinit
rename to package/base-files/brcm/etc/preinit
diff --git a/package/base-files/brcm-2.4/sbin/mount_root b/package/base-files/brcm/sbin/mount_root
similarity index 91%
rename from package/base-files/brcm-2.4/sbin/mount_root
rename to package/base-files/brcm/sbin/mount_root
index ec82cd40f..e73afdc88 100755
--- a/package/base-files/brcm-2.4/sbin/mount_root
+++ b/package/base-files/brcm/sbin/mount_root
@@ -32,3 +32,4 @@ fi
 mount none /tmp -t tmpfs -o remount,nosuid,nodev,mode=1777
 mkdir -p /dev/pts
 mount none /dev/pts -t devpts
+grep sysfs /proc/filesystems >/dev/null && mount -t sysfs none /sys 2>&-
diff --git a/package/base-files/rb532-2.6/etc/config/network b/package/base-files/rb532/etc/config/network
similarity index 100%
rename from package/base-files/rb532-2.6/etc/config/network
rename to package/base-files/rb532/etc/config/network
diff --git a/package/base-files/rb532-2.6/sbin/cf2nand b/package/base-files/rb532/sbin/cf2nand
similarity index 100%
rename from package/base-files/rb532-2.6/sbin/cf2nand
rename to package/base-files/rb532/sbin/cf2nand
diff --git a/package/base-files/x86-2.6/etc/config/network b/package/base-files/x86-2.6/etc/config/network
deleted file mode 100644
index 68d8e4240..000000000
--- a/package/base-files/x86-2.6/etc/config/network
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-
-config interface loopback
-	option ifname	lo
-	option proto	static
-	option ipaddr	127.0.0.1
-	option netmask	255.0.0.0
-
-config interface lan
-	option type 	bridge
-	option ifname	"eth1 eth2"
-	option proto	static
-	option ipaddr	192.168.1.1
-	option netmask	255.255.255.0
-
-config interface wan
-	option ifname	eth0
-	option proto	dhcp
-
diff --git a/package/base-files/x86-2.4/etc/config/network b/package/base-files/x86/etc/config/network
similarity index 100%
rename from package/base-files/x86-2.4/etc/config/network
rename to package/base-files/x86/etc/config/network
diff --git a/package/base-files/xscale-2.6/etc/config/network b/package/base-files/xscale/etc/config/network
similarity index 100%
rename from package/base-files/xscale-2.6/etc/config/network
rename to package/base-files/xscale/etc/config/network
-- 
2.20.1