From 84d0faceba9c645acb5a1d865a897e6c649b6e4c Mon Sep 17 00:00:00 2001
From: lars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Wed, 4 Aug 2010 13:31:45 +0000
Subject: [PATCH] [xburst] Adjust codec driver module name for 2.6.35

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22483 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/xburst/config-2.6.35     |  1 -
 target/linux/xburst/modules.mk        | 19 +++++++++++++++----
 target/linux/xburst/n516/target.mk    |  2 +-
 target/linux/xburst/n526/target.mk    |  2 +-
 target/linux/xburst/qi_lb60/target.mk |  2 +-
 5 files changed, 18 insertions(+), 8 deletions(-)

diff --git a/target/linux/xburst/config-2.6.35 b/target/linux/xburst/config-2.6.35
index 19805e0f5..507468f08 100644
--- a/target/linux/xburst/config-2.6.35
+++ b/target/linux/xburst/config-2.6.35
@@ -295,7 +295,6 @@ CONFIG_SCSI_MOD=y
 # CONFIG_SIBYTE_SENTOSA is not set
 # CONFIG_SIBYTE_SWARM is not set
 # CONFIG_SND_SOC_ALL_CODECS is not set
-# CONFIG_SND_SOC_JZCODEC is not set
 # CONFIG_SND_SOC_JZ4740 is not set
 # CONFIG_SND_JZ4740_SOC_N516 is not set
 # CONFIG_SND_JZ4740_SOC_N526 is not set
diff --git a/target/linux/xburst/modules.mk b/target/linux/xburst/modules.mk
index 104ad227d..bb8d1f59c 100644
--- a/target/linux/xburst/modules.mk
+++ b/target/linux/xburst/modules.mk
@@ -6,14 +6,24 @@ define KernelPackage/sound-soc-jz4740
   SUBMENU:=$(SOUND_MENU)
   DEPENDS:=kmod-sound-soc-core @TARGET_xburst
   TITLE:=JZ4740 SoC sound support
-  KCONFIG:=CONFIG_SND_JZ4740_SOC CONFIG_SND_JZ4740_SOC_I2S @TARGET_xburst
+  KCONFIG:=CONFIG_SND_JZ4740_SOC CONFIG_SND_JZ4740_SOC_I2S
   FILES:= \
 	$(LINUX_DIR)/sound/soc/jz4740/snd-soc-jz4740.ko \
 	$(LINUX_DIR)/sound/soc/jz4740/snd-soc-jz4740-i2s.ko
   AUTOLOAD:=$(call AutoLoad,60,snd-soc-jz4740 snd-soc-jz4740-i2s)
 endef
 
-define KernelPackage/sound-soc-jzcodec
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
+define KernelPackage/sound-soc-jz4740-codec
+  SUBMENU:=$(SOUND_MENU)
+  DEPENDS:=kmod-sound-soc-core @TARGET_xburst
+  TITLE:=JZ4740 SoC internal codec support
+  KCONFIG:=CONFIG_SND_SOC_JZ4740_CODEC
+  FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-jz4740-codec.ko
+  AUTOLOAD:=$(call AutoLoad,60,snd-soc-jz4740-codec)
+endef
+else
+define KernelPackage/sound-soc-jz4740-codec
   SUBMENU:=$(SOUND_MENU)
   DEPENDS:=kmod-sound-soc-core @TARGET_xburst
   TITLE:=JZ4740 SoC internal codec support
@@ -21,10 +31,11 @@ define KernelPackage/sound-soc-jzcodec
   FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-jzcodec.ko
   AUTOLOAD:=$(call AutoLoad,60,snd-soc-jzcodec)
 endef
+endif
 
 define KernelPackage/sound-soc-xburst/default
   SUBMENU:=$(SOUND_MENU)
-  DEPENDS:=kmod-sound-soc-jz4740 kmod-sound-soc-jzcodec @TARGET_xburst_$(if $(4),$(4),$(3))
+  DEPENDS:=kmod-sound-soc-jz4740 kmod-sound-soc-jz4740-codec @TARGET_xburst_$(if $(4),$(4),$(3))
   TITLE:=$(1) sound support
   KCONFIG:=CONFIG_SND_JZ4740_SOC_$(2)
   FILES:=$(LINUX_DIR)/sound/soc/jz4740/snd-soc-$(3).ko
@@ -44,7 +55,7 @@ $(call KernelPackage/sound-soc-xburst/default,Hanvon N526,N526,n526)
 endef
 
 $(eval $(call KernelPackage,sound-soc-jz4740))
-$(eval $(call KernelPackage,sound-soc-jzcodec))
+$(eval $(call KernelPackage,sound-soc-jz4740-codec))
 $(eval $(call KernelPackage,sound-soc-qilb60))
 $(eval $(call KernelPackage,sound-soc-n516))
 $(eval $(call KernelPackage,sound-soc-n526))
diff --git a/target/linux/xburst/n516/target.mk b/target/linux/xburst/n516/target.mk
index b265d9aba..4035af2b2 100644
--- a/target/linux/xburst/n516/target.mk
+++ b/target/linux/xburst/n516/target.mk
@@ -3,6 +3,6 @@ DEFAULT_PACKAGES += \
 	kmod-sound-core \
 	kmod-sound-soc-core \
 	kmod-sound-soc-jz4740 \
-	kmod-sound-soc-jzcodec \
+	kmod-sound-soc-jz4740-codec \
 	kmod-sound-soc-n516 \
 
diff --git a/target/linux/xburst/n526/target.mk b/target/linux/xburst/n526/target.mk
index afff49c2e..e7bcc77de 100644
--- a/target/linux/xburst/n526/target.mk
+++ b/target/linux/xburst/n526/target.mk
@@ -3,5 +3,5 @@ DEFAULT_PACKAGES += \
 	kmod-sound-core \
 	kmod-sound-soc-core \
 	kmod-sound-soc-jz4740 \
-	kmod-sound-soc-jzcodec \
+	kmod-sound-soc-jz4740-codec \
 	kmod-sound-soc-n516 \
diff --git a/target/linux/xburst/qi_lb60/target.mk b/target/linux/xburst/qi_lb60/target.mk
index 0b2f578f4..7477225c9 100644
--- a/target/linux/xburst/qi_lb60/target.mk
+++ b/target/linux/xburst/qi_lb60/target.mk
@@ -3,6 +3,6 @@ DEFAULT_PACKAGES += \
 	kmod-sound-core \
 	kmod-sound-soc-core \
 	kmod-sound-soc-jz4740 \
-	kmod-sound-soc-jzcodec \
+	kmod-sound-soc-jz4740-codec \
 	kmod-sound-soc-qilb60 \
 
-- 
2.20.1