From 8b19e52abbe1f4ab5a63f1975c9d17d386b7127b Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 14 Jun 2005 22:25:42 +0000
Subject: [PATCH] Update to new upstream release (v0.3.9)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1245 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/wpa_supplicant/Makefile       |  6 ++--
 .../patches/driver_broadcom-memleak.patch     | 36 -------------------
 2 files changed, 3 insertions(+), 39 deletions(-)
 delete mode 100644 openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch

diff --git a/openwrt/package/wpa_supplicant/Makefile b/openwrt/package/wpa_supplicant/Makefile
index cfb6e873d..70792fe4e 100644
--- a/openwrt/package/wpa_supplicant/Makefile
+++ b/openwrt/package/wpa_supplicant/Makefile
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.3.8
-PKG_RELEASE:=2
-PKG_MD5SUM:=c9ced104f0322f834a84336c293b4b57
+PKG_VERSION:=0.3.9
+PKG_RELEASE:=1
+PKG_MD5SUM:=113873aafc4fcaa0515841a6f0a17fd0
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch b/openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch
deleted file mode 100644
index 3d295f5e5..000000000
--- a/openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Fixes some memory leaks in driver_broadom.c
-
-  http://openwrt.org/forum/viewtopic.php?pid=8217#p8217
-
-Thanks Greg (framer99)
-
---- wpa_supplicant-0.3.8/driver_broadcom.c.orig	2005-01-22 05:35:13.000000000 +0100
-+++ wpa_supplicant-0.3.8/driver_broadcom.c	2005-06-10 08:50:14.000000000 +0200
-@@ -289,6 +289,7 @@
- 			   wwh->type);
- 		break;
- 	}
-+	free(data.assoc_info.resp_ies);
- }	
- 
- static void * wpa_driver_broadcom_init(void *ctx, const char *ifname)
-@@ -449,8 +450,10 @@
- 	wsr->count = 0;
- 
- 	if (broadcom_ioctl(drv, WLC_SCAN_RESULTS, buf, WLC_IOCTL_MAXLEN) <
--	    0)
-+	    0) {
-+		free(buf);
- 		return -1;
-+	}
- 
- 	memset(results, 0, max_size * sizeof(struct wpa_scan_result));
- 
-@@ -490,6 +493,7 @@
- 	wpa_printf(MSG_MSGDUMP, "Received %d bytes of scan results (%d BSSes)",
- 		   wsr->buflen, ap_num);
- 
-+	free(buf);
- 	return ap_num;
- }
- 
-- 
2.20.1