From 9b433b090a57ca648ca0e3eeb3ddc68136a7ccc7 Mon Sep 17 00:00:00 2001
From: jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 7 Feb 2012 18:35:48 +0000
Subject: [PATCH] [package] firewall: don't filter IPv4 ICMP types (#10928)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30363 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/firewall/Makefile        | 2 +-
 package/firewall/files/lib/fw.sh | 5 +----
 2 files changed, 2 insertions(+), 5 deletions(-)

diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 746cca488..978154b3f 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=44
+PKG_RELEASE:=45
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index 0814ffc31..76e294f56 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -275,10 +275,7 @@ fw_check_icmptype4() {
 		export FW_ICMP4_TYPES=$(
 			iptables -p icmp -h 2>/dev/null | \
 			sed -n -e '/^Valid ICMP Types:/ {
-				n; :r;
-				/router-advertisement/d;
-				/router-solicitation/d;
-				s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
+				n; :r; s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
 			}' | sort -u
 		)
 
-- 
2.20.1