From 9e7554db871433758f661e85f8ff95501b62d935 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 21 Mar 2010 17:16:50 +0000
Subject: [PATCH] change from /jffs to /overlay, patch from Daniel Dickinson

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20356 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/image.mk                                       |  3 +--
 package/base-files/Makefile                            |  2 +-
 .../base-files/files/lib/firstboot/20_no_fo_mount_jffs |  4 ++--
 .../files/lib/firstboot/30_is_rootfs_mounted           |  2 +-
 package/base-files/files/lib/firstboot/30_no_fo_pivot  |  2 +-
 .../base-files/files/lib/firstboot/40_copy_ramoverlay  |  2 +-
 package/base-files/files/lib/firstboot/50_pivot        |  4 ++--
 .../base-files/files/lib/firstboot/99_10_no_fo_cleanup |  2 +-
 package/base-files/files/lib/functions/boot.sh         |  3 +--
 package/base-files/files/lib/preinit/40_mount_jffs2    |  3 ++-
 .../base-files/files/lib/preinit/70_pivot_jffs2_root   |  3 ++-
 package/base-files/files/lib/upgrade/common.sh         | 10 +++++-----
 package/base-files/files/sbin/firstboot                |  4 ++--
 package/block-extroot/files/50_determine_usb_root      |  4 ++--
 package/block-extroot/files/60_pivot_usb_root          |  2 +-
 package/opkg/files/opkg.conf                           |  2 +-
 16 files changed, 26 insertions(+), 26 deletions(-)

diff --git a/include/image.mk b/include/image.mk
index 47871f954..0ce6336cc 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -62,14 +62,13 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
 		$(call Image/Build,jffs2-$(1))
     endef
     define Image/mkfs/jffs2
-		rm -rf $(TARGET_DIR)/jffs
 		$(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
     endef
   endif
 
   ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
     define Image/mkfs/squashfs
-		@mkdir -p $(TARGET_DIR)/jffs
+		@mkdir -p $(TARGET_DIR)/overlay
 		$(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
 		$(call Image/Build,squashfs)
     endef
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0d4c29eec..88ab61018 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -364,7 +364,7 @@ define Package/base-files/install
 	mkdir -p $(1)/dev
 	mkdir -p $(1)/etc/crontabs
 	mkdir -p $(1)/etc/rc.d
-	mkdir -p $(1)/jffs
+	mkdir -p $(1)/overlay
 	mkdir -p $(1)/lib/firmware
 	$(if $(LIB_SUFFIX),-ln -s lib $(1)/lib$(LIB_SUFFIX))
 	mkdir -p $(1)/mnt
diff --git a/package/base-files/files/lib/firstboot/20_no_fo_mount_jffs b/package/base-files/files/lib/firstboot/20_no_fo_mount_jffs
index da914b143..8a1d4e06d 100644
--- a/package/base-files/files/lib/firstboot/20_no_fo_mount_jffs
+++ b/package/base-files/files/lib/firstboot/20_no_fo_mount_jffs
@@ -5,11 +5,11 @@
 
 no_fo_mount_jffs() {
     # initialize jffs2
-    mount "$mtdpart" /jffs -t jffs2 || exit
+    mount "$mtdpart" /overlay -t jffs2 || exit
     
     # workaround to ensure that union can attach properly
     sync
-    ls /jffs >/dev/null
+    ls /overlay >/dev/null
 }
 
 boot_hook_add no_fo no_fo_mount_jffs
diff --git a/package/base-files/files/lib/firstboot/30_is_rootfs_mounted b/package/base-files/files/lib/firstboot/30_is_rootfs_mounted
index 7c3fe6c4c..e2ba01d50 100644
--- a/package/base-files/files/lib/firstboot/30_is_rootfs_mounted
+++ b/package/base-files/files/lib/firstboot/30_is_rootfs_mounted
@@ -4,7 +4,7 @@
 # Copyright (C) 2010 Vertical Communications
 
 skip_if_rootfs_mounted() {
-    mount "$mtdpart" /rom/jffs -t jffs2 || exit
+    mount "$mtdpart" /rom/overlay -t jffs2 || exit
 }
 
 boot_hook_add switch2jffs skip_if_rootfs_mounted
diff --git a/package/base-files/files/lib/firstboot/30_no_fo_pivot b/package/base-files/files/lib/firstboot/30_no_fo_pivot
index cb82cde5d..b5c2601ee 100644
--- a/package/base-files/files/lib/firstboot/30_no_fo_pivot
+++ b/package/base-files/files/lib/firstboot/30_no_fo_pivot
@@ -5,7 +5,7 @@
 
 no_fo_pivot() {
     # switch to the new (empty) jffs2
-    fopivot /jffs /rom 1
+    fopivot /overlay /rom 1
 }
 
 boot_hook_add no_fo no_fo_pivot
diff --git a/package/base-files/files/lib/firstboot/40_copy_ramoverlay b/package/base-files/files/lib/firstboot/40_copy_ramoverlay
index 4b6a8828f..39c2edacb 100644
--- a/package/base-files/files/lib/firstboot/40_copy_ramoverlay
+++ b/package/base-files/files/lib/firstboot/40_copy_ramoverlay
@@ -8,7 +8,7 @@ copy_ramoverlay() {
     mount -o remount,ro none / 2>&-
     # copy ramoverlay to jffs2
     echo -n "copying files ... "
-    cp -a /tmp/root/* /rom/jffs 2>&-
+    cp -a /tmp/root/* /rom/overlay 2>&-
     echo "done"
 }
 
diff --git a/package/base-files/files/lib/firstboot/50_pivot b/package/base-files/files/lib/firstboot/50_pivot
index fa1c7b540..53801d7a8 100644
--- a/package/base-files/files/lib/firstboot/50_pivot
+++ b/package/base-files/files/lib/firstboot/50_pivot
@@ -9,9 +9,9 @@ with_fo_pivot() {
     pivot /rom /mnt
     mount -o move /mnt /tmp/root
 
-    # /jffs is the overlay
+    # /overlay is the overlay
     # /rom is the readonly
-    fopivot /jffs /rom
+    fopivot /overlay /rom
 }
 
 boot_hook_add switch2jffs with_fo_pivot
diff --git a/package/base-files/files/lib/firstboot/99_10_no_fo_cleanup b/package/base-files/files/lib/firstboot/99_10_no_fo_cleanup
index 5eddfb14f..6dedcb1e8 100644
--- a/package/base-files/files/lib/firstboot/99_10_no_fo_cleanup
+++ b/package/base-files/files/lib/firstboot/99_10_no_fo_cleanup
@@ -5,7 +5,7 @@
 
 no_fo_cleanup() {
     echo "done"
-    umount -l /jffs
+    umount -l /overlay
     umount -l /tmp/root
     exit 0
 }
diff --git a/package/base-files/files/lib/functions/boot.sh b/package/base-files/files/lib/functions/boot.sh
index 96c1c59db..e6f6633ad 100644
--- a/package/base-files/files/lib/functions/boot.sh
+++ b/package/base-files/files/lib/functions/boot.sh
@@ -42,7 +42,7 @@ dupe() { # <new_root> <old_root>
 	{
 		cd $2 
 		find . -xdev -type d
-		echo "./dev ./jffs ./mnt ./proc ./tmp"
+		echo "./dev ./overlay ./mnt ./proc ./tmp"
 		# xdev skips mounted directories
 		cd $1 
 	} | xargs mkdir -p
@@ -69,7 +69,6 @@ pivot() { # <new_root> <old_root>
 		mount -o move $2/dev /dev
 		mount -o move $2/tmp /tmp
 		mount -o move $2/sys /sys 2>&-
-		mount -o move $2/jffs /jffs 2>&-
 		mount -o move $2/overlay /overlay 2>&-
 		return 0
 	}
diff --git a/package/base-files/files/lib/preinit/40_mount_jffs2 b/package/base-files/files/lib/preinit/40_mount_jffs2
index 99fe262c6..cb743ea75 100644
--- a/package/base-files/files/lib/preinit/40_mount_jffs2
+++ b/package/base-files/files/lib/preinit/40_mount_jffs2
@@ -3,7 +3,8 @@
 # Copyright (C) 2010 Vertical Communications
 
 find_mount_jffs2() {
-    mount "$(find_mtd_part rootfs_data)" /jffs -t jffs2
+	mkdir -p /tmp/overlay
+    mount "$(find_mtd_part rootfs_data)" /tmp/overlay -t jffs2
 }
 
 jffs2_not_mounted() {
diff --git a/package/base-files/files/lib/preinit/70_pivot_jffs2_root b/package/base-files/files/lib/preinit/70_pivot_jffs2_root
index f0a2a5569..821bfb14f 100644
--- a/package/base-files/files/lib/preinit/70_pivot_jffs2_root
+++ b/package/base-files/files/lib/preinit/70_pivot_jffs2_root
@@ -5,7 +5,8 @@
 rootfs_pivot() {
     check_skip || jffs2_not_mounted || {
 	echo "switching to jffs2"
-	fopivot /jffs /rom && pi_mount_skip_next=true
+	mount -o move /tmp/overlay /overlay 2>&-
+	fopivot /overlay /rom && pi_mount_skip_next=true
     }
 }
 
diff --git a/package/base-files/files/lib/upgrade/common.sh b/package/base-files/files/lib/upgrade/common.sh
index 3beb6484d..970016e7b 100644
--- a/package/base-files/files/lib/upgrade/common.sh
+++ b/package/base-files/files/lib/upgrade/common.sh
@@ -35,7 +35,7 @@ install_bin() { # <file> [ <symlink> ... ]
 
 pivot() { # <new_root> <old_root>
 	mount | grep "on $1 type" 2>&- 1>&- || mount -o bind $1 $1
-	mkdir -p $1$2 $1/proc $1/dev $1/tmp $1/jffs && \
+	mkdir -p $1$2 $1/proc $1/dev $1/tmp $1/overlay && \
 	mount -o move /proc $1/proc && \
 	pivot_root $1 $1$2 || {
         umount $1 $1
@@ -43,7 +43,7 @@ pivot() { # <new_root> <old_root>
 	}
 	mount -o move $2/dev /dev
 	mount -o move $2/tmp /tmp
-	mount -o move $2/jffs /jffs 2>&-
+	mount -o move $2/overlay /overlay 2>&-
 	return 0
 }
 
@@ -63,9 +63,9 @@ run_ramfs() { # <command> [...]
 	mount -o remount,ro /mnt
 	umount -l /mnt
 
-	grep /jffs /proc/mounts > /dev/null && {
-		mount -o remount,ro /jffs
-		umount -l /jffs
+	grep /overlay /proc/mounts > /dev/null && {
+		mount -o remount,ro /overlay
+		umount -l /overlay
 	}
 
 	# spawn a new shell from ramdisk to reduce the probability of cache issues
diff --git a/package/base-files/files/sbin/firstboot b/package/base-files/files/sbin/firstboot
index e9994dec3..4da299189 100755
--- a/package/base-files/files/sbin/firstboot
+++ b/package/base-files/files/sbin/firstboot
@@ -27,8 +27,8 @@ if [ "${0##*/}" = "firstboot" ]; then
 	boot_run_hook jffs2reset
     else
 	mtd erase "$partname"
-	mount "$mtdpart" /jffs -t jffs2
-	fopivot /jffs /rom 1
+	mount "$mtdpart" /overlay -t jffs2
+	fopivot /overlay /rom 1
     fi
 fi
 
diff --git a/package/block-extroot/files/50_determine_usb_root b/package/block-extroot/files/50_determine_usb_root
index 1e5f153b6..192990c91 100644
--- a/package/block-extroot/files/50_determine_usb_root
+++ b/package/block-extroot/files/50_determine_usb_root
@@ -16,8 +16,8 @@ determine_external_root() {
 	# extroot requires extroot and fstab config files, therefore 
 	# we assume configuration is incomplete and not to be used if either of them
 	# is missing (for jffs versions of these files on squashfs image)
-	if [ "$jffs" = "/jffs" ] && [ -r "/jffs/etc/config/fstab" ]; then
-		UCI_CONFIG_DIR="/jffs/etc/config"
+	if [ "$jffs" = "/tmp/overlay" ] && [ -r "/tmp/overlay/etc/config/fstab" ]; then
+		UCI_CONFIG_DIR="/tmp/overlay/etc/config"
 		ER_IS_SQUASHFS=true
 	fi
 
diff --git a/package/block-extroot/files/60_pivot_usb_root b/package/block-extroot/files/60_pivot_usb_root
index c8572a35f..1c9be97ca 100644
--- a/package/block-extroot/files/60_pivot_usb_root
+++ b/package/block-extroot/files/60_pivot_usb_root
@@ -10,7 +10,7 @@ external_root_pivot() {
 	check_skip || [ "$pi_extroot_mount_success" != "true" ] || {
 		echo "switching to external rootfs"
 		if [ "$ER_IS_SQUASHFS" = "true" ]; then
-			umount /jffs
+			umount /tmp/overlay
 		fi
 		mount -o remount,ro / && fopivot /overlay /rom && pi_mount_skip_next=true
 	}
diff --git a/package/opkg/files/opkg.conf b/package/opkg/files/opkg.conf
index fb61d7a47..0e85936ba 100644
--- a/package/opkg/files/opkg.conf
+++ b/package/opkg/files/opkg.conf
@@ -2,4 +2,4 @@ src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$S/packages
 dest root /
 dest ram /tmp
 lists_dir ext /var/opkg-lists
-option overlay_root /jffs
+option overlay_root /overlay
-- 
2.20.1