From a20af599b866e615b8cd52fee0f604b43b95a6d8 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 1 Sep 2008 11:03:51 +0000
Subject: [PATCH] install a symlink to the correct version of find in
 $(STAGING_DIR_HOST)/bin

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12451 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 tools/Makefile | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/tools/Makefile b/tools/Makefile
index 3cfbb8bbd..989f3f097 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -26,8 +26,11 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
 	$(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
 	touch $@
 
-$(curdir)//prepare = $(STAGING_DIR)/.prepared
-$(curdir)//compile = $(STAGING_DIR)/.prepared
+$(STAGING_DIR_HOST)/bin/find:
+	[ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
-- 
2.20.1