From a4d094be2ac657698039b16163822b8ccd32f0d9 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 16 Nov 2007 03:10:40 +0000
Subject: [PATCH] add git checkout support

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9553 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/download.mk     | 20 ++++++++++++++++++--
 include/prereq-build.mk | 12 ++++++++++++
 2 files changed, 30 insertions(+), 2 deletions(-)

diff --git a/include/download.mk b/include/download.mk
index 386624280..3c7cb7e77 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -46,7 +46,7 @@ endef
 
 define DownloadMethod/svn
 	$(call wrap_mirror, \
-		echo "Checking out files from svn repository..."; \
+		echo "Checking out files from the svn repository..."; \
 		mkdir -p $(TMP_DIR)/dl && \
 		cd $(TMP_DIR)/dl && \
 		rm -rf $(SUBDIR) && \
@@ -59,8 +59,24 @@ define DownloadMethod/svn
 	)
 endef
 
+define DownloadMethod/git
+	$(call wrap_mirror, \
+		echo "Checking out files from the git repository..."; \
+		mkdir -p $(TMP_DIR)/dl && \
+		cd $(TMP_DIR)/dl && \
+		rm -rf $(SUBDIR) && \
+		[ \! -d $(SUBDIR) ] && \
+		git-clone $(URL) $(SUBDIR) && \
+		(cd $(SUBDIR) && git-checkout $(VERSION)) && \
+		echo "Packing checkout..." && \
+		rm -rf $(SUBDIR)/.git && \
+		$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+		mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+	)
+endef
+
 Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
 
 define Download/Defaults
   URL:=
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c31020c32..9b77a1baf 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -119,6 +119,18 @@ $(eval $(call Require,gnutar, \
 	Please install GNU tar. \
 ))
 
+define Require/git
+	which git-clone
+endef
+
+$(eval $(call Require,git, \
+	Please install git. \
+))
+
+$(eval $(call RequireCommand,svn, \
+	Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
 	Please install GNU autoconf. \
 ))
-- 
2.20.1