From ade52e08f778b1b5dc673b65d416ec517654ca57 Mon Sep 17 00:00:00 2001
From: hauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 18 Aug 2011 12:06:17 +0000
Subject: [PATCH] gcc: rename linaro to 4.5-linaro

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28038 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 toolchain/gcc/Config.in      |  4 ++--
 toolchain/gcc/Config.version | 12 ++++++------
 toolchain/gcc/common.mk      |  2 +-
 3 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 24885d498..7725ddebb 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -3,7 +3,7 @@
 choice
 	prompt "GCC compiler Version" if TOOLCHAINOPTS
 	default GCC_VERSION_4_4_6 if GCC_DEFAULT_VERSION_4_4_6
-	default GCC_VERSION_LINARO
+	default GCC_VERSION_4_5_LINARO
 	help
 	  Select the version of gcc you wish to use.
 
@@ -14,7 +14,7 @@ choice
 	config GCC_VERSION_4_6_1
 		bool "gcc 4.6.1"
 
-	config GCC_VERSION_LINARO
+	config GCC_VERSION_4_5_LINARO
 		bool "gcc 4.5.x with Linaro enhancements"
 
 	config GCC_VERSION_LLVM
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 46da90070..aee7748f2 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -6,7 +6,7 @@ config GCC_DEFAULT_VERSION_4_4_6
 	default y if (avr32 || ubicom32)
 	bool
 
-config GCC_DEFAULT_VERSION_LINARO
+config GCC_DEFAULT_VERSION_4_5_LINARO
 	default y if !(GCC_DEFAULT_VERSION)
 	bool
 
@@ -15,9 +15,9 @@ config GCC_VERSION
 	string
 	default "4.4.6"	    if GCC_VERSION_4_4_6
 	default "4.6.1"	    if GCC_VERSION_4_6_1
-	default "linaro"    if GCC_VERSION_LINARO
+	default "4.5-linaro"    if GCC_VERSION_4_5_LINARO
 	default "llvm"	    if GCC_VERSION_LLVM
-	default "linaro"
+	default "4.5-linaro"
 
 config GCC_VERSION_4_4
 	bool
@@ -25,7 +25,7 @@ config GCC_VERSION_4_4
 
 config GCC_VERSION_4_5
 	bool
-	default y       if GCC_VERSION_LINARO
+	default y       if GCC_VERSION_4_5_LINARO
 
 config GCC_VERSION_4_6
 	bool
@@ -37,8 +37,8 @@ if !TOOLCHAINOPTS
 		default y if GCC_DEFAULT_VERSION_4_4_6
 		bool
 
-	config GCC_VERSION_LINARO
-		default y if GCC_DEFAULT_VERSION_LINARO
+	config GCC_VERSION_4_5_LINARO
+		default y if GCC_DEFAULT_VERSION_4_5_LINARO
 		bool
 
 endif
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index d2177c546..32f2b2b0b 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -36,7 +36,7 @@ ifdef CONFIG_GCC_VERSION_LLVM
   PKG_SOURCE_SUBDIR:=$(GCC_DIR)
   HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
 else
-ifeq ($(CONFIG_GCC_VERSION),"linaro")
+ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
     PKG_REV:=4.5-2011.06-0
     PKG_VERSION:=4.5.4
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/$(PKG_REV)/+download/
-- 
2.20.1