From b15366186d330d7581ececb5401693674d4ec5e6 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 29 Sep 2007 00:25:38 +0000
Subject: [PATCH] proper series file support for regular packages

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9059 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/quilt.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/include/quilt.mk b/include/quilt.mk
index 4dce2a6d8..c156d3062 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -44,7 +44,12 @@ ifneq ($(QUILT),)
 else
   define Build/Patch/Default
 	@if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
-		$(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+		if [ -f $(PATCH_DIR)/series ]; then \
+			grep -vE '^#' $(PATCH_DIR)/series | xargs -n1 \
+				$(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+		else \
+			$(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+		fi; \
 	fi
   endef
 endif
-- 
2.20.1