From ba41f912a98d80538f9f8ceff8a39b663f9e0819 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 30 Sep 2011 12:55:30 +0000
Subject: [PATCH] [package] add kmod-hwmon-lm95241

This allows building the module for the national lm95241 i2c temperature sensor.

Signed-off-by: Daniel Golle <dgolle@allnet.de>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28335 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/kernel/modules/hwmon.mk | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index ebbe7cfab..57dd5684c 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -89,6 +89,20 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm90))
 
+define KernelPackage/hwmon-lm95241
+  TITLE:=LM95241 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM95241
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm95241.ko
+  AUTOLOAD:=$(call AutoLoad,60,lm95241)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm95241/description
+ Kernel module for LM95241 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm95241))
+
 
 define KernelPackage/hwmon-pc87360
   TITLE:=PC87360 monitoring support
-- 
2.20.1