From cade7d9b1450b874cb558e65797eb07cab799a4f Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 14 Aug 2005 06:41:39 +0000
Subject: [PATCH] add libxml2 package

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1657 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/Config.in                    |   1 +
 openwrt/package/Makefile                     |   2 +
 openwrt/package/libxml2/Config.in            |  11 ++
 openwrt/package/libxml2/Makefile             | 122 +++++++++++++++++++
 openwrt/package/libxml2/ipkg/libxml2.control |   9 ++
 5 files changed, 145 insertions(+)
 create mode 100644 openwrt/package/libxml2/Config.in
 create mode 100644 openwrt/package/libxml2/Makefile
 create mode 100644 openwrt/package/libxml2/ipkg/libxml2.control

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 1364efd99..96d6f154b 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -145,6 +145,7 @@ source "package/sqlite/Config.in" # libsqlite
 source "package/sqlite2/Config.in" # libsqlite2
 source "package/libtasn1/Config.in"
 source "package/libusb/Config.in"
+source "package/libxml2/Config.in"
 source "package/uclibc++/Config.in"
 source "package/zlib/Config.in"
 source "package/irssi/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index fd06b9f58..2c7bc2843 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -72,6 +72,7 @@ package-$(BR2_PACKAGE_LIBPTHREAD) += libpthread
 package-$(BR2_PACKAGE_LIBTASN1) += libtasn1
 package-$(BR2_PACKAGE_LIBTOOL) += libtool
 package-$(BR2_PACKAGE_LIBUSB) += libusb
+package-$(BR2_PACKAGE_LIBXML2) += libxml2
 package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
 package-$(BR2_PACKAGE_LUA) += lua
@@ -187,6 +188,7 @@ libgcrypt-compile: libgpg-error-compile
 libgd-compile: libpng-compile
 libnet-compile: libpcap-compile
 libnids-compile: libnet-compile
+libxml2-compile: zlib-compile
 lighttpd-compile: openssl-compile pcre-compile
 mini_httpd-compile: matrixssl-compile
 mysql-compile: ncurses-compile zlib-compile
diff --git a/openwrt/package/libxml2/Config.in b/openwrt/package/libxml2/Config.in
new file mode 100644
index 000000000..3230b2f54
--- /dev/null
+++ b/openwrt/package/libxml2/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBXML2
+	tristate "libxml2 - Gnome XML library"
+#	default m if CONFIG_DEVEL
+	default n
+	select BR2_PACKAGE_LIBPTHREAD
+	select BR2_PACKAGE_ZLIB
+	help
+	  A library for manipulating XML and HTML resources.
+	  
+	  http://xmlsoft.org/
+	  
diff --git a/openwrt/package/libxml2/Makefile b/openwrt/package/libxml2/Makefile
new file mode 100644
index 000000000..a3c6e00f0
--- /dev/null
+++ b/openwrt/package/libxml2/Makefile
@@ -0,0 +1,122 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libxml2
+PKG_VERSION:=2.6.20
+PKG_RELEASE:=1
+PKG_MD5SUM:=8f0b3ce721bda11401e656b90ba4e78c
+
+PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
+	ftp://fr.rpmfind.net/pub/libxml/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBXML2,libxml2,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+		$(TARGET_CONFIGURE_OPTS) \
+		CFLAGS="$(strip $(TARGET_CFLAGS))" \
+		CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+		LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+		./configure \
+			--target=$(GNU_TARGET_NAME) \
+			--host=$(GNU_TARGET_NAME) \
+			--build=$(GNU_HOST_NAME) \
+			--program-prefix="" \
+			--program-suffix="" \
+			--prefix=/usr \
+			--exec-prefix=/usr \
+			--bindir=/usr/bin \
+			--datadir=/usr/share \
+			--includedir=/usr/include \
+			--infodir=/usr/share/info \
+			--libdir=/usr/lib \
+			--libexecdir=/usr/lib \
+			--localstatedir=/var \
+			--mandir=/usr/share/man \
+			--sbindir=/usr/sbin \
+			--sysconfdir=/etc \
+			$(DISABLE_LARGEFILE) \
+			$(DISABLE_NLS) \
+			--enable-shared \
+			--enable-static \
+			--disable-rpath \
+			--with-gnu-ld \
+			--without-c14n \
+			--without-catalog \
+			--without-debug \
+			--without-docbook \
+			--without-html \
+			--without-ftp \
+			--without-http \
+			--without-iconv \
+			--without-iso8859x \
+			--without-legacy \
+			--with-output \
+			--without-pattern \
+			--without-push \
+			--without-python \
+			--with-reader \
+			--without-readline \
+			--without-regexps \
+			--with-sax1 \
+			--with-schemas \
+			--with-threads \
+			--with-tree \
+			--with-valid \
+			--with-writer \
+			--without-xinclude \
+			--without-xpath \
+			--without-xptr \
+			--with-zlib \
+	);
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	rm -rf $(PKG_INSTALL_DIR)
+	mkdir -p $(PKG_INSTALL_DIR)
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		DESTDIR="$(PKG_INSTALL_DIR)" \
+		all install
+	touch $@
+
+$(IPKG_LIBXML2):
+	install -m0755 -d $(IDIR_LIBXML2)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* $(IDIR_LIBXML2)/usr/lib/
+	$(RSTRIP) $(IDIR_LIBXML2)
+	$(IPKG_BUILD) $(IDIR_LIBXML2) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libxml2.so: $(PKG_BUILD_DIR)/.built
+	mkdir -p $(STAGING_DIR)/usr/bin
+	cp -fpR $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(STAGING_DIR)/usr/bin/
+	mkdir -p $(STAGING_DIR)/usr/include
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/libxml2 $(STAGING_DIR)/usr/include/
+	mkdir -p $(STAGING_DIR)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libxml2.{a,so*} $(STAGING_DIR)/usr/lib/
+	mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+	touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libxml2.so
+
+uninstall-dev:
+	rm -rf \
+		$(STAGING_DIR)/usr/bin/libxml2-config \
+		$(STAGING_DIR)/usr/include/libxml2 \
+		$(STAGING_DIR)/usr/lib/libxml2.{a,so*} \
+		$(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc \
+
+compile: install-dev
+clean: uninstall-dev
+
+mostlyclean:
+	make -C $(PKG_BUILD_DIR) clean
+	rm $(PKG_BUILD_DIR)/.built
+
diff --git a/openwrt/package/libxml2/ipkg/libxml2.control b/openwrt/package/libxml2/ipkg/libxml2.control
new file mode 100644
index 000000000..383a4d0e3
--- /dev/null
+++ b/openwrt/package/libxml2/ipkg/libxml2.control
@@ -0,0 +1,9 @@
+Package: libxml2
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/libxml2/
+Description: Gnome XML library
+Depends: zlib
-- 
2.20.1