From d7b52bb02bcea490585f29b06f1a2e33060cf052 Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 30 Aug 2005 07:49:06 +0000
Subject: [PATCH] update fuse to v2.3.0 (thanks to Christian Magnusson)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1791 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/fuse/Makefile                 | 80 ++++++++++---------
 openwrt/package/fuse/ipkg/fuse-utils.control  |  8 +-
 openwrt/package/fuse/ipkg/libfuse.control     |  8 +-
 .../package/fuse/patches/101-kmod-build.patch | 59 --------------
 openwrt/target/linux/package/fuse/Makefile    |  4 +-
 .../linux/package/fuse/ipkg/kmod-fuse.control |  6 +-
 .../package/fuse/patches/101-kmod_build.patch |  7 +-
 7 files changed, 58 insertions(+), 114 deletions(-)
 delete mode 100644 openwrt/package/fuse/patches/101-kmod-build.patch

diff --git a/openwrt/package/fuse/Makefile b/openwrt/package/fuse/Makefile
index 30b03a8d9..35d096a5a 100644
--- a/openwrt/package/fuse/Makefile
+++ b/openwrt/package/fuse/Makefile
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fuse
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.3.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=250d89b9c7b6ecf531df60c67f75737d
+PKG_MD5SUM:=0bee98df5b2a29841f75fc188975eabc
 
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -30,33 +30,34 @@ $(PKG_BUILD_DIR)/.configured:
 		$(TARGET_CONFIGURE_OPTS) \
 		CFLAGS="$(TARGET_CFLAGS)" \
 		./configure \
-		  --target=$(GNU_TARGET_NAME) \
-		  --host=$(GNU_TARGET_NAME) \
-		  --build=$(GNU_HOST_NAME) \
-		  --program-prefix="" \
-		  --program-suffix="" \
-		  --prefix=/usr \
-		  --exec-prefix=/usr \
-		  --bindir=/usr/bin \
-		  --datadir=/usr/share \
-		  --includedir=/usr/include \
-		  --infodir=/usr/share/info \
-		  --libdir=/usr/lib \
-		  --libexecdir=/usr/lib \
-		  --localstatedir=/var \
-		  --mandir=/usr/share/man \
-		  --sbindir=/usr/sbin \
-		  --sysconfdir=/etc \
-		  $(DISABLE_LARGEFILE) \
-		  $(DISABLE_NLS) \
-		  --enable-shared \
-		  --enable-static \
-		  --disable-kernel-module \
-		  --enable-lib \
-		  --enable-util \
-		  --disable-example \
-		  --disable-auto-modprobe \
-		  --with-kernel=$(LINUX_DIR) \
+			--target=$(GNU_TARGET_NAME) \
+			--host=$(GNU_TARGET_NAME) \
+			--build=$(GNU_HOST_NAME) \
+			--program-prefix="" \
+			--program-suffix="" \
+			--prefix=/usr \
+			--exec-prefix=/usr \
+			--bindir=/usr/bin \
+			--datadir=/usr/share \
+			--includedir=/usr/include \
+			--infodir=/usr/share/info \
+			--libdir=/usr/lib \
+			--libexecdir=/usr/lib \
+			--localstatedir=/var \
+			--mandir=/usr/share/man \
+			--sbindir=/usr/sbin \
+			--sysconfdir=/etc \
+			$(DISABLE_LARGEFILE) \
+			$(DISABLE_NLS) \
+			--enable-shared \
+			--enable-static \
+			--disable-rpath \
+			--disable-kernel-module \
+			--enable-lib \
+			--enable-util \
+			--disable-example \
+			--disable-auto-modprobe \
+			--with-kernel=$(LINUX_DIR) \
 	);
 	touch $@
 
@@ -71,7 +72,6 @@ $(PKG_BUILD_DIR)/.built:
 $(IPKG_LIBFUSE):
 	mkdir -p $(IDIR_LIBFUSE)/usr/lib
 	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfuse.so.* $(IDIR_LIBFUSE)/usr/lib/
-	chmod 0644 $(IDIR_LIBFUSE)/usr/lib/lib*.so*
 	$(RSTRIP) $(IDIR_LIBFUSE)
 	$(IPKG_BUILD) $(IDIR_LIBFUSE) $(PACKAGE_DIR)
 
@@ -83,17 +83,25 @@ $(IPKG_FUSE_UTILS):
 
 $(STAGING_DIR)/usr/lib/libfuse.so: $(PKG_BUILD_DIR)/.built
 	mkdir -p $(STAGING_DIR)/usr/include
-	cp -fpR $(PKG_INSTALL_DIR)/usr/include/fuse* $(STAGING_DIR)/usr/include/
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/fuse $(STAGING_DIR)/usr/include/
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/fuse.h $(STAGING_DIR)/usr/include/
+	mkdir -p $(STAGING_DIR)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfuse.a $(STAGING_DIR)/usr/lib/
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfuse.so* $(STAGING_DIR)/usr/lib/
 	mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfuse.{a,so*} $(STAGING_DIR)/usr/lib/
 	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/fuse.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+	$(SED) 's,-I$${includedir}/fuse,,g' $(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc
+	$(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc
 	
 install-dev: $(STAGING_DIR)/usr/lib/libfuse.so
 
 uninstall-dev:
-	rm -rf $(STAGING_DIR)/usr/include/fuse*
-	rm -rf $(STAGING_DIR)/usr/lib/libfuse.{a,so*}
-	rm -rf $(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc
+	rm -rf \
+		$(STAGING_DIR)/usr/include/fuse \
+		$(STAGING_DIR)/usr/include/fuse.h \
+		$(STAGING_DIR)/usr/lib/libfuse.a \
+		$(STAGING_DIR)/usr/lib/libfuse.so* \
+		$(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc \
 
-install: install-dev
+compile: install-dev
 clean: uninstall-dev
diff --git a/openwrt/package/fuse/ipkg/fuse-utils.control b/openwrt/package/fuse/ipkg/fuse-utils.control
index 4a1b8691c..f95fe5a6b 100644
--- a/openwrt/package/fuse/ipkg/fuse-utils.control
+++ b/openwrt/package/fuse/ipkg/fuse-utils.control
@@ -1,9 +1,7 @@
 Package: fuse-utils
 Priority: optional
 Section: admin
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/fuse2/
-Description: Filesystem in Userspace (utilities)
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>, Christian Magnusson <christian.magnusson@runaware.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/fuse/
 Depends: kmod-fuse
+Description: Filesystem in Userspace (utilities)
diff --git a/openwrt/package/fuse/ipkg/libfuse.control b/openwrt/package/fuse/ipkg/libfuse.control
index b1d113fc3..c5f7fc9f6 100644
--- a/openwrt/package/fuse/ipkg/libfuse.control
+++ b/openwrt/package/fuse/ipkg/libfuse.control
@@ -1,9 +1,7 @@
 Package: libfuse
 Priority: optional
 Section: libs
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/fuse2/
-Description: Filesystem in Userspace (library)
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>, Christian Magnusson <christian.magnusson@runaware.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/fuse/
 Depends: libpthread
+Description: Filesystem in Userspace (library)
diff --git a/openwrt/package/fuse/patches/101-kmod-build.patch b/openwrt/package/fuse/patches/101-kmod-build.patch
deleted file mode 100644
index 5f4bee745..000000000
--- a/openwrt/package/fuse/patches/101-kmod-build.patch
+++ /dev/null
@@ -1,59 +0,0 @@
---- fuse-2.2.1-orig/kernel/Makefile.in	2005-01-09 13:07:00.000000000 +0100
-+++ fuse-2.2.1-1/kernel/Makefile.in	2005-04-06 14:48:59.000000000 +0200
-@@ -31,11 +31,11 @@
- install-y: all
- 	$(mkdir_p) $(DESTDIR)$(fusemoduledir)
- 	$(INSTALL) -m 644 $(fusemodule) $(DESTDIR)$(fusemoduledir)/$(fusemodule)
--	-/sbin/depmod -a
-+#	-/sbin/depmod -a
- 
- uninstall-y:
- 	rm -f $(DESTDIR)$(fusemoduledir)/$(fusemodule)
--	-/sbin/depmod -a
-+#	-/sbin/depmod -a
- 
- clean:
- 	-rm -f $(fusemodule) *.o .*.cmd *.mod.c *.ko *.s */*.o
-@@ -54,23 +54,8 @@
- 
- ifeq ($(majver), 2.4)
- 
--CC = gcc
--LD = ld
--CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe 
--CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
--
- fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
- 
--SUFFIXES = .c .o .s
--
--all-spec: fuse.o
--
--.c.o:
--	$(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
--
--fuse.o: $(fuse_objs)
--	$(LD) -r -o fuse.o $(fuse_objs)
--
- fuse_headers = fuse_i.h fuse_kernel.h
- 
- dev.o: $(fuse_headers)
-@@ -78,6 +63,18 @@
- file.o: $(fuse_headers)
- inode.o: $(fuse_headers)
- 
-+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
-+
-+O_TARGET := fuse.o
-+
-+obj-y := $(fuse_objs) 
-+obj-m := $(O_TARGET)
-+
-+-include $(TOPDIR)/Rules.make
-+
-+all-spec:
-+	$(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
-+
- else
- 
- EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
diff --git a/openwrt/target/linux/package/fuse/Makefile b/openwrt/target/linux/package/fuse/Makefile
index 950a9d20c..d4171d117 100644
--- a/openwrt/target/linux/package/fuse/Makefile
+++ b/openwrt/target/linux/package/fuse/Makefile
@@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
 include ../../rules.mk
 
 PKG_NAME:=fuse
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.3.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=250d89b9c7b6ecf531df60c67f75737d
+PKG_MD5SUM:=0bee98df5b2a29841f75fc188975eabc
 
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/openwrt/target/linux/package/fuse/ipkg/kmod-fuse.control b/openwrt/target/linux/package/fuse/ipkg/kmod-fuse.control
index 9d2e919c7..77019be2c 100644
--- a/openwrt/target/linux/package/fuse/ipkg/kmod-fuse.control
+++ b/openwrt/target/linux/package/fuse/ipkg/kmod-fuse.control
@@ -1,8 +1,6 @@
 Package: kmod-fuse
 Priority: optional
 Section: kernel
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/fuse2/
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>, Christian Magnusson <christian.magnusson@runaware.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/target\linux\package/fuse/
 Description: Filesystem in Userspace (kernel module)
diff --git a/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch b/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
index 5f4bee745..9d4a666e2 100644
--- a/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
+++ b/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
@@ -1,5 +1,6 @@
---- fuse-2.2.1-orig/kernel/Makefile.in	2005-01-09 13:07:00.000000000 +0100
-+++ fuse-2.2.1-1/kernel/Makefile.in	2005-04-06 14:48:59.000000000 +0200
+diff -ruw fuse-2.3.0.org/kernel/Makefile.in fuse-2.3.0/kernel/Makefile.in
+--- fuse-2.3.0.org/kernel/Makefile.in	2005-04-21 21:00:39.000000000 +0200
++++ fuse-2.3.0/kernel/Makefile.in	2005-08-26 09:13:41.000000000 +0200
 @@ -31,11 +31,11 @@
  install-y: all
  	$(mkdir_p) $(DESTDIR)$(fusemoduledir)
@@ -20,7 +21,7 @@
  
 -CC = gcc
 -LD = ld
--CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe 
+-CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe -msoft-float
 -CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
 -
  fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
-- 
2.20.1