From df70463b99a6c9d5ef3879f0cf58dea99cac59ba Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 23 Nov 2006 10:15:19 +0000
Subject: [PATCH] Add ethernet bonding support for x86 (#856)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5626 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/kernel/modules/network.mk | 11 +++++++++++
 target/linux/x86-2.6/config       |  2 +-
 2 files changed, 12 insertions(+), 1 deletion(-)

diff --git a/package/kernel/modules/network.mk b/package/kernel/modules/network.mk
index c377c309e..8bc216eda 100644
--- a/package/kernel/modules/network.mk
+++ b/package/kernel/modules/network.mk
@@ -34,6 +34,17 @@ define KernelPackage/atmtcp
 endef
 $(eval $(call KernelPackage,atmtcp))
 
+define KernelPackage/bonding
+  TITLE:=Ethernet bonding driver
+  DESCRIPTION:= \
+    Kernel module for NIC bonding.
+  DEPENDS:=@LINUX_2_6_X86
+  FILES:=$(MODULES_DIR)/kernel/drivers/net/bonding/bonding.$(LINUX_KMOD_SUFFIX)
+  KCONFIG:=$(CONFIG_BONDING)
+  SUBMENU:=$(NSMENU)
+  AUTOLOAD:=$(call AutoLoad,40,bonding)
+endef
+$(eval $(call KernelPackage,bonding))
 
 define KernelPackage/ipip
   TITLE:=IP in IP encapsulation support
diff --git a/target/linux/x86-2.6/config b/target/linux/x86-2.6/config
index cd1893ec7..d186327f6 100644
--- a/target/linux/x86-2.6/config
+++ b/target/linux/x86-2.6/config
@@ -962,7 +962,7 @@ CONFIG_BLK_DEV_SD=m
 #
 CONFIG_NETDEVICES=y
 # CONFIG_DUMMY is not set
-# CONFIG_BONDING is not set
+CONFIG_BONDING=m
 # CONFIG_EQUALIZER is not set
 CONFIG_IMQ=m
 # CONFIG_IMQ_BEHAVIOR_AA is not set
-- 
2.20.1