From e4c6bd13192fd179bd808d36bbbd3462a8b029e0 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 29 Mar 2010 03:38:40 +0000
Subject: [PATCH] add a new helper macro to deal with conditional ./configure
 flags

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20570 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/autotools.mk | 1 +
 1 file changed, 1 insertion(+)

diff --git a/include/autotools.mk b/include/autotools.mk
index e1535d0b1..c941a4949 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -32,6 +32,7 @@ update_libtool_ucxx = \
 	) \
 	$(call update_libtool_common)
 
+autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
 # prevent libtool from linking against host development libraries
 define libtool_fixup_libdir
-- 
2.20.1